S600 ViRGE/DX is not supplied in XServer?

S600 ViRGE/DX is not supplied in XServer?

Post by Frank Hofman » Wed, 20 Aug 1997 04:00:00



:       Recently, I bought a display card with S3 ViRGE/DX chip.

: When I try to "startx", there is an error message:

:       (--) S3: Unknown S3 chipset: chip_id = 0x1e1 rev. 11

: Please tell me how to do with it?

Get XFree86 3.3.1 (you really need that !!!) and use the XF86_SVGA server.
It contains a driver module for any Virge[/{VX,DX,GX[2]}] chipset. The
S3 server can't handle the Virge series. There's also a special S3V server
but that's to become obsolete - development and further enhancements are
done in the XAA driver module for the SVGA server.

Bye,
Frank Hofmann

 ... remove NOSPAM!!_ from email adress to reply ...

 
 
 

S600 ViRGE/DX is not supplied in XServer?

Post by Yi-Jong Y » Wed, 20 Aug 1997 04:00:00


        Recently, I bought a display card with S3 ViRGE/DX chip.

When I try to "startx", there is an error message:

        (--) S3: Unknown S3 chipset: chip_id = 0x1e1 rev. 11

Please tell me how to do with it?

--


 
 
 

S600 ViRGE/DX is not supplied in XServer?

Post by Christopher B. Brow » Thu, 21 Aug 1997 04:00:00


On 19 Aug 1997 05:46:47 GMT, Yi-Jong Yeh

Quote:>    Recently, I bought a display card with S3 ViRGE/DX chip.
>When I try to "startx", there is an error message:
>    (--) S3: Unknown S3 chipset: chip_id = 0x1e1 rev. 11
>Please tell me how to do with it?

The S3 X server does *NOT* support the S3 ViRGE chipsets.  (Note
the plural; there's DX, GX, amongst other ViRGE sets...

You need to get the S3V server, which *does* support S3 ViRGE.

Or, new with XFree86 3.3, the SVGA server includes S3V support.
It is probably preferable to use the SVGA server, as most of the
XAA (Extended Acceleration Architecture) support that provides
faster server speed will be going into the SVGA version, and not
the S3V version...

XFree86 Version 3.3.1 was just announced, which apparently fixes
some S3V bugs, so that very likely is what will "hit the spot."

Depending on your favored distribution, you may wish to
consult ftp.redhat.com or ftp.debian.org as alternatives to
the central web site, http://www.xfree86.org...
--

PGP Fingerprint: 10 5A 20 3C 39 5A D3 12  D9 54 26 22 FF 1F E9 16
URL: <http://www.hex.net/~cbbrowne/>
Bill Gates to his broker: "You idiot, I said $150 million on **SNAPPLE**!!!"

 
 
 

1. Virge/DX - Xserver S3V

I successfully installed Redhat's version 5.2 of Linux on Intel box
(pentium 166).
The original video card was a STB Horizon 64 and it was lousy as a
Xwindows platform. So I installed another video card - STB Nitro. I then
used  Xconfigurator and it probed and found the card as follows :

Virdge/DX or /GX
Xserver: S3V

Once that above description is displayed it does not continue with the
other configuration menus and goes back to the command prompt with the
error :

server does not exist, can't continue
tried to use ../../usr/X11R6/bin/XF86_S3V

I tried to find the file XF86_S3V in all directories, but was unable to
find it; only a XF86_SVGA file from the previous setup.

By the way, the monitor is a Sampo Alphascan 17, and I can still run
Xwindows but it is at 320X200 and the icons, etc. are huge and
distorted.

What am I missing; I thought installing a new card and re-running
Xconfigurator was the extent of what needed to be done ??

Thanks in advance.

Greg

2. metaroot problem

3. S3 ViRGE/DX and S3 ViRGE/GX: is one better than the other?

4. Solved: Problems logging in at ISP

5. S3 ViRGE/DX not found

6. Logging off locks up machine when using XDM

7. glquake with a S3 virge/dx card?

8. problem with NIS, +@netgroup in passwd file

9. S3 ViRGE DX Problems

10. s3 virge Dx chipset& redhat

11. S3 Virge DX and no acceleration

12. ViRGE /DX when?

13. Textmode corruption with S3 ViRGE/DX X server