accelerated x 2.1.1 errors

accelerated x 2.1.1 errors

Post by Shawn Toliva » Tue, 09 Dec 1997 04:00:00



I have just upgraded my system to slackware 3.3 and now I get the error,
Can't open fixed fonts, unable to set fonts path. When I start X
Windows. The path is set to

/usr/X11/lib/X11/fonts/75dpi/
which is the way that it was origanaly set up, but now it won't work.
Any info would greatly be appriciated. Thank you
                        Shawn

 
 
 

accelerated x 2.1.1 errors

Post by Jim Knob » Tue, 09 Dec 1997 04:00:00



: I have just upgraded my system to slackware 3.3 and now I get the error,
: Can't open fixed fonts, unable to set fonts path. When I start X
: Windows. The path is set to
:
: /usr/X11/lib/X11/fonts/75dpi/
: which is the way that it was origanaly set up, but now it won't work.
: Any info would greatly be appriciated. Thank you
:                       Shawn

What version of XFree86 are you using?  XFree86-3.3 changed to gzipped
fonts (.gz) by default instead of compressed ones (.Z).  Accel-X may
not be able to read gzipped fonts.

--jim

--
%%%%%%%%%%%% jim knoble %%%%%%%% jmknoble-at-pobox-dot-com %%%%%%%%%%%%%
+----------------------------------------------------------------------+
| note: my return email address is not valid, specifically in order to |
| avoid detection by scanning robots who gather addresses for bulk     |

+----------------------------------------------------------------------+
| senders of unsolicited adverti*ts will be charged US$500/message |
+----------------------------------------------------------------------+  

 
 
 

accelerated x 2.1.1 errors

Post by Jason A. Marshal » Tue, 09 Dec 1997 04:00:00


if you've upgraded to 3.3.1 the the gzipped fonts aren't supported by
accelerated x and you need to unzip them then recompress them....

cd /usr/X11R6/lib/X11/fonts
gunzip 75dpi/*
compress 75dpi/*.pcf
mkfontdir 75dpi

do this for each directory with gzipped fonts in it and your problem
should go away...

--
Jason A. Marshall
Chemical Physics Dept. / WSU

 
 
 

accelerated x 2.1.1 errors

Post by Jon Truls » Tue, 16 Dec 1997 04:00:00



Quote:> I have just upgraded my system to slackware 3.3 and now I get the error,
> Can't open fixed fonts, unable to set fonts path. When I start X
> Windows. The path is set to
> /usr/X11/lib/X11/fonts/75dpi/
> which is the way that it was origanaly set up, but now it won't work.
> Any info would greatly be appriciated. Thank you
>                    Shawn

        Hmmm... Xf 3.3 started using gzipped fonts. Accelx 4.1 now
supports them too.  What you could do is convert all of the gzipped
versions into compressed (.Z) versions.  You can do this yourself or grab
the conversion script I wrote sometime ago for just this purpose off of

--

Xi Graphics,   http://www.xig.com
ID: 1A9A2B09, FP: C23F328A721264E7 B6188192EC733962

#include <stddisclaimer.h>
FREE MARS!

 
 
 

1. Accelerated X problems from an Accelerated X newbie

Hi folks,

I am very much the newbie at Accelerated X (I have used MetroX for
most of my X needs)

In any case, here is my problem:

Just reinstalled my system:  RedHat 5.1

installed Accelerated X 4.1

getting the following errors

Example:

wmaker:  error in loading shared libraries
/usr/X11R6/lib/libXext.so.6: undefined symbol: _Xglobal_lock

wmaker never actually starts, just dumps.  I relinked libXext.so.6 to
libXext.so.6.1 (it was linked to libXext.so.6.2).  I was hoping this
would at least allow me to start window maker, which it did.  The
problem though, was that no applications would work.  Each would give
me some other library error (and attempting to relink them did no
help).

kernel 2.0.35

This occurs with:
fvwm
enlightenment
window maker (hey i even remembered the space)

can someone please give me some hint as to what may be the issue?
This has been ongoing for most of the weekend.

thanks a ton

[Sn]

2. Upgrading RH5.2 -> RH6.0

3. Accelerated X socket error

4. Adding Programs to the Desktop Menu

5. Link errors with Accelerated-X

6. Matsonic Mouse Problems-Redhat

7. Does Linux support ATI Mach64 card in non-accelerated mode

8. question on mmap(2)

9. Does Accelerated-X really help?

10. Does maXimum cde include Accelerated-X

11. Is ATI ULTRA PRO an accelerated card?

12. XFree86 1.3 - No accelerated Chipsets

13. HW accelerated OpenGL on FreeBSD