gcc 2.95... installation problem

gcc 2.95... installation problem

Post by 172.173.85.96 [Anshul Kothari » Tue, 17 Apr 2001 16:30:26



Hi,

I am trying to install gcc-2.95 in my redhat 6.1 system. When i try to do rpm -Uhv gcc-2.96.rpm, it gives me an error saying that it needs cpp-2.96.

When I try to install cpp-2.96, I get the following errors:

# rpm -Uhv cpp-2.96~1.rpm

error: failed dependencies:
        cpp = 1.1.2 is needed by egcs-1.1.2-24
        cpp = 1.1.2 is needed by egcs-objc-1.1.2-24
        cpp = 1.1.2 is needed by egcs-c++-1.1.2-24

When I query the rpm database for the cpp and egcs installed. It gives me following output:

#rpm -q -a | grep cpp
cpp-1.1.2-24

#rpm -q -a | grep egcs
egcs-1.1.2-24
egcs-g77-1.1.2-24
egcs-objc-1.1.2-24
egcs-c++-1.1.2-24

It clearly shows that cpp-1.1.2 is already installed so why is cpp-2.96 not able to find it?

TIA,
anshul

==================================
Poster's IP address: 172.173.85.96
Posted via http://nodevice.com
Linux Programmer's Site

 
 
 

gcc 2.95... installation problem

Post by jw » Tue, 17 Apr 2001 20:39:41


On 16 Apr 2001 07:30:26 GMT, 172.173.85.96 [Anshul Kothari]

> Hi,

> I am trying to install gcc-2.95 in my redhat 6.1 system. When i try to do rpm -Uhv gcc-2.96.rpm, it gives me an error saying that it needs cpp-2.96.

This newsgroup is about X, not about gcc-installation. You should try
another newsgroup, as you are not likely to get any answers here. Short
tip: if you're sure, try --force.

Good luck,
Jurriaan

--
Whoever thought that one up should have his head examined. *y minstrels...
        Simon R Green - Blue Moon Rising
GNU/Linux 2.4.3-ac6 SMP/ReiserFS 2x1743 bogomips load av: 0.47 0.17 0.07

 
 
 

1. gcc 2.95... installation problem

Hi,

I am trying to install gcc-2.95 in my redhat 6.1 system. When i try to do rpm -Uhv gcc-2.96.rpm, it gives me an error saying that it needs cpp-2.96.

When I try to install cpp-2.96, I get the following errors:

# rpm -Uhv cpp-2.96~1.rpm

error: failed dependencies:
        cpp = 1.1.2 is needed by egcs-1.1.2-24
        cpp = 1.1.2 is needed by egcs-objc-1.1.2-24
        cpp = 1.1.2 is needed by egcs-c++-1.1.2-24

When I query the rpm database for the cpp and egcs installed. It gives me following output:

#rpm -q -a | grep cpp
cpp-1.1.2-24

#rpm -q -a | grep egcs
egcs-1.1.2-24
egcs-g77-1.1.2-24
egcs-objc-1.1.2-24
egcs-c++-1.1.2-24

It clearly shows that cpp-1.1.2 is already installed so why is cpp-2.96 not able to find it?

TIA,
anshul


==================================
Poster's IP address: 172.173.85.96
Posted via http://nodevice.com
Linux Programmer's Site

2. NCSA httpd 1.5.2 and POST caching problem.

3. Kernel compile problem with (P)GCC 2.95

4. sooner 2.4.21-pre8

5. link problem (gcc 2.95 on AIX 4.3.3)

6. kde konsole with TERM=xterm.. is this right setting?

7. Any interest in gcc 2.95* sparcv9 (64-bit) ?

8. fsetpos\fprintf in AIX\SUN

9. gcc 2.95 vs. 3.0

10. math.h of gcc 2.95/2.96 on redhat 7.3 platform

11. gcc 2.95, segfault when throwing exceptions (_eh_rtime_match)

12. Help with GCC 2.95 in Solaris 8

13. Core in 2nd map::insert STLport 4.5.0/ AIX 4.3.3 / gcc 2.95.x