can't find library 'libXaw.so.6

can't find library 'libXaw.so.6

Post by Matthew Ross Dav » Fri, 21 Jun 1996 04:00:00



Hi all,

I'm having a problem with X apps finding libXaw.so.6, when as far as I can
tell, it exists on my system!

For example, I downloaded xcalendar, and when I try to run the binary, I get:

   can't find library 'libXaw.so.6'

But if I look in /usr/X11/lib, I get:

   lrwxrwxrwx   libXaw.so -> libXaw.so.6.0
   lrwxrwxrwx   libXaw.so.6 -> libXaw.so.6.0
   -rwxr-xr-x   libXaw.so.6.0

So what is going on? ldconfig doesn't seem to solve the problem. I'm also
having the same difficulty with libXt.so.6.

Thanks for any help,

Matthew Ross Davis

 
 
 

can't find library 'libXaw.so.6

Post by Robert Benso » Sat, 22 Jun 1996 04:00:00



> Hi all,

> I'm having a problem with X apps finding libXaw.so.6, when as far as I can
> tell, it exists on my system!

> For example, I downloaded xcalendar, and when I try to run the binary, I get:

>    can't find library 'libXaw.so.6'

> But if I look in /usr/X11/lib, I get:

>    lrwxrwxrwx   libXaw.so -> libXaw.so.6.0
>    lrwxrwxrwx   libXaw.so.6 -> libXaw.so.6.0
>    -rwxr-xr-x   libXaw.so.6.0

> So what is going on? ldconfig doesn't seem to solve the problem. I'm also
> having the same difficulty with libXt.so.6.

> Thanks for any help,

> Matthew Ross Davis


Just a thought,
Is the /usr/X11 dir a sym. link to /usr/X11R6 ?
If not make the sym. link X11R6-->X11

Robert Benson.

 
 
 

can't find library 'libXaw.so.6

Post by Matthew Ross Dav » Sat, 22 Jun 1996 04:00:00


Quote:> Just a thought,
> Is the /usr/X11 dir a sym. link to /usr/X11R6 ?
> If not make the sym. link X11R6-->X11

Yup, it's already like that: X11 -> X11R6
 
 
 

can't find library 'libXaw.so.6

Post by Martin Etteldo » Sun, 14 Jul 1996 04:00:00



: Hi all,
:
: I'm having a problem with X apps finding libXaw.so.6, when as far as I can
: tell, it exists on my system!
:
: For example, I downloaded xcalendar, and when I try to run the binary, I get:
:
:    can't find library 'libXaw.so.6'
:
: But if I look in /usr/X11/lib, I get:
:
:    lrwxrwxrwx   libXaw.so -> libXaw.so.6.0
:    lrwxrwxrwx   libXaw.so.6 -> libXaw.so.6.0
:    -rwxr-xr-x   libXaw.so.6.0
:
: So what is going on? ldconfig doesn't seem to solve the problem. I'm also
: having the same difficulty with libXt.so.6.
:

Hiho Matthew,
        you should do a "ldd /path/to/the/executable/xcalendar" and
have a look at the output. The output tells you which libraries are
dynamical linked in the Program and where the Program tries to find
them.
If all seems allright (e.g.:

ldd /usr/local/X11R6/bin/xcalendar
        libXaw.so => /usr/X11R6/lib/libXaw.so.6.0
        .       .
        .       .
        .       .
        and so on...)

this Program may require ELF-Libs and is running on a a-out System
or vice versa.
In this case you may have to get the Source-Code and compile the
Program by yourself.

So long,
                        Martin.

 
 
 

1. Problem: "can't find library 'libXaw.so.6' ..

First of all, for reference sake, I'm running linux 2.0.21, with x3.1.2G ..

Now, my problem.. whenever I load up most *all* of the programs available in XWindows (xfm, color_xterm, etc), I get an error telling me that XWindows cannot find "libXaw.so.6", or "libX11.so.6" ..

Now, these files are in my /usr/X11/lib directory, and are found by ldconfig..


Thanks..

2. Lilo mount read-only

3. Error-> xterm: can't load library '//libXaw.so.3'

4. Emacs and xhost on ppc2000

5. XF86Setup: Can't load library 'libXaw.so.6'

6. recommended motherboards bsd5.0?

7. can't load library 'libXaw.so.6'

8. parallel port

9. SOLVED: Re: XF86Setup: Can't load library 'libXaw.so.6'

10. Troubles with ' libXaw3d ', can't load libXaw.so.6 ERROR - Please help!

11. 'can't load libXaw.so.6'

12. Troubles with ' libXaw3d ', can't load libXaw.so.6 ERROR - Please help!

13. "xterm" can't find libXaw.so.6 ?????????????????????