PCI S3 864 XFConfig startup Problems

PCI S3 864 XFConfig startup Problems

Post by David E. Fann » Fri, 30 Dec 1994 06:27:44



A Humble Request for help in Configuring
an HP Vectra XU (P5/90) with an Integrated UVGA card.

The problem is having the screen go blank and "lockup"
after using the "startx" command, with no error messages
that give me an idea of what's going wrong.  No
indication of errors in either the logfile or
in /var/adm/messages as to what to look for.

The output of the startx file is shown below. I have also
included the XF86Config file that is being used.

Any help on this one would be greatly appreciated.

thanks,

dave fannin
defa...@pacbell.com

------------------------------------------------------------
Specs:
HP Vectra XU (pentium/90Mz)
Adaptec 1542CF SCSI controller with Quantum 1.05G drive
NEC 601 SCSI CD

Integrated Ultra VGA card (chips confirmed by inspection of motherboard)
     - S3 Series 86C864
     - Clockchip ICS9161  (used "ICD2061A" , listed as compatible)
     - RAMDAC (not sighted, Probe shows as "Normal")

Viewsonic 21 (Model 2182-1) Monitor (Multi-Freq)

Running Slackware 2.0.1 (from June 94 InfoMagic CD)
        XFree86 3.1 (downloaded from the Net two days ago)
        XF86_S3 as X server

PS/2 Mouse

Background:

1) removed "selection" from /etc/rc.local that interfered with ps/2 mouse.

2) was able to get XF86_SVGA to startup and display to confirm
   that at least something worked. However, this display is pretty ugly...

3) I have tried setting "Clocks", using Chipset "s3_generic"
   instead of "mmio_928", and Clockchip "s3gendac" and "s3_sdac".
   All were unsuccessful.

------------------------------------------------------------
output from startx >file 2>&1
------------------------------------------------------------
starting xinit cmd...

XFree86 Version 3.1 / X Window System
(protocol Version 11, revision 0, vendor release 6000)
Operating System: Linux
Configured drivers:
  S3: accelerated server for S3 graphics adaptors (Patchlevel 2)
      mmio_928, s3_generic
(using VT number 7)

XF86Config: /usr/X11R6/lib/X11/XF86Config
(**) stands for supplied, (--) stands for probed/default values
(**) Mouse: type: PS/2, device: /dev/mouse, baudrate: 1200
(**) S3: Graphics device ID: "HP Vectra XU UVGA"
(**) S3: Monitor ID: "Viewsonic-21"
(**) FontPath set to "/usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts
     /Type1/,/usr/X11R6/lib/X11/fonts/Speedo/,/usr/X11R6/lib/X11/fonts/75dpi/
     ,/usr/X11R6/lib/X11/fonts/100dpi/"
(--) S3: card type: PCI
(--) S3: chipset:   864 rev. 1
(--) S3: chipset driver: mmio_928
(**) S3: videoram:  2048k
(--) S3: Ramdac type: normal
(--) S3: Ramdac speed: 110
(**) S3: Using ICD2061A programmable clock
(--) S3: Maximum allowed dot-clock: 110.000 MHz
(**) S3: Mode "640x480": mode clock =  31.500
(**) S3: Mode "800x600": mode clock =  50.000
(**) S3: Mode "1024x768": mode clock =  75.000
(--) S3: Using 6 bits per RGB value
(**) S3: Virtual resolution set to 1280x1024
S3: Cannot read colourmap from VGA.  Will restore with default
(--) S3: Local bus LAW is 0xF3000000
(--) S3: Using a banksize of 2048k, line width of 1280
(--) S3: Using a single 64x64 area for expanding pixmaps
(--) S3: Using 8 planes of 1216x613 at (0,1025) aligned 8 as font cache
------------------------------------------------------------
------------------------------------------------------------

------------------------------------------------------------
Here's the xf86config file I am using.
------------------------------------------------------------
# File generated by xf86config.

#
# Copyright (c) 1994 by The XFree86 Project, Inc.
#
Section "Files"
    RgbPath     "/usr/X11R6/lib/X11/rgb"
    FontPath    "/usr/X11R6/lib/X11/fonts/misc/"
        FontPath        "/usr/X11R6/lib/X11/fonts/Type1/"
        FontPath        "/usr/X11R6/lib/X11/fonts/Speedo/"
        FontPath        "/usr/X11R6/lib/X11/fonts/75dpi/"
    FontPath    "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection
Section "ServerFlags"
EndSection
Section "Keyboard"
    Protocol    "Standard"
    AutoRepeat  500 5
    ServerNumLock
EndSection
Section "Pointer"
    Protocol    "PS/2"
    Device      "/dev/mouse"
EndSection

# **********************************************************************
# Monitor section
# **********************************************************************

# Any number of monitor sections may be present

Section "Monitor"

    Identifier  "Viewsonic-21"
    VendorName  "Viewsonic"
    ModelName   "2182-1"

# Bandwidth is in MHz unless units are specified

    Bandwidth   110
    HorizSync   31.5 - 79.0
    VertRefresh 50-150

# 640x400 @ 70 Hz, 31.5 kHz hsync
Modeline "640x400"     25.175 640  664  760  800   400  409  411  450
# 640x480 @ 60 Hz, 31.5 kHz hsync
Modeline "640x480"     25.175 640  664  760  800   480  491  493  525
# 800x600 @ 56 Hz, 35.15 kHz hsync
ModeLine "800x600"     36     800  824  896 1024   600  601  603  625
# 1024x768 @ 87 Hz interlaced, 35.5 kHz hsync
Modeline "1024x768"    44.9  1024 1048 1208 1264   768  776  784  817 Interlace
#
# 640x480 @ 72 Hz, 36.5 kHz hsync
 Modeline "640x480"     31.5   640  680  720  864   480  488  491  521
# 800x600 @ 60 Hz, 37.8 kHz hsync
Modeline "800x600"     40     800  840  968 1056   600  601  605  628 +hsync +vsync

# 800x600 @ 72 Hz, 48.0 kHz hsync
Modeline "800x600"     50     800  856  976 1040   600  637  643  666 +hsync +vsync
# 1024x768 @ 60 Hz, 48.4 kHz hsync
Modeline "1024x768"    65    1024 1032 1176 1344   768  771  777  806 -hsync -vsync

# 1024x768 @ 70 Hz, 56.5 kHz hsync
Modeline "1024x768"    75    1024 1048 1184 1328   768  771  777  806 -hsync -vsync

EndSection

# **********************************************************************
# Graphics device section
# **********************************************************************

# Any number of graphics device sections may be present

# Standard VGA Device:

Section "Device"
    Identifier  "Generic VGA"
    VendorName  "Unknown"
    BoardName   "Unknown"
    Chipset     "generic"

    VideoRam    2048

#    Clocks     25.2 28.3

EndSection

# Device configured by xf86config (S3):

Section "Device"
    Identifier  "HP Vectra XU UVGA"
    VendorName  "HP"
    BoardName   "UVGA"
    VideoRam    2048
    # Insert Clocks lines here
    Clockchip   "icd2061a"
EndSection

# **********************************************************************
# Screen sections
# **********************************************************************

# The Colour SVGA server

Section "Screen"
    Driver      "svga"
    Device      "Generic VGA"
    #Device      "HP Vectra XU UVGA"
    Monitor     "Viewsonic-21"
    Subsection "Display"
        Depth       8
        Modes       "640x480" "800x600"
        ViewPort    0 0
        Virtual     640 480
        #Virtual     1280 1024
    EndSubsection
EndSection

# The 16-color VGA server

Section "Screen"
    Driver      "vga16"
    Device      "Generic VGA"
    Monitor     "Viewsonic-21"
    Subsection "Display"
        #Modes       "640x480" "800x600"
        Modes       "640x480"
        ViewPort    0 0
        Virtual     800 600
    EndSubsection
EndSection

# The Mono server

Section "Screen"
    Driver      "vga2"
    Device      "Generic VGA"
    Monitor     "Viewsonic-21"
    Subsection "Display"
        #Modes       "640x480" "800x600"
        Modes       "640x480"
        ViewPort    0 0
        Virtual     800 600
    EndSubsection
EndSection

# The accelerated servers (S3, Mach32, Mach8, 8514, P9000, AGX, W32)

Section "Screen"
    Driver      "accel"
    Device      "HP Vectra XU UVGA"
    Monitor     "Viewsonic-21"
    Subsection "Display"
        Depth       8
        Modes       "640x480" "800x600" "1024x768"
        ViewPort    0 0
        Virtual     1280 1024
    EndSubsection
    Subsection "Display"
        Depth       16
        Modes       "640x480" "800x600" "1024x768"
        ViewPort    0 0
        Virtual     1024 768
    EndSubsection
    Subsection "Display"
        Depth       32
        Modes       "640x480" "800x600"
        ViewPort    0 0
        Virtual     800 600
    EndSubsection
EndSection

 
 
 

1. S3-864 PCI and HiColor problem

I'm having a problem with a DFI s3-864 2Mb videocard. On switching from a
S3-805i card to a DFI 864 card, I noticed a problem with the colorpalette in
HiColor mode. The video screen goes from blue to a great purple in 16 bit
mode and to a wonderfull deep blue in 15 bit mode. Apart from the color
problem everything works fine. The only hassle is that everything has the
stranges colors, and graphics look awefull because of this.
I've had the problem with Xfree 3.1 as well as with 3.1.1.
My XF86Config device section looks like this:

Section "Device"
    Identifier  "S3 Vision864"
    VendorName  "DFI"
    BoardName   "Unknown"
    Ramdac      "s3_sdac"
    Clockchip   "s3_sdac"
    VideoRam    2048
Endsection

The depth is set to 16 with weight 5-6-5.

Anyone any ideas?
Thanks a lot in advance.

Greetings from Holland,

Martijn.

2. ne.o doesn't build

3. S3 864 Vision PCI and X

4. LinuxPPC and Mouse Macally

5. Asus S3 864 (PCI)

6. X WINDOWS

7. Driver for PCI video card S3-864 : where ?

8. Stripped-down Linux box as X terminal

9. Help! PCI S3 864 and Tatung Monitor

10. PCI S3-864 XF86Config Help Needed.

11. Graphic Card: S3 PCI P64 864 V

12. HELP: generic S3-864 PCI config file

13. Recommending S3-Trio64 over S3-864?