can't resolve symbol _Xcatopen in RedHat 5.1

can't resolve symbol _Xcatopen in RedHat 5.1

Post by John McDonal » Fri, 05 Jun 1998 04:00:00



I upgraded to RedHat 5.1 and am now having a problem with CDE from
Xinside.
The best I can figure is a message in /var/dt/Xerrors of

        dtgreet: can't resolve symbol '_Xcatopen'

I went to /usr/X11/lib and did a `nm *.a | grep Xcatopen` and the only
result was from libXintl.a of:

        00000000 T _Xcatopen

It does appear that this is not defined.

I do not think this is a RedHat problem. I could possible contact Xi
Graphics
but I think the problem resides with the X libraries somewhere.

Any help would be appreciated.

John McDonald

 
 
 

can't resolve symbol _Xcatopen in RedHat 5.1

Post by John McDonal » Fri, 05 Jun 1998 04:00:00


I upgraded to RedHat 5.1 and am now having a problem with CDE from
Xinside.
The best I can figure is a message in /var/dt/Xerrors of

        dtgreet: can't resolve symbol '_Xcatopen'

I went to /usr/X11/lib and did a `nm *.a | grep Xcatopen` and the only
result was from libXintl.a of:

        00000000 T _Xcatopen

It does appear that this is not defined.

I do not think this is a RedHat problem. I could possible contact Xi
Graphics
but I think the problem resides with the X libraries somewhere.

Any help would be appreciated.

John McDonald


 
 
 

can't resolve symbol _Xcatopen in RedHat 5.1

Post by John McDonal » Fri, 05 Jun 1998 04:00:00


I upgraded to RedHat 5.1 and am now having a problem with CDE from
Xinside.
The best I can figure is a message in /var/dt/Xerrors of

        dtgreet: can't resolve symbol '_Xcatopen'

I went to /usr/X11/lib and did a `nm *.a | grep Xcatopen` and the only
result was from libXintl.a of:

        00000000 T _Xcatopen

It does appear that this is not defined.

I do not think this is a RedHat problem. I could possible contact Xi
Graphics
but I think the problem resides with the X libraries somewhere.

Any help would be appreciated.

John McDonald

 
 
 

can't resolve symbol _Xcatopen in RedHat 5.1

Post by John McDonal » Fri, 05 Jun 1998 04:00:00


I upgraded to RedHat 5.1 and am now having a problem with CDE from
Xinside.
The best I can figure is a message in /var/dt/Xerrors of

        dtgreet: can't resolve symbol '_Xcatopen'

I went to /usr/X11/lib and did a `nm *.a | grep Xcatopen` and the only
result was from libXintl.a of:
        00000000 T _Xcatopen

It does appear that this is not defined.

I do not think this is a RedHat problem. I could possible contact Xi
Graphics
but I think the problem resides with the X libraries somewhere.

Any help would be appreciated.

John McDonald

 
 
 

can't resolve symbol _Xcatopen in RedHat 5.1

Post by Doug Kilpatric » Sat, 06 Jun 1998 04:00:00



> I upgraded to RedHat 5.1 and am now having a problem with CDE from
> Xinside.
> The best I can figure is a message in /var/dt/Xerrors of

>         dtgreet: can't resolve symbol '_Xcatopen'

> I went to /usr/X11/lib and did a `nm *.a | grep Xcatopen` and the only
> result was from libXintl.a of:

>         00000000 T _Xcatopen

Neat.  Its not undefined, but it has no address.  I want one...:)
No "01234567 U _Xcatopen" results?

(The U means undefined. The T means "Text section" I think... which is
where functions typically are.)

I'd suggest tracking things down a bit more.  Use "ldd" on dtgreet to
find out what libraries it includes.  Use nm on those libraries and
dtgreet to verify that the symbol is missing.

If you can not find the symbol in any ".so." file, then dtgreet may need
to be recompilied.  (although it might work if you use LD_PRELOAD.  Not
sure.)

Doug

I do not speak for my employer.

 
 
 

can't resolve symbol _Xcatopen in RedHat 5.1

Post by z.. » Wed, 10 Jun 1998 04:00:00


I upgraded to RedHat 5.1 and am now having a problem with
CDE from Xinside. The best I can figure is a message in
/var/dt/Xerrors of

        dtgreet: can't resolve symbol '_Xcatopen'

I went to /usr/X11/lib and did a `nm *.a | grep Xcatopen`
and the only result was from libXintl.a of:

        00000000 T _Xcatopen

It does appear that this is not defined.

I do not think this is a RedHat problem. I could possible
contact Xi Graphics but I think the problem resides with
the X libraries somewhere.

Have others seen this problem ?
Any help would be appreciated.

John McDonald

 
 
 

1. can't resolve symbol _Xcatopen in RedHat 5.1

I upgraded to RedHat 5.1 and am now having a problem with CDE from
Xinside.
The best I can figure is a message in /var/dt/Xerrors of

        dtgreet: can't resolve symbol '_Xcatopen'

I went to /usr/X11/lib and did a `nm *.a | grep Xcatopen` and the only
result was from libXintl.a of:

        00000000 T _Xcatopen

It does appear that this is not defined.

I do not think this is a RedHat problem. I could possible contact
Xi Graphics but I think the problem resides with the X libraries
somewhere.

Any help would be appreciated.

John McDonald

2. Apache 1.2: mod_auth_msql.o

3. can't resolve symbol '_IO_putc' - SUSE 5.0/5.1

4. RFC for TALK, where?

5. redhat 4.0 install, 'can't resolve symbol' errors...

6. Hi, need advice

7. can't resolve symbol '_h_errno'

8. Waiting for a dialog to finish?

9. Netscape 3.0x and 'Can't resolve symbol'

10. ifconfig: can't resolve symbol: '_h_errno'???

11. can't resolve symbol 'XkbLookupKeySym'

12. can't resolve symbol '_h_errno'

13. LIBC 5.4.13: can't resolve symbol '__start___libc_subinit'