problem with agp/nvidia gpu on samsung x10 notebook

problem with agp/nvidia gpu on samsung x10 notebook

Post by Florian March » Thu, 26 Jun 2003 02:55:33




i am new to this board/mailinglist. i hope you can help me with the
following concern:

i got a brand new Samsung X10 XTC1300 Centrino laptop. it has got an
nvidia gpu (geforce 4 420 go).

with all the needful hints at www.tuxmobil.org i nearly completed the
installation of my debian woody distribution.
soundcard, nic, ide and cdrom are working fine, acpi seems to be a
huge problem with centrino notebooks though.

i'm currently running an 4.1.0-16 xserver with the vesa-driver since
the nvidia driver doesn't work at all.
i really tried everything: compiling kernels over and over, but
nothing helps. even the kernel patches from alan cox
(with a new agpgart-module) didn't help, the nvidia driver produces
nothing but trash.

all i ask for is some useful information concerning graphics
acceleration on that samsung machine because
every time i want to play mpeg-videos (for instance), my xserver
chrashes. i suggest it's the vesa driver so i barely
need the nvidia-driver working.

thanks in advance

florian marchal, germany

 
 
 

1. nvidia agp problem: cannot writecombine agp aperture

I have an MSI 8831 video card (geforce 2) and a FIC AD11 mom board (AMD
761). I'm running Slackware 8.0 (XFree86 4.1.0) with a 2.4.12 kernel
that I compiled (mtrr support is compiled in). I'm using the nvidia
1.0-1541 driver.

When agpgart isn't compiled in, after I startx "dmesg | grep NVRM" yields:
     NVRM: loading NVIDIA kernel module version 1.0-1541
     NVRM: *** Cannot WriteCombine the AGP Aperture

"cat /proc/nv/card0" yields:
     ----- Driver Info -----
     NVRM Version: 1.0-1541
     ------ Card Info ------
     Model:        GeForce2 GTS
     IRQ:          10
     Video BIOS:   03.15.01.00
     ------ AGP Info -------
     AGP status:   Disabled
     AGP Driver:
     Bridge:       Generic AMD
     SBA:          Supported [disabled]
     FW:           Supported [disabled]
     Rates:        4x 2x 1x  [-]
     Registers:    0x0f000217:0x00000000

When agpgart is compiled in, after I startx, "dmesg | grep agpgart" yields:
     Linux agpgart interface v0.99 (c) Jeff Hartmann
     agpgart: Maximum main memory to use for agp memory: 203M
     agpgart: Detected AMD 761 chipset

and "dmesg | grep NVRM" yields:
     NVRM: loading NVIDIA kernel module version 1.0-1541
     NVRM: AGPGART: unknown chipset
     NVRM: AGPGART: unable to set MTRR write-combining

     NVRM: AGPGART: aperture mapped from 0xd0000000 to 0xd598f000
     NVRM: AGPGART: mode 4x
     NVRM: AGPGART: allocated 16 pages

and /proc/nv/card0 says:
     ...
     ------ AGP Info -------
     AGP status:   Enabled
     AGP Driver:   AGPGART
     Bridge:       Generic AMD
     SBA:          Supported [disabled]
     FW:           Supported [disabled]
     Rates:        4x 2x 1x  [4x]
     Registers:    0x0f000217:0x00000104

Does anyone have any ideas? Is this just a configuration problem? Am I
having a hardware problem?

Much thanks,
Jason

2. backpack cd rom compatibility

3. nVidia 8MB AGP vs. ATI 8MB Rage Pro Turbo AGP and XFree86

4. Sound Hacker's Guide: where is it?

5. Choice: STB 8MB NVidia 3D AGP or ATI XPert 8MB 2X AGP 3D Video?

6. Mouse X & Y Directions Reversed Gateway-2000 PS/2 type

7. Dual headed with Nvidia GeForce4 (MX420) AGP + Nvidia TNT2 PCI

8. TALK Problem. Help!

9. AGP problem with Intel E7505 chipset and nvidia quadro4 750xgl

10. nvidia agp problems

11. MDK9.2, NVidia drivers, GF FX 5200, AGPx8 SiS746, kernel 2.6.2 - problem with agp

12. AGP NVidia Card, X, and eth0 Problems???

13. STB nVidia AGP Card Problem