xfree libncurses

xfree libncurses

Post by Juan » Sat, 07 Apr 2001 13:30:06



after installing xfree 4.0.2, i run startx and it stops with a message of
libncurses.so.4, i got libncurses.so.5 somewhere in the system, what file
do i change?
it will work with version 5?

--
Posted via CNET Help.com
http://www.help.com/

 
 
 

xfree libncurses

Post by Mike Cast » Sat, 07 Apr 2001 14:28:28




>after installing xfree 4.0.2, i run startx and it stops with a message of

Did you compile it yourself?  That's the easiest way.

mrc
--
       Mike Castle       Life is like a clock:  You can work constantly

www.netcom.com/~dalgoda/ and be right at least twice a day.  -- mrc
    We are all of us living in the shadow of Manhattan.  -- Watchmen

 
 
 

xfree libncurses

Post by Juergen Hein » Sun, 08 Apr 2001 08:07:01



>after installing xfree 4.0.2, i run startx and it stops with a message of
>libncurses.so.4, i got libncurses.so.5 somewhere in the system, what file
>do i change?
>it will work with version 5?

[-]
Yes. Off the cuff the only application I know which'd require
curses is xterm. You can compile a new version of xterm yourself.

Ta',
Juergen

--
\ Real name     : Juergen Heinzl                \       no flames      /

 
 
 

xfree libncurses

Post by Vigi » Mon, 09 Apr 2001 02:13:36


Just link the version of libncurses you have to the version it's looking for.


Quote:> after installing xfree 4.0.2, i run startx and it stops with a message of libncurses.so.4, i got libncurses.so.5 somewhere in the system,
> what file do i change?
> it will work with version 5?

--

.

 
 
 

xfree libncurses

Post by Thomas Dicke » Mon, 09 Apr 2001 08:02:11



> Just link the version of libncurses you have to the version it's looking for.

that sort of advice seems to be for/by Redhat users.

(it's not good advice)

--

http://dickey.his.com
ftp://dickey.his.com

 
 
 

xfree libncurses

Post by Vigi » Tue, 10 Apr 2001 04:04:07


Would you rather I told him to go through the entire XFree86 source replacing all occurances of libncurses 4?


Quote:>> Just link the version of libncurses you have to the version it's looking for.
> that sort of advice seems to be for/by Redhat users.
> (it's not good advice)

--

.

 
 
 

xfree libncurses

Post by Juan » Tue, 10 Apr 2001 11:30:07



> Would you rather I told him to go through the entire XFree86 source

replacing all occurances of libncurses 4?


> >> Just link the version of libncurses you have to the version it's
looking for.
> > that sort of advice seems to be for/by Redhat users.
> > (it's not good advice)

> --

thanxs guys i just installed libcurses 4, and theres no problem

Quote:> .

--
Posted via CNET Help.com
http://www.help.com/
 
 
 

xfree libncurses

Post by Thomas Dicke » Tue, 10 Apr 2001 19:40:36



> Would you rather I told him to go through the entire XFree86 source replacing all occurances of libncurses 4?

it's not necessary (if he's running Redhat, they have some variation of
ncurses with version "4" where "5.0" or "5.1" was correct).  But linking
that way will break other applications which happen to use ncurses 4.2


>>> Just link the version of libncurses you have to the version it's looking for.
>> that sort of advice seems to be for/by Redhat users.
>> (it's not good advice)
> --
> .

--

http://dickey.his.com
ftp://dickey.his.com
 
 
 

1. How to upgrade XFree 1.3 to XFree 2.0 ????

Hi,

I think it is time for me to upgrade my XFREE 1.3 (coming with SLS 1.03)
to XFREE 2.0.

Now my questions:
What have I to do?
Which Files must be replaced?
Are the old binaries running with the new XFREE?
Which libs do I need?

I installed LD.SO 1.3 with the libs 4.4.4 short time ago...I knew that the
new XFREE needs LS.SO....but what else?

Or it is possible to run Binaries for XFREE 2.0 with XFREE 1.3 ?
(this solution I would prefer)

I hope that anyone can help me,
thanx in advance,

 Thomas Niederreiter

2. Unix - Frequently Asked Questions (Contents) [Frequent posting]

3. Upgrading XFree to XFree 4.X

4. Sockets and threads, sockets and threads

5. Upgrading from XFree-3.1 to XFree-3.1.1?

6. samba remote access

7. Q: GUI XFree configurator for XFree 4.n

8. 2 tip running instead of one

9. XFree - how do I get a full console during xfree running?

10. XFree Classic or XFree

11. XFree + "stonerview" screensaver -> Xfree oops

12. XFree v2.1.1 -> XFree v3.

13. Problem upgrade from Xfree-3.3.2 to Xfree-3.3.3