ATAPI CD-DA extraction & SCSI emulation

ATAPI CD-DA extraction & SCSI emulation

Post by Ben McKeeg » Wed, 01 Apr 1998 04:00:00



I am using the SCSI host emulation driver in the 2.0.32 kernel (patched)
to enable me to use my ATAPI CD Writer (a Mitsumi CR-2801TE). This works
fine, however, I have been unable to get CD Digital Audio extraction to
work correctly via the SCSI driver. I've tried both cdda2wav and
cdparanioa and they both just yeild .WAV files full of zeroes. Using the
same kernel but with the ATAPI CD driver compiled in CD-DA works fine, so
this would appear to be a bug in the SCSI emulation.

I know others have experienced the same problem. My questions are:

 Is there a reasonably safe development kernel where the SCSI module
 support has been fixed, so I can load ATAPI or SCSI emulation as modules
 as needed? Would this work?

 Has this problem been fixed in any of the kernels yet?

Thanks.

--
/   Ben McKeegan                                                       \
\   Fitzwilliam College, University of Cambridge, UK.                  /

 
 
 

ATAPI CD-DA extraction & SCSI emulation

Post by Itai Nahsho » Fri, 03 Apr 1998 04:00:00



> I am using the SCSI host emulation driver in the 2.0.32 kernel (patched)
> to enable me to use my ATAPI CD Writer (a Mitsumi CR-2801TE). This works
> fine, however, I have been unable to get CD Digital Audio extraction to
> work correctly via the SCSI driver. I've tried both cdda2wav and
> cdparanioa and they both just yeild .WAV files full of zeroes. Using the
> same kernel but with the ATAPI CD driver compiled in CD-DA works fine, so
> this would appear to be a bug in the SCSI emulation.

This is being discussed on the cdrecord mailing list.

You have to get a recent alpha version of cdda2wav or
cdparanoiaIII bata3 (expected to release very soon).

Itai
--