3-button PS/2 mouse not working

3-button PS/2 mouse not working

Post by John Goerze » Mon, 08 Sep 1997 04:00:00



Hi,

I have a Mouse Systems Optical Mouse.  When it is hooked up to the
serial port, it works fine.  When I hook it up to the PS/2 port (using
the supplied adapter), XFree86 thinks that the middle button is the
right button (meaning that both the middle and right buttons do the
same thing).

This is Linux 2.0.29, XFree86 3.3.

How do I fix this?

Thanks,
John Goerzen

--
John Goerzen          | Running Debian GNU/Linux (www.debian.org)
Custom Programming    | Debian GNU/Linux is a free replacement for

----------------------+----------------------------------------------
Notice: You may purchase the right to send me unsolicited commercial e-mail
("spam") for the fee of $500 (USD) per message.  Billing can be either
pre-arranged or can occur automatically after the reception of a spam.
Failure to pay will be treated in accordance to US Code, title 47, sec. 227,
which allows unsolicited e-mail to be punishable by action to recover actual
monetary loss or $500, whichever is greater, per violation.  Sending spam
to me without payment constitutes unauthorized access to my mail daemon,
which is in violation of federal law.

 
 
 

1. Mouse Systems 3-button "PS/2 Mouse" - Will it Work?

I just purchased a Mouse Systems 3-button PS/2 Mouse to replace a 2-button
mouse (the user couldn't stand using chorded middle).

Unfortunately, I can't get it to work with either gpm or Xree86.  The
mouse will move up and to the right, but simply jumps when you attempt to
move left or down.  I mostly tried /dev/mouse -> /dev/psaux, but the other
options (/dev/inportbm, etc. don't seem to work, either).

It's not a hardware problem, as the mouse works fine under Win95.  I'm
beginning to suspect and incompatibility with the linux PS/2 mouse driver.

Does anyone have any ideas/experience?

Also, I can't get test-mouse to work with ANY mouse I have, most of which
work fine with gpm and XFree86.  Anyone else?

2. oops in hisax

3. 3-button PS2 mouse on a 390 - middle button not working

4. C++ Beginner

5. -> 3-button mouse, 2nd button not work

6. [v850] Define flush_page_to_ram on v850/nb85e

7. Can 2-button mouse do 3-button mouse works?

8. Making lib's for NIS+

9. Logitech Mouseman 3-button PS/2 mouse won't work under RedHat 5.1 Xwin

10. Mouse Systems 3-button PS/2 mouse - weird behaviour.

11. Middle button on 3-button mouse not registering

12. KeyMouse 3-button mouse - anyone get the third button working?

13. fvwm and 3-button mouse not working.