10Gb disk and mke2fs -- solved

10Gb disk and mke2fs -- solved

Post by Steve Marti » Wed, 21 Jun 2000 04:00:00



I had posted a message describing a problem I had with
making filesystems on my new 10 Gb disk. Turns out that
the problem was that the BIOS had auto-detected the
drive on installation and had set it up as LBA with
255 heads. Apparently, mke2fs did not like that. I
went back and manually re-detected the drive with
the "LARGE" option rather than "LBA", which brought
the number of heads back down to 128. This seems to
have cured the problem.
 
 
 

1. Missing 10gb after mke2fs on LaCie 120gb ext drive

Hi, I have installed a LaCie 120gb D2 drive under firewire on RedHat 8.
When the drive is fired up on startup, dmesg reports:

SCSI device sda: 234441648 512-byte hdwr sectors (120034 MB)
sda: sda1

Perfect.

But, after formatting the drive using fdisk and mke2fs, when I mount the
drive, df reports:

Filesystem ??????????1K-blocks ?????Used Available Use% Mounted on
/dev/sda ????????????115380224 ???????20 109519164 ??1% /data

If a 120gb drive has 128849018880 bytes (120 * 1073741824)
it seems to me that I've lost nearly 10gb on this drive after formatting
(115380224 blocks = 118149349376 bytes which is 110.04gb).
fdisk /dev/sda displays the following when printing the table:

Disk /dev/sda: 255 heads, 63 sectors, 14593 cylinders
Units = cylinders of 16065 * 512 bytes

??Device Boot ???Start ??????End ???Blocks ??Id ?System
/dev/sda1 ????????????1 ????14593 117218241 ??83 ?Linux

All this doesn't make sense to me... are my calculations wrong?

Also, when I share the mounted drive on samba, and connect
to it on my mac, the mac reports that the drive only have 104gb
remaining, which is even worse....

Is this just a case of invalid calculations/reporting or have I
really lost between 10 and 16 gb of space after formatting
and making the filesystem?

Thanks!
paul

2. What is /opt for and more...

3. SLS install problem (mke2fs) (SOLVED)

4. New Linux Box (Revisited)

5. SOLVED:mke2fs: can't find block for inode table

6. MD5 in which browsers?

7. FreeBSD-3.1 + 10Gb hard disk..

8. /dev/sda2: UNEXPECTED INCONSISTENCY !!!!

9. MKE2FS: mke2fs on the WRONG Partition. Recovery possible?

10. 10GB disk and LILO - I tried EVERYTHING!

11. Partitioning a 10Gb IDE disk

12. LILO and a 10GB disk???