anyone know how to install HP 970cse print driver?

anyone know how to install HP 970cse print driver?

Post by Samm » Fri, 09 Feb 2001 05:04:24



Hi all,

I\'m running Linux 7.0 and have a HP Deskjet 970cse.  I tried installing the
driver on this www.linuxprinting.org site written by Rene' Harsch but am
having trouble.  I'm new to LINUX and am not sure what I'm doing wrong here.
Can anyone help me? Below, I have documented my environment and error log.
Thank you.

1)  I have gs in the /usr/bin directory (version 5.50)
2)  I have the lpd-o-matic description file for the 970cse driver in the
/usr/local/bin.  It is named lpd-o-matic.cgi
3)  I have the lpdomatic perl script in the /usr/local/sbin.  The file is
named
lpdomatic.
4)  My printcap file looks like this:

lp:\
        :sd=/var/spool/lpd/lp:\
        :mx#0:\
        :sh:\
        :lp=/dev/lp0:\
        :af=/usr/local/lpd-o-matic.cgi:\
        :if=/usr/local/sbin/lpdomatic:

5)  After setting the debug flag in the lpdomatic perl script, I tried this
print command:  lpr -P lp SplitterI.java

I then got this error in the /temp/prnlog

Lpdomatic backend version $Revision: 1.5 $ running...
/usr/local/sbin/lpdomatic: called with arguments:
l
ocaldomain','-JSplitterI.java','-Plp','-Qlp','-a/usr/local/lib/lpd-o-matic.c
gi','-b353','-d/var/spool/lpd/lp','-edfA398localhost.localdomain','-fSplitte
rI.java','-hlocalhost.localdomain','-j398','-kcfA398localhost.localdomain','
-l66','-nroot','-sstatus','-t2001-02-06-20:38:25.000','-w80','-x0','-y0','/u
sr/local/lib/lpd-o-matic.cgi
/usr/local/sbin/lpdomatic: af=/usr/local/lib/lpd-o-matic.cgi
/usr/local/sbin/lpdomatic: unable to evaluate datablob

So, in summary, what does this mean?  I did not see my printer budge at
all..nothing happened.

Thanks,
Sammy

 
 
 

anyone know how to install HP 970cse print driver?

Post by Knut Zakariasse » Fri, 09 Feb 2001 09:01:33


Sammy,

First of all, as the hp970 is not supported in gs5.50, you need to add
the support to your ghostscript binary before you get to the driver you
got from linuxprinting.org

Id suggest you should first stop by the ghostscript site

http://sourceforge.net/projects/ghostscript

to get the latest stable version (currently 6.5), with utilities and
fonts,
and then go to Rens site http://www.harsch.net to get the ghostscript
driver for the hp970.

Rens site is in german, but gives a very good point for point
explanation on how to make a ghostscript binary that supports your
printer.

When you have a working gs binary that supports your printer, I would
guess your problems with the lpdomatic scripts should be straightenend
out as well.

If you still cant get the scripts to work, maybe you should take a look
at apsfilter (http://www.apsfilter.org), which may be easier to set up,
and that has excellent support for the 970c series printer.

Good luck!

Knut.



> Hi all,

> I\'m running Linux 7.0 and have a HP Deskjet 970cse.  I tried installing
> the driver on this www.linuxprinting.org site written by Rene' Harsch
> but am having trouble.  I'm new to LINUX and am not sure what I'm doing
> wrong here. Can anyone help me? Below, I have documented my environment
> and error log. Thank you.

> 1)  I have gs in the /usr/bin directory (version 5.50)
> 2)  I have the lpd-o-matic description file for the 970cse driver in the
> /usr/local/bin.  It is named lpd-o-matic.cgi
> 3)  I have the lpdomatic perl script in the /usr/local/sbin.  The file
> is
> named lpdomatic.
> 4)  My printcap file looks like this:

> lp:\
>    :sd=/var/spool/lpd/lp:\
>    :mx#0:\
>    :sh:\
>    :lp=/dev/lp0:\
>    :af=/usr/local/lpd-o-matic.cgi:\
>    :if=/usr/local/sbin/lpdomatic:

> 5)  After setting the debug flag in the lpdomatic perl script, I tried
> this
> print command:  lpr -P lp SplitterI.java

> I then got this error in the /temp/prnlog

> Lpdomatic backend version $Revision: 1.5 $ running...
> /usr/local/sbin/lpdomatic: called with arguments:
l
> ocaldomain','-JSplitterI.java','-Plp','-Qlp','-a/usr/local/lib/lpd-o-matic.c
> gi','-b353','-d/var/spool/lpd/lp','-edfA398localhost.localdomain','-fSplitte
> rI.java','-hlocalhost.localdomain','-j398','-kcfA398localhost.localdomain','
> -l66','-nroot','-sstatus','-t2001-02-06-20:38:25.000','-w80','-x0','-y0','/u
> sr/local/lib/lpd-o-matic.cgi
> /usr/local/sbin/lpdomatic: af=/usr/local/lib/lpd-o-matic.cgi
> /usr/local/sbin/lpdomatic: unable to evaluate datablob

> So, in summary, what does this mean?  I did not see my printer budge at
> all..nothing happened.

> Thanks, Sammy


 
 
 

1. Does anyone have the print driver for hp laserjet 5n and how do I install it?

I currently have SCO unix (I believe version 5) I need to install an HP
laserjet 5N printer and I don't see the driver listed, the only driver I see
listed is a laserjet. I used that driver but anytime you send something to
print it goes to the manual feed also on a full page of text some of the
words are cut off on the right side and the bottom. I heard that a driver
for the laserjet 4 would work but I can't find that one either. I have never
added an
entry to the terminfo so I could use some assistance . I appreciate any
help.

Thanks in advance.

Todd

2. scsi_merge oops (2.5.8-pre2)

3. Does anyone know of a linux driver for the HP ScanJet 2400?

4. Popper logging

5. HP Desk Jet 970Cse

6. Configue Pager

7. Need assistance setting up HP DeskJet 970Cse

8. tcsh fork deficiency

9. print setup using ijs HP gs driver with HP DJ 648c problems

10. printing to HP IIIsi with HP jet direct card, Linux driver?

11. Anyone know how to setup a HP 720C printer???

12. anyone know anything about hp en5000 digital media players?

13. Anyone knows the specification of monitor of HP Pavilion 4440