Getting sound to work on Gateway 9100 (Yamaha OPL3-SA)

Getting sound to work on Gateway 9100 (Yamaha OPL3-SA)

Post by Peter Wainwrig » Wed, 19 Nov 1997 04:00:00



I've just bought a Gateway 9100 laptop (200LS) and Linux seems to work
pretty well on it. However, I haven't yet configured the sound entirely
successfully. The 4-op FM synth works OK, but I can't play sound through
the external MIDI interface (which is supposed to be a MPU-401).
When I try playmidi -e or the Jazz++ sequencer I get a load of errors like

...
Nov 18 22:25:07 wainpr kernel: Sound Blaster: DSP Command(90) Timeout.
Nov 18 22:25:07 wainpr kernel: Sound Blaster: DSP Command(3a) Timeout.
Nov 18 22:25:07 wainpr kernel: Sound Blaster: DSP Command(0) Timeout.
Nov 18 22:25:07 wainpr kernel: Sound Blaster: DSP Command(93) Timeout.
Nov 18 22:25:07 wainpr kernel: Sound Blaster: DSP Command(41) Timeout.
Nov 18 22:25:07 wainpr kernel: Sound Blaster: DSP Command(0) Timeout.
Nov 18 22:25:07 wainpr kernel: Sound Blaster: DSP Command(90) Timeout.
Nov 18 22:25:07 wainpr kernel: Sound Blaster: DSP Command(41) Timeout.
Nov 18 22:25:07 wainpr kernel: Sound Blaster: DSP Command(0) Timeout.
Nov 18 22:25:07 wainpr kernel: Sound Blaster: DSP Command(93) Timeout.
Nov 18 22:25:07 wainpr kernel: Sound Blaster: DSP Command(3a) Timeout.
Nov 18 22:25:07 wainpr kernel: Sound Blaster: DSP Command(0) Timeout.
Nov 18 22:25:07 wainpr kernel: Sound Blaster: DSP Command(92) Timeout.
Nov 18 22:25:07 wainpr kernel: Sound Blaster: DSP Command(46) Timeout.
Nov 18 22:25:07 wainpr kernel: Sound Blaster: DSP Command(0) Timeout.
Nov 18 22:25:07 wainpr kernel: Sound Blaster: DSP Command(90) Timeout.
Nov 18 22:25:07 wainpr kernel: Sound Blaster: DSP Command(2e) Timeout.
Nov 18 22:25:07 wainpr kernel: Sound Blaster: DSP Command(0) Timeout.
Nov 18 22:25:07 wainpr kernel: Sound Blaster: DSP Command(90) Timeout.
...
etc. ad nauseam.

Also, /dev/audio is not a valid device unless I first boot Windoze 95
and then do a warm boot to Linux or use loadlin. I can only guess some
plug-and-pray magic is going on here, but when I try pnpdump it
reports no cards found. I don't understand :-(

Has anyone got a working /etc/soundconf for this laptop and sound
card, or any suggestions?

The Windoze dialogs show something like this:
              Addr     IRQ      DMA
WSS:          530      5        Play 0 Rec 1
SoundBlaster: 220      5        1
OPL/3 FM:     388
MPU 401:      330      5

HELP! I really don't understand sound at all :-(

Peter Wainwright

--
Peter Wainwright


http://www.wainpr.demon.co.uk

 
 
 

Getting sound to work on Gateway 9100 (Yamaha OPL3-SA)

Post by Mike Ivers » Thu, 20 Nov 1997 04:00:00


Try the OSS/Linux sound driver. This should perform better.
It fully supports the OPL3-SA chips.

However, it costs $20. You do get free upgrades for the next
4 or 5 years, though.

You can download and try it out for a 10 day free trial.

Mike


>I've just bought a Gateway 9100 laptop (200LS) and Linux seems to work
>pretty well on it. However, I haven't yet configured the sound entirely
>successfully. The 4-op FM synth works OK, but I can't play sound through
>the external MIDI interface (which is supposed to be a MPU-401).
>When I try playmidi -e or the Jazz++ sequencer I get a load of errors like

>...
>Nov 18 22:25:07 wainpr kernel: Sound Blaster: DSP Command(90) Timeout.
>Nov 18 22:25:07 wainpr kernel: Sound Blaster: DSP Command(3a) Timeout.
>Nov 18 22:25:07 wainpr kernel: Sound Blaster: DSP Command(0) Timeout.
>Nov 18 22:25:07 wainpr kernel: Sound Blaster: DSP Command(93) Timeout.
>Nov 18 22:25:07 wainpr kernel: Sound Blaster: DSP Command(41) Timeout.
>Nov 18 22:25:07 wainpr kernel: Sound Blaster: DSP Command(0) Timeout.
>Nov 18 22:25:07 wainpr kernel: Sound Blaster: DSP Command(90) Timeout.
>Nov 18 22:25:07 wainpr kernel: Sound Blaster: DSP Command(41) Timeout.
>Nov 18 22:25:07 wainpr kernel: Sound Blaster: DSP Command(0) Timeout.
>Nov 18 22:25:07 wainpr kernel: Sound Blaster: DSP Command(93) Timeout.
>Nov 18 22:25:07 wainpr kernel: Sound Blaster: DSP Command(3a) Timeout.
>Nov 18 22:25:07 wainpr kernel: Sound Blaster: DSP Command(0) Timeout.
>Nov 18 22:25:07 wainpr kernel: Sound Blaster: DSP Command(92) Timeout.
>Nov 18 22:25:07 wainpr kernel: Sound Blaster: DSP Command(46) Timeout.
>Nov 18 22:25:07 wainpr kernel: Sound Blaster: DSP Command(0) Timeout.
>Nov 18 22:25:07 wainpr kernel: Sound Blaster: DSP Command(90) Timeout.
>Nov 18 22:25:07 wainpr kernel: Sound Blaster: DSP Command(2e) Timeout.
>Nov 18 22:25:07 wainpr kernel: Sound Blaster: DSP Command(0) Timeout.
>Nov 18 22:25:07 wainpr kernel: Sound Blaster: DSP Command(90) Timeout.
>...
>etc. ad nauseam.

>Also, /dev/audio is not a valid device unless I first boot Windoze 95
>and then do a warm boot to Linux or use loadlin. I can only guess some
>plug-and-pray magic is going on here, but when I try pnpdump it
>reports no cards found. I don't understand :-(

>Has anyone got a working /etc/soundconf for this laptop and sound
>card, or any suggestions?

>The Windoze dialogs show something like this:
>              Addr     IRQ      DMA
>WSS:          530      5        Play 0 Rec 1
>SoundBlaster: 220      5        1
>OPL/3 FM:     388
>MPU 401:      330      5

>HELP! I really don't understand sound at all :-(

>Peter Wainwright

>--
>Peter Wainwright


>http://www.wainpr.demon.co.uk

--

| University Technology Services and                                   |
| the Department of Electrical Engineering                             |
| The Ohio State University                                            |