Adaptec 1542CF, IBM DPES-31080, SCSI Probs

Adaptec 1542CF, IBM DPES-31080, SCSI Probs

Post by Matthias Hamm » Sat, 02 Sep 1995 04:00:00



Hi,

I have problems with my new IBM DPES-31080 under Linux 1.2.9.
My configuration is:
        Intel 486-50 ISA
        Linux 1.2.9
        Adaptec 1542CF
        Toshiba CD-ROM XM-3601TA        SCSI-ID 3
        IBM DPES-31080                  SCSI-ID 0
        SEAGATE ST11200N                SCSI-ID 1

When I tried to install Linux on the IBM-HD (from CDROM), the system
startet to work, but later during the installtion the SCSI-Bus locked
(crashed, don't know the right word). Then I decided to use the
Seagate HD for Linux and the IBM HD for DOS. The Seagate HD works well
with Linux and the IBM HD with DOS.
Now I have the problem when accessing the DOS partition from Linux the
SCSI Bus locks sometimes and I have to press the reset button.

Is there anybody knowing something about this problem. Is the there a
solution or workaround (new firmware for the IBM or newer kernel or
patch?)

Cheers
        Matthias

--
------------------------------------------------------------------------------
Matthias Hammer
FG Flugmechanik und Regelungstechnik       Dept. Flightmechanics and Control
THD - FB 16                                Technical University of Darmstadt
Petersenstrasse 30
64287 Darmstadt
Germany

Tel.:  +49 6151 16-6569         FAX: +49 6151 16-5434

------------------------------------------------------------------------------

 
 
 

Adaptec 1542CF, IBM DPES-31080, SCSI Probs

Post by Bernd Brinkma » Tue, 05 Sep 1995 04:00:00


Hi,

I had the same problem. You only have to disable
'disconnection' in the setup of the Adaptec
for the IBM-HD. (Or buy another controller, HD: It is only
this combination (Adaptec, IBM) that doesn't work)
Hope this helps

Bernd

: Hi,

: I have problems with my new IBM DPES-31080 under Linux 1.2.9.
: My configuration is:
:       Intel 486-50 ISA
:       Linux 1.2.9
:       Adaptec 1542CF
:       Toshiba CD-ROM XM-3601TA        SCSI-ID 3
:       IBM DPES-31080                  SCSI-ID 0
:       SEAGATE ST11200N                SCSI-ID 1

: When I tried to install Linux on the IBM-HD (from CDROM), the system
: startet to work, but later during the installtion the SCSI-Bus locked
: (crashed, don't know the right word). Then I decided to use the
: Seagate HD for Linux and the IBM HD for DOS. The Seagate HD works well
: with Linux and the IBM HD with DOS.
: Now I have the problem when accessing the DOS partition from Linux the
: SCSI Bus locks sometimes and I have to press the reset button.

: Is there anybody knowing something about this problem. Is the there a
: solution or workaround (new firmware for the IBM or newer kernel or
: patch?)

:  
: Cheers
:         Matthias

--
******************************************************************************

*. 63743 Aschaffenburg ......................................................*
*. Germany ..................................................................*

 
 
 

Adaptec 1542CF, IBM DPES-31080, SCSI Probs

Post by Franz Fackelma » Wed, 06 Sep 1995 04:00:00



|> Hi,
|>
|> I have problems with my new IBM DPES-31080 under Linux 1.2.9.
|> My configuration is:
|>   Intel 486-50 ISA
|>   Linux 1.2.9
|>   Adaptec 1542CF
|>   Toshiba CD-ROM XM-3601TA        SCSI-ID 3
|>   IBM DPES-31080                  SCSI-ID 0
|>   SEAGATE ST11200N                SCSI-ID 1
|>
|> When I tried to install Linux on the IBM-HD (from CDROM), the system
|> startet to work, but later during the installtion the SCSI-Bus locked
|> (crashed, don't know the right word). Then I decided to use the
|> Seagate HD for Linux and the IBM HD for DOS. The Seagate HD works well
|> with Linux and the IBM HD with DOS.
|> Now I have the problem when accessing the DOS partition from Linux the
|> SCSI Bus locks sometimes and I have to press the reset button.
|>
|> Is there anybody knowing something about this problem. Is the there a
|> solution or workaround (new firmware for the IBM or newer kernel or
|> patch?)
|>
|>  
|> Cheers
|>         Matthias
|>
|> --
|> ------------------------------------------------------------------------------
|> Matthias Hammer
|> FG Flugmechanik und Regelungstechnik       Dept. Flightmechanics and Control
|> THD - FB 16                                Technical University of Darmstadt
|> Petersenstrasse 30
|> 64287 Darmstadt
|> Germany
|>
|> Tel.:  +49 6151 16-6569         FAX: +49 6151 16-5434

|> ------------------------------------------------------------------------------

I have a similar configuration (0:IBM 662, 1:IBM DPES, ...). When I
installed the IBM DPES-31080 the first time, I had the same hangups as
you did. I was shocked, because I didn't knew a solution for that.
From a news article I got the hint to disable `SCSI disconnect' feature
for the drive in the AHA-1542C's configuration. I did it and since than
the problems are gone (even though I ask myself, what implications this
might have on the system -- I don't know what the SCSI disconnect feature
means, and maybe there is a more adequate solution for this problem).

Hope this helps

--Franz

PS: If someone reading my article can explain what `SCSI disconnect'
    is good for, I would be thankfull if he could post an explanation
    or e-mail me.
______________________________________________________________________

 IBM - European Networking Center       Tel.: +49 6221 59-4563

 D-69115 Heidelberg                     VM:   mazvm01(fackel)

 
 
 

Adaptec 1542CF, IBM DPES-31080, SCSI Probs

Post by Bernd Brinkma » Wed, 06 Sep 1995 04:00:00


: PS: If someone reading my article can explain what `SCSI disconnect'
:     is good for, I would be thankfull if he could post an explanation
:     or e-mail me.
: ______________________________________________________________________

disconnection allow the device to sign off the bus and work on its on,
so that the system has not to wait for the result of the
requested operation.
This is useful for example if you rewind a tape.
If you don't use disconnection for the tape, the system stops
until the tape is rewinded.
For disks this is not so important.
I guess the problem is, that the IBM-disk cannot reconnect to
the controller for some reason.
As I said before this seems to be a problem only
with Adaptec and IBM.

Bernd
--
******************************************************************************

*. 63743 Aschaffenburg ......................................................*
*. Germany ..................................................................*

 
 
 

1. SOLUTION: Adaptec 1542CF, IBM DPES 31080 and other SCSI devices

I have posted the following problem some days ago:

Now I got a very good and fast support from IBM. Here is the solution
for all the people out there with a similar problem:

Reply from IBM:

The Adaptec 1542CF has a Bug in the BIOS before 2.10. With the BIOS
and the Microcode 2.10 the SCSI lock problem with IBM DPES-31080 is solved.
The new code can be obtained at http://www.adaptec.com, the file is
called CF154X.EXE. You must have an EPROM burner to get the files
installed (and two EPROM's to keep the old ones until you know it
works. I had no problems with it).
Otherwise you must order them from Adaptec.

Matthias Hammer

--
------------------------------------------------------------------------------
Matthias Hammer
FG Flugmechanik und Regelungstechnik       Dept. Flightmechanics and Control
THD - FB 16                                Technical University of Darmstadt
Petersenstrasse 30
64287 Darmstadt
Germany

Tel.:  +49 6151 16-6569         FAX: +49 6151 16-5434

------------------------------------------------------------------------------

2. lm_sensors - a little help?

3. Adaptec AHA-1742 with IBM DPES-31080 harddisk

4. TCP problems ?

5. IBM 1Gb DPES-31080 on Solaris 2.5

6. configuring debian

7. Adaptec 1515 with IBM DPES 31080

8. How to set up a PPP server?

9. Adaptec 1542 + IBM DPES 31080 + Kernel 1.2.11 Problem

10. Asus SC200 and IMB DPES-31080, Linux-1.3.50

11. IBM 1GByte disk (DPES 31080) crashes Slackware with 1.2.13 (repost)

12. problems at recognition of HDs: COMPAQPC(IBM) DPES-31080, QUANTUM FIREBALL ST3.2S and SEAGATE ST-124

13. prob with IBM 730MB hd + AHA 1542CF