Can someone help me with a CHINON CDS-535 CD-ROM?

Can someone help me with a CHINON CDS-535 CD-ROM?

Post by Carlos O'Ry » Mon, 03 Jul 1995 04:00:00



Hi,
        I was wondering if some kind soul could point me to the right
FAQ or HOWTO (or even better mail me some info).
        I hace a CHINON CDS-535 SCSI CD-ROM, somehow the thing is not
working, it mounts OK, but after reading a couple of blocks it just
hangs. I checked that both mounting and reading some files or
directories and using dd.

        I have checked the SCSI-HOWTO and some other FAQ to no avail.
        Any other document, source code, folklore, anything!!! I
should checkt?

--

#include <std.disclaimer>
#include <cute.quote> // "Speak softly and carry a megawatt laser"
--
--

#include <std.disclaimer>
#include <cute.quote> // "Speak softly and carry a megawatt laser"

 
 
 

Can someone help me with a CHINON CDS-535 CD-ROM?

Post by Ken L » Tue, 04 Jul 1995 04:00:00




Quote:>    I hace a CHINON CDS-535 SCSI CD-ROM, somehow the thing is not
>working, it mounts OK, but after reading a couple of blocks it just
>hangs.

What SCSI controller are you using?  My Chinon 535 works fine with an
Adaptec 1522 controller.

Ken

_______


 
 
 

Can someone help me with a CHINON CDS-535 CD-ROM?

Post by Clint davi » Tue, 04 Jul 1995 04:00:00


Mine works fine with FD-168x controller.  Give us some info on your setup
 and messages that appear when you boot Linux.

Clint
--
"All the world is my country and all mankind are my brethren,
 and to do good is my religion."
          -- Thomas Paine

 
 
 

Can someone help me with a CHINON CDS-535 CD-ROM?

Post by Stephen M. Gue » Wed, 05 Jul 1995 04:00:00


Just to let you all know that I got my Chinon working with an

stating that he uses the following command

aha152x=0x340,11,7,0
                   ^
                   !

Note that last 0, that is not the default but that works the
magic on my machine.  It believe it does some type of
connect/disconnect enabling/disabling.  Finally, after months,
and after dowloading the slackware release over the internet, I
have my CD-ROM working.  Maybe this simple little '0' will help
someone else who has been having the same problem.

Stephen

 
 
 

Can someone help me with a CHINON CDS-535 CD-ROM?

Post by Stephen M. Gue » Wed, 05 Jul 1995 04:00:00


     I am having the same problem with a Chinon 535 and a Adaptec 1520.
It seems to mount with no error messages and you can get just a little
bit of info out of it (like listing a small directory).  Anything more
than that and it sits for about 3 minutes with the CD activitly light on
solid and then it comes up with an error message along the lines of
(can't remember exactly) wrong mount type or bad (boot or super?) block.
     Glad to know someone has essentially the same thing working.  What
are the jumper settings that you are using on the 1522.  Maybe I have
one wrong.
     Thanks for any info.

Stephen




>>       I hace a CHINON CDS-535 SCSI CD-ROM, somehow the thing is not
>>working, it mounts OK, but after reading a couple of blocks it just
>>hangs.

>What SCSI controller are you using?  My Chinon 535 works fine with an
>Adaptec 1522 controller.

>Ken

>_______


 
 
 

Can someone help me with a CHINON CDS-535 CD-ROM?

Post by Joel N. Squi » Wed, 05 Jul 1995 04:00:00



        I am having the same problem with a Chinon 535 and a Adaptec 1520.
   It seems to mount with no error messages and you can get just a little
   bit of info out of it (like listing a small directory).  Anything more
   than that and it sits for about 3 minutes with the CD activitly light on
   solid and then it comes up with an error message along the lines of
   (can't remember exactly) wrong mount type or bad (boot or super?) block.
        Glad to know someone has essentially the same thing working.  What
   are the jumper settings that you are using on the 1522.  Maybe I have
   one wrong.
        Thanks for any info.

   Stephen

Just for another data point, my Chinon CDS 435 (the old single speed) has
the same problem (or so it seems). It seems to dislike sections of CDs, so
that most directory reads and mounts work fine, but most file accesses
cause a series of spin-up and spin-downs until it dies with an error. Music
plays back fine though, so the problem doesn't seem very obvious. I bought
it cheap, so I can't complain too much. If anyone has any ideas about this
I would be delighted to hear them.


--

                      .oO finger for PGP key Oo.

 
 
 

Can someone help me with a CHINON CDS-535 CD-ROM?

Post by Carlos O'Ry » Thu, 13 Jul 1995 04:00:00


Hi,
        Thanks to all the people who answered to my help request, in
fact I should have included the SCSI card I was using (an Adaptec 152X
BTW), but fortunately somelese (Stephen Guest) provided me with the
right incantation, namely:

aha152x=0x340,11,7,0

on the boot prompt. That last cero does the trick, it disables the
"reconnect" option (whatever that may means).
        My guess is that I should expect some performance problem,
hope that it is not too big.

        I wonder if the problem lays on the aha152x driver or in
the CD-ROM? just out of curiosity...

                Thanks again.

--

#include <std.disclaimer>
#include <cute.quote> // "Speak softly and carry a megawatt laser"
--
--

#include <std.disclaimer>
#include <cute.quote> // "Speak softly and carry a megawatt laser"

 
 
 

1. Problem in using PAS16 + Chinon cd-rom CDS-535


                <more stuff deleted>

    system hangs here

 The Chinon drive is your problem.  Apparently it does not like being polled
 for multiple logical units.

 While filling out the recent hardware survey in linux.announce, I realized
 I hadn't sent this fix to anyone.  My apologies.

 When I would try to boot the Slackware 1.1.1 boot floppy my system would
 hang just after printing a message about resetting for second half retries.
 I finally got my system up by borrowing a friend's Toshiba CD-ROM, installing,
 and then building a kernel with the Chinon drive added to the blacklist.

 My system is a 486-66 with an ultrastor 34F and a Conner CP30540 drive.

 >1.16) CD ROM questions:
 >
 >Manufacturer:Chinon
 >Model:CDS-535
 >Type [IDE/SCSI]:SCSI
 >ALPHA? [Y/N]:
 >Comments:
 I had major problems getting this drive to work.  My solution was to add the
 following line to the blacklist array in drivers/scsi/scsi.c
    {"CHINON","CD-ROM CDS-535","Q14"},
 This was still necessary after upgrading the firmware to rev Q20.

Galen Seitz

2. gcc 2.5.8

3. Chinon CDS-535 CD-ROM/Sound Blaster 16 SCSI-2 Mount problems

4. wireless bridge turned router

5. Problem with PAS 16 & Chinon CDS-535 CD-ROM Drive

6. CD-Writer

7. Chinon 535 CD ROM and Chinon SCSI controller - driver?

8. 2.5.66 buglet

9. Chinon 535 CD-ROM Cannot Run With Linux?.

10. Chinon 535 CD-ROM and Adap. 1520

11. Anyone using Linux with PAS-16 SCSI and Chinon 535 CD-ROM??

12. Chinon CDS-535 HELP

13. Adaptec AHA-151x, Chinon CDS-535 install problems.