redhat won't probe 2nd ne2000 card

redhat won't probe 2nd ne2000 card

Post by Donald Beck » Wed, 10 Sep 1997 04:00:00





>im trying to set up a second ethernet card and i've edited my lilo.conf
>file and executed lilo, but
>when i boot it ,it probes for eth0 but when it should probe for eth1 it
>reports that it is delaying init for this card..

RedHat uses "modules" for most device drivers, thus the LILO parameters
aren't used.

If you have two ethernet cards and only one is detected do the following:

   1) As root, run X.  The "control-panel" should start up.

   2) Select the "kernel daemon configuration" tool in the control panel.

   3) Entry the following as the argument aka "options" for the ne driver:
        io=0x300,0x280
      (assuming your NE2000 cards are at 0x300 and 0x280)
   3) Restart kerneld using the button

--

USRA-CESDIS, Center of Excellence in Space Data and Information Sciences.
Code 930.5, Goddard Space Flight Center,  Greenbelt, MD.  20771
301-286-0882         http://cesdis.gsfc.nasa.gov/pub/people/becker/whoiam.html

 
 
 

1. redhat won't probe 2nd ne2000 card

 > im trying to set up a second ethernet card and i've edited my
lilo.conf
 > file and executed lilo, but
 > when i boot it ,it probes for eth0 but when it should probe for eth1
it
 > reports that it is delaying init for this card..

 > what do i do???

Well, without knowing what you _did_, we can't tell you what you did
wrong and/or what you should do. You edited lilo.conf, but what did you
put in it?
What brand/model are your ethernet cards, and how are they configured?
Are you using kerneld and/or modules? If so, all the lilo.conf editing
in the world won't help, since those parameters are passed to the
kernel, not the loadable modules. In that case, you have to
appropriately edit /etc/modules.conf, or /etc/conf.modules, but I don't
recall exactly how now.

It is "delating eth1 initialization" at the point where the cards are
configured for IP address and such, not where their drivers are loaded.

2. Experience with SunLink ISDN Cards

3. HELP - 2nd NE2000 card not being probed

4. When can time(2) return 0?!

5. Option in Redhat 4.1 to 'turn on' detection of 2nd ethernet card?

6. mod_rewrite Help!

7. Ethernet problem - NE2000 (probe's okay) but can't route

8. Compaq DPW Workstation

9. redhat disk druid won't use 2nd disk

10. HELP! NE2000 Ethernet card won't work!

11. Pulled out 2nd NIC card, now linux won't boot

12. Linux 1.2.13 won't recognize GVC ethernet card (in NE2000 or WD8013 mode)

13. Redhat 5.1 doesn't probe my network card