Does Teles S0/PCI - Tj ISDN card work on Linux 2.0.36

Does Teles S0/PCI - Tj ISDN card work on Linux 2.0.36

Post by Ya-houn So » Thu, 11 Mar 1999 04:00:00



Has anyone got the Teles S0/PCI card to work with linux?.

Have been trying to get the hisax driver to recognize the card (Teles
S0/PCI) but to no avail.

The isdn subsystem is compiled as modules then tried

/sbin/modprobe hisax protocol=2 type=21
(type=21 being Teles PCI does this refer to the Teles S0/PCI or to
something else?)

to check if the drivers recognize the card. But all I got was this:

ISDN subsystem Rev: 1.44.2.9/1.41.2.11/1.48.2.27/1.28.2.2/1.8.2.2 loaded
TelesPCI: No PCI card found
HiSax: Card Teles PCI not installed !
/lib/modules/2.0.36/misc/hisax.o: init_module: Device or resource busy
ISDN-subsystem unloaded

Anybody have any ideas what I'm doing wrong? Any help will be greatly
appreciated. TIA.

More Info:

more /proc/pci shows:

PCI devices found:
  Bus 0, device 15, function 0:
    Network controller: Unknown vendor Tiger300 ISDN (rev 0).
      Medium devsel.   IRQ 10.   Master Capable. Latency=8.
      I/O at 0xe800.
      Non-prefetchable 32 bit memory at 0xe7000000.

Compiled the kernel with the '.config' with ISDN options as below:

#
# ISDN subsystem
#
CONFIG_ISDN=m
CONFIG_ISDN_PPP=y
CONFIG_ISDN_MPP=Y
CONFIG_ISDN_AUDIO=Y
CONFIG_ISDN_DRV_LOOP=M
CONFIG_ISDN_DRV_HISAX=M
CONFIG_HISAX_EURO=Y
CONFIG_HISAX_16_0=Y
CONFIG_HISAX_16_3=Y
CONFIG_HISAX_TELES3C=Y
CONFIG_HISAX_TELESPCI=Y
CONFIG_HISAX_S0BOX=Y

Once again TIA.

 
 
 

1. Teles 16.3c ISDN card + kernel 2.0.36

Hi,

Anybody got a Teles 16.3c ISA PnP ISDN card working with
Linux kernel 2.0.36??

I've compiled the ISDN subsystem as a module...
HiSax drivers as modules... here's the relevant section in
the .config file...

CONFIG_ISDN=m
CONFIG_ISDN_PPP=y
CONFIG_ISDN_PPP_VJ=y
CONFIG_ISDN_MPP=y
CONFIG_ISDN_DRV_LOOP=m
CONFIG_ISDN_DRV_HISAX=m
CONFIG_HISAX_EURO=y
CONFIG_HISAX_16_0=y
CONFIG_HISAX_16_3=y
CONFIG_HISAX_TELES3C=y
CONFIG_HISAX_TELESPCI=y
CONFIG_HISAX_S0BOX=y

Booted with this kernel... got isapnp to load the following isapnp.conf..

(CONFIGURE TAG2620/209717183 (LD 0
(IO 0 (SIZE 2) (BASE 0x0300))
(INT 0 (IRQ 10 (MODE +E)))
(NAME "TAG2620/209717183[0]{TELES.S0/16.3c Plug&Play}")
(ACT Y)
))

ran isapnp and got ...

Board 1 has Identity 76 04 03 02 01 00 20 32 0d:  CIR2000 Serial No 67305985 [checksum 76]
Board 2 has Identity bd 0c 80 07 bf 20 26 27 50:  TAG2620 Serial No 209717183 [checksum bd]
TAG2620/209717183[0]{TELES.S0/16.3c Plug&Play}: Port 0x300; IRQ10 --- Enabled OK

BUT when i tried to load the HiSax modules by modprobe... i
got the following errors...

# modprobe hisax type=14 protocol=2 io=0x300 irq=10
Initialization of hisax failed
Initialization of hisax failed
ISDN subsystem Rev: 1.44.2.9/1.41.2.11/1.48.2.27/1.28.2.2/none loaded
Teles 16.3c: IRQ(10) getting no interrupts during init 1
Teles 16.3c: IRQ(10) getting no interrupts during init 2
Teles 16.3c: IRQ(10) getting no interrupts during init 3
HiSax: Card Teles 16.3c not installed !
Initialization of hisax failed
ISDN-subsystem unloaded

What could be the problem? any ideas?

regards,

John Wong

2. Output filters in Solaris

3. Linux & Teles S0 isdn-Card ?

4. Ghostscript 5.10

5. TELES S0/PCI ISDN adapter, any HOWTO out there ?

6. CALDERA NETWORK DESKTOP

7. ISDN Teles S0 PCI

8. Simple 4U X video Question

9. Teles S0 PCI ISDN-adaptor

10. Teles S0 ISDN card and fax

11. Installing a Teles S0.16/3 ISDN card (PnP)

12. Problem with a Teles.S0/PnP ISDN card

13. Teles S0-16/3c PnP ISDN Card