access to 2s SCSI card

access to 2s SCSI card

Post by guy.. » Wed, 01 Nov 2000 13:00:28



I run redHat 6.2 with an inboard SCSI card (adaptec 160M). 2 disks are
connected on this card and linux boot on one of them (sda).
I add another IDE SCSI card (adaptec 160M) to connect external devices
(zip 250 and Dat).

First, I don't change the standard configuration of the cards. But I saw
that Linux didn't reconize the boot disk because he look on SCSI-0, and
SCSI-0 was the IDE card (not the inboard card).
I look on the adaptec reference guide and see that I have to configure
the second card with "no BIOS" with 'crtl-A'.
So, I configure the IDE card with 'no BIOS' (I select scan Bus). Now
Linux reconize my boot disk sda on the SCSI-0 (inboard SCSI card), and
all my devices are seen. This is the result of dmesg command:

(scsi0) <Adaptec AIC-7892 Ultra 160/m SCSI host adapter> found at PCI
1/3/0
(scsi0) Wide Channel, SCSI ID=7, 32/255 SCBs
(scsi0) Downloading sequencer code... 396 instructions downloaded
enable_irq() unbalanced from e081b401
(scsi1) <Adaptec AIC-7892 Ultra 160/m SCSI host adapter> found at PCI
1/1/0
(scsi1) Wide Channel, SCSI ID=7, 32/255 SCBs
(scsi1) Downloading sequencer code... 396 instructions downloaded
enable_irq() unbalanced from e081b401
scsi0 : Adaptec AHA274x/284x/294x (EISA/VLB/PCI-Fast SCSI) 5.1.28/3.2.4
       <Adaptec AIC-7892 Ultra 160/m SCSI host adapter>
scsi1 : Adaptec AHA274x/284x/294x (EISA/VLB/PCI-Fast SCSI) 5.1.28/3.2.4
       <Adaptec AIC-7892 Ultra 160/m SCSI host adapter>
scsi : 2 hosts.
(scsi0:0:0:0) Synchronous at 160.0 Mbyte/sec, offset 31.
  Vendor: SEAGATE   Model: ST39236LW         Rev: 0004
  Type:   Direct-Access                      ANSI SCSI revision: 03
Detected scsi disk sda at scsi0, channel 0, id 0, lun 0
(scsi0:0:2:0) Synchronous at 160.0 Mbyte/sec, offset 31.
  Vendor: SEAGATE   Model: ST39236LW         Rev: 0004
  Type:   Direct-Access                      ANSI SCSI revision: 03
Detected scsi disk sdb at scsi0, channel 0, id 2, lun 0
(scsi0:0:6:0) Synchronous at 20.0 Mbyte/sec, offset 16.
  Vendor: TOSHIBA   Model: CD-ROM XM-6401TA  Rev: 1001
  Type:   CD-ROM                             ANSI SCSI revision: 02
Detected scsi CD-ROM sr0 at scsi0, channel 0, id 6, lun 0
(scsi1:0:5:0) Synchronous at 40.0 Mbyte/sec, offset 32.
  Vendor: HP        Model: C5683A            Rev: C908
  Type:   Sequential-Access                  ANSI SCSI revision: 02
  Vendor: IOMEGA    Model: ZIP 250           Rev: H.41
  Type:   Direct-Access                      ANSI SCSI revision: 02
Detected scsi removable disk sdc at scsi1, channel 0, id 6, lun 0
Uniform CDROM driver Revision: 2.56
SCSI device sda: hdwr sector= 512 bytes. Sectors= 17942584 [8761 MB]
[8.8 GB]
 sda: sda1 sda2 < sda5 sda6 sda7 sda8 sda9 sda10 sda11 >
SCSI device sdb: hdwr sector= 512 bytes. Sectors= 17942584 [8761 MB]
[8.8 GB]
 sdb: sdb1 sdb2 < sdb5 >
sdc : READ CAPACITY failed.
sdc : status = 1, message = 00, host = 0, driver = 28
sdc : extended sense code = 2
sdc : block size assumed to be 512 bytes, disk size 1GB.
 sdc:scsidisk I/O error: dev 08:20, sector 0
 unable to read partition table

But, the problem is that I can't access to the devices on SCSI-1.
I can't read old data my zip disk (100M or 250M), but I can write and
read new data ....
sdc : READ CAPACITY failed.
sdc : status = 1, message = 00, host = 0, driver = 28
sdc : extended sense code = 2
sdc : block size assumed to be 512 bytes, disk size 1GB.
 sdc:scsidisk I/O error: dev 08:20, sector 0
 unable to read partition table
VFS: Disk change detected on device fd(2,0)
end_request: I/O error, dev 02:00 (floppy), sector 0
VFS: Disk change detected on device fd(2,0)
end_request: I/O error, dev 02:00 (floppy), sector 0
VFS: Disk change detected on device sd(8,36)
SCSI device sdc: hdwr sector= 512 bytes. Sectors= 196608 [96 MB] [0.1
GB]
sdc: Write Protect is off
 sdc: sdc4

It is the same with the Dat. I can't write on nst0 (tar cf /dev/nst0
/etc), but I can read the content of an old Dat (tar tvf /dev/nst0) ...
st0: Error with sense data: [valid=0] Info fld=0x0, Current st09:00:
sense key Aborted Command
Additional sense indicates Data phase error
st0: Error with sense data: [valid=0] Info fld=0x0, Current st09:00:
sense key Aborted Command
Additional sense indicates Data phase error
st0: Error with sense data: [valid=0] Info fld=0x0, Current st09:00:
sense key Aborted Command
Additional sense indicates Data phase error

What is the problem ??
Do I have to insert a module driver for the devices on SCSI-1 ?
Perhaps the configuration of SCSI cards is not correct ??

Thanks to help me.
Pierre

Sent via Deja.com http://www.deja.com/
Before you buy.

 
 
 

1. - A Great Mystery - Can NOT boot from Quantum SE3.2S SCSI ????

This has me foxed.

I have a Quantum Fireball SE3.2S SCSI hard drive. I can run it as a second or
third drive, but I can not run it as a BOOT drive. If I try to set it up as the
primary drive, it get i/o errors, and hangs, or on the install process, panics
and goes for reboot.

I can use disklabel to set it up, no complaints - wont boot
I try to use /stand/sysinstall to set it up, and when it tries to write the
partition information to the drive, it panics, and goes for reboot.

I can't believe this. If it works as a secondary drive, why can't I set it up
any way as a boot drive?

Does anyone have any experience of this?

thanks for any help,
Bob
--
Support Whirled Peas.      Business in China?          China House

http://www.chalmers.com.au/ChinaHouse/Business/webposition  
http://www.chalmers.com.au/ChinaHouse/Business/net2phone.html
http://www.chalmers.com.au/ChinaHouse/Business/vpay/vpay.html

2. lost+found

3. Need patch NetMos 9835 for 2S PCI card

4. C/C++ development system ?

5. Multitech ISIHP-2S card config ?

6. Is this spoofing ???

7. VLB IDE/floppy/2S/P card recommendation

8. fetch of http source - weird results

9. difference between dual-single ended scsi card and single ended scsi card

10. ! NCR 53c810 SCSI card, TeraSys Magneto-Optical Drive: no access

11. SCSI: Does one need a special SCSI LVD adapter, over and above a SCSI card?

12. Race conditions while accessing /proc/scsi/scsi

13. X server with prodesigner 2s (Hicolor)