sndconfig locks up RH 5.2

sndconfig locks up RH 5.2

Post by Simon Anderso » Fri, 27 Aug 1999 04:00:00



I have a SB 32 PNP  ISA card. isapnp finds it, but there is still no
sound. So I tried sndconfig and my machine locked up. Do I have to
recompile the kernel with sound support? I tried make config as root and
got :

No rule to make target 'config'. Stop.

I'm using RedHat 5.2 , how do I tell if I have support for sound alredy
installed in the kernel?

I could really like this Linux thing if I could get some tunes!!

Thanks!
Simon

 
 
 

sndconfig locks up RH 5.2

Post by Holecz Endr » Wed, 01 Sep 1999 04:00:00



> I have a SB 32 PNP  ISA card. isapnp finds it, but there is still no
> sound. So I tried sndconfig and my machine locked up. Do I have to
> recompile the kernel with sound support? I tried make config as root and
> got :

> No rule to make target 'config'. Stop.

Try to go into the kernel sources directory first. Usually /usr/src/linux.

Quote:

> I'm using RedHat 5.2 , how do I tell if I have support for sound alredy
> installed in the kernel?

> I could really like this Linux thing if I could get some tunes!!

> Thanks!
> Simon

Endre

 
 
 

1. Audio: sndconfig not working on RH 5.2

(Running RedHat 5.2 on a Compaq 4764)

For some odd reason, I can't seem to configure my sound device.
Compaqs use a chip (not a real sound card), and on RedHat 5.1,
I had no trouble configuring the sound 'chip' using sndconfig.
All I had to do was mess with the IRQ, DMA, and the address
a few times, and walla!  I eventually discovered the right settings.

Now, however, on RH 5.2, I can't get anything to work.  When the
configurator tries to kick in, I get an error message, something along
the lines of 'cannot open /dev/audio'.  Don't know why!

If I try to use 'wavplay' on a sound file, I receive the following
message:

Operation not supported by device:
Opening audio device /dev/dsp

I'm a bit perplexed in this.  I don't know what the device 'dsp' is
used for, and why the audio is trying to route through that.

Anyone have any thoughts on this (and why the hell I can't get
sndconfig up and runnin')?

2. subscribe

3. sndconfig and RH 5.2

4. Question: heapsize, stacksize, compilers

5. RH 5.2 no sndconfig?

6. talk error

7. FTP RH 5.2 -> RH 5.2 = NFT (No File Transfer)

8. undefined symbol _malloc_rmutex

9. Red Hat 5.2 Loadlin HOWTO (WAS: Can't install LILO from RH 5.2)

10. Tulip Driver worked under RH 5.0, doesn't under 5.2 or SuSE 5.2, any ideas?

11. sndconfig on redhat 5.2

12. redhat 5.2 no sndconfig file

13. RedHat 5.2 - sndconfig - SB AWE64 - HELP