sound SIS 7012(AC97) help

sound SIS 7012(AC97) help

Post by lassa » Wed, 09 Apr 2003 19:41:28



Good day !

I have just instaled Redhat 9 and I've got a small problem. So, my sound
card (in topic) is not working. I mean that I run sndconfig and he say that
this card is supported but it is disable and he advise me to turn off BIOS
option "PnP OS". It wouldn't be anything wrong in that but ... I don't have
such option in my BIOS (100%). So is that anything else that I can do about
this, for example some manual settings. If you know sth I would be gratefull
for any informations.

P.S. It is laptop so new sound card ... rather not :(

thx anyway :P

 
 
 

sound SIS 7012(AC97) help

Post by Bram Bouwen » Wed, 09 Apr 2003 20:23:31



>Good day !
>I have just instaled Redhat 9 and I've got a small problem. So, my sound
>card (in topic) is not working. I mean that I run sndconfig and he say that
>this card is supported but it is disable and he advise me to turn off BIOS
>option "PnP OS". It wouldn't be anything wrong in that but ... I don't have
>such option in my BIOS (100%). So is that anything else that I can do about
>this, for example some manual settings. If you know sth I would be gratefull
>for any informations.

I got a L7S7A2 mobo which also has sis7012 on board.

    Multimedia audio controller: Silicon Integrated Systems [SiS] SiS7012 PCI
Audio Accelerator (rev 160).
      IRQ 10.
      Master Capable.  Latency=64.  Min Gnt=52.Max Lat=11.
      I/O at 0xdc00 [0xdcff].
      I/O at 0xd400 [0xd47f].

But in dmesg:

i810: SiS 7012 found at IO 0xd400 and 0xdc00, IRQ 10
i810_audio: Audio Controller supports 6 channels.
ac97_codec: AC97  codec, id: 0x434d:0x4961 (Unknown)
i810_audio: only 48Khz playback available.
i810_audio: AC'97 codec 0, new EID value = 0x05c6
i810_audio: AC'97 codec 0, DAC map configured, total channels = 6

There is sound, but the mixer (kmix) shows `Unknown' as the name,
and the sound is either as max volume (earplugs required) or off.
This is on a 2.4.19 kernel BTW, I hope we'll get 2.4.21 soon to get
proper support for the SiS746; IDE DMA doesn't work now.

Bram

 
 
 

1. SiS 7012 sound card not working

hi all,
i have a sony vaio with a SiS 7012 sound card which will not work under Red
Hat 8.0.  I tried the driver from the SiS linux driver site, but it spit out
a bunch of errors when i used the install script, and now it says some stuff
when i boot about "blah blah blah.o will taint the kernel" or something. can
anyone help me with this please?

thanks in advance,
Stuart

2. problem with IP multicasting

3. ECS k7s5a audio sound SiS 735 - 7012

4. blocking inline images with mod_rewrite

5. SiS 7012 sound card wont work

6. Floppy on AlphaStation

7. Sound record vs RH9/SIS 7012

8. Lost in space

9. ECS k7s5a audio sound SiS 735 - 7012

10. SIS 7012 audio and SIS 650 grpahic

11. SiS 7012 under Red Hat 8.0

12. Asus P4S8X - SiS 7012 audio with C-Media 9739 codec

13. SiS 7012 config Patch for 2.4.20-dj2