Linksys BEFSR41 - no browser access in linux?

Linksys BEFSR41 - no browser access in linux?

Post by R S Priga » Sun, 20 Jan 2002 02:53:40



<posted & mailed>

I have a Linksys BEFSR41 router/switch, and find no browser access in linux!

"Connection refused" ... "Could not connect to host" ...

Same in Netscape, Konquerer, Mozilla, Galeon, ...??

I'd swear I used to be able to connect!

I can ping it. It works for routing. It refuses ftp!
        ftp> open 192.168.1.1
        ftp: connect: Connection refused)

This situation is the same with various BEFSR41 firmware, including: 1.37,
1.39, 1.40-2

Any ideas?

Scott

 
 
 

Linksys BEFSR41 - no browser access in linux?

Post by Chris Co » Sun, 20 Jan 2002 03:07:06



> <posted & mailed>

> I have a Linksys BEFSR41 router/switch, and find no browser access in linux!

> "Connection refused" ... "Could not connect to host" ...

> Same in Netscape, Konquerer, Mozilla, Galeon, ...??

> I'd swear I used to be able to connect!

> I can ping it. It works for routing. It refuses ftp!
>         ftp> open 192.168.1.1
>         ftp: connect: Connection refused)

You may want to try using tftp... just an idea though.

 
 
 

Linksys BEFSR41 - no browser access in linux?

Post by One Shama » Sun, 20 Jan 2002 16:37:58




Quote:>This situation is the same with various BEFSR41 firmware, including: 1.37,
>1.39, 1.40-2

I have a BEFSR11 (1.39 firmware) and a separate Linksys 5 port switch.
I just installed SuSE 7.3 on two PCs connected to these devices, and
everything worked perfectly with no hassles.

Make sure you are using the DCHP server in the LInksys router. If you
manually set your own static IP address and try to use this with the
Linksys NAT, you will get the result you describe.
--
Jim

 
 
 

Linksys BEFSR41 - no browser access in linux?

Post by Theodore Hei » Mon, 21 Jan 2002 02:47:36


On Sat, 19 Jan 2002 07:37:58 GMT,

Quote:> Make sure you are using the DCHP server in the LInksys router. If you
> manually set your own static IP address and try to use this with the
> Linksys NAT, you will get the result you describe.

I have set my own IP address on my RH 7.2 box (not using DHCP), and can
log on to my Linksys 4-port "router" with Lynx--he may need to check that
the right password is being used.

--

 
 
 

Linksys BEFSR41 - no browser access in linux?

Post by Phil Bake » Tue, 22 Jan 2002 23:22:39



> <posted & mailed>

> I have a Linksys BEFSR41 router/switch, and find no browser access in linux!

> "Connection refused" ... "Could not connect to host" ...

> Same in Netscape, Konquerer, Mozilla, Galeon, ...??

> I'd swear I used to be able to connect!

> I can ping it. It works for routing. It refuses ftp!
>         ftp> open 192.168.1.1
>         ftp: connect: Connection refused)

> This situation is the same with various BEFSR41 firmware, including: 1.37,
> 1.39, 1.40-2

> Any ideas?

> Scott

I have had better luck using Opera to get into the web-based admin page
of my Linksys 4-port router.  I keep Opera around just for that reason.

Phil

 
 
 

Linksys BEFSR41 - no browser access in linux?

Post by Mav » Fri, 25 Jan 2002 00:03:20


--
Linux
Registered User 163862


> > <posted & mailed>

> > I have a Linksys BEFSR41 router/switch, and find no browser access in
linux!

> > "Connection refused" ... "Could not connect to host" ...

> > Same in Netscape, Konquerer, Mozilla, Galeon, ...??

> > I'd swear I used to be able to connect!

> > I can ping it. It works for routing. It refuses ftp!
> >         ftp> open 192.168.1.1
> >         ftp: connect: Connection refused)

> > This situation is the same with various BEFSR41 firmware, including:
1.37,
> > 1.39, 1.40-2

> > Any ideas?

> > Scott

> I have had better luck using Opera to get into the web-based admin page
> of my Linksys 4-port router.  I keep Opera around just for that reason.

> Phil

I have the BEFSR41 and can access with Netscape, Konquerer, Mozilla, Opera,
etc... but I go in http not ftp.  I Just type the IP in the Address area,
then I'm asked for the password....
Could that be your issue?

Dave

 
 
 

Linksys BEFSR41 - no browser access in linux?

Post by Sergei Rodiono » Fri, 25 Jan 2002 00:43:29


Eh?

I am using SuSE 7.3 (at the moment.. used to play with Corel, Mandrake
8.0/8.1, SuSE 7.1, 7.2) - all worked without any problems with any kind of
browsers via my BEFSR11 + Linksys switch box...

are you sure you didnt set up some strange routing in your linksys thingy?
I.e what mode you using it exactly in? Router or gateway? Any filtering?

I doesnt look for me like much of Linux issue, b/c i had same behavior (not
much of outside inet access) under WinXP box that i got here, when i has
been playing with settings in BESFR..

Cheers,
Sergei

 
 
 

Linksys BEFSR41 - no browser access in linux?

Post by R S Priga » Fri, 25 Jan 2002 03:32:00


I thought I might have stumbled upon the solution to the problem, when I
found needed to change ipchains from RH 7.2 default to get Samba  to work
-- but NO.

Can't even get it to work if I stop ipchains and iptables in SysV control.

No luck FTP either ...

No login prompt to supply pw for http://192.168.1.1 or ftp://...

Does not work in konquerer, netscape, galeon, mozilla, opera, lynx, ... no
ftp from terminal ...

I use DHCP from the router, except for the network printer which has fixed
address (set on the printer.) I don't have any static routing tables set up
on the router.

!? ** It WORKS in Caldera eServer 3.1! *** ... (Someone else also noted the
same problem with M$'s newest) ...

I reset the router to factory defaults - on the "password" page (except for
enabling logging on "log" page) ...   still NO

hosts.allow and hosts deny are empty.

Must be some configuration issue, but where?




>>This situation is the same with various BEFSR41 firmware, including: 1.37,
>>1.39, 1.40-2

> I have a BEFSR11 (1.39 firmware) and a separate Linksys 5 port switch.
> I just installed SuSE 7.3 on two PCs connected to these devices, and
> everything worked perfectly with no hassles.

> Make sure you are using the DCHP server in the LInksys router. If you
> manually set your own static IP address and try to use this with the
> Linksys NAT, you will get the result you describe.
> --
> Jim

 
 
 

Linksys BEFSR41 - no browser access in linux?

Post by M. Buchenried » Fri, 25 Jan 2002 05:04:10



[...]

Quote:>!? ** It WORKS in Caldera eServer 3.1! *** ... (Someone else also noted the
>same problem with M$'s newest) ...
>I reset the router to factory defaults - on the "password" page (except for
>enabling logging on "log" page) ...   still NO
>hosts.allow and hosts deny are empty.
>Must be some configuration issue, but where?

[...]

Did you disable the ECN kernel support?

Michael

--

          Lumber Cartel Unit #456 (TINLC) & Official Netscum
    Note: If you want me to send you email, don't munge your address.

 
 
 

Linksys BEFSR41 - no browser access in linux?

Post by Colin Grad » Fri, 25 Jan 2002 14:11:17


Be sure to disable TCP Explicit Congestion Notification (ECN) in the kernel
under Networking Options.

Good luck,
Colin



Quote:> <posted & mailed>

> I have a Linksys BEFSR41 router/switch, and find no browser access in
linux!

> "Connection refused" ... "Could not connect to host" ...

> Same in Netscape, Konquerer, Mozilla, Galeon, ...??

> I'd swear I used to be able to connect!

> I can ping it. It works for routing. It refuses ftp!
>         ftp> open 192.168.1.1
>         ftp: connect: Connection refused)

> This situation is the same with various BEFSR41 firmware, including: 1.37,
> 1.39, 1.40-2

> Any ideas?

> Scott

 
 
 

Linksys BEFSR41 - no browser access in linux?

Post by R S Priga » Fri, 25 Jan 2002 23:39:13


<posted & mailed>

I think it IS in kernel! ... the 2.4.9.-21athlon one works okay (but has a
lot of extra hardware stuff I don't need)

DISable??

Does that mean the BEFSR41 is a "broken router?" (according to
Configure.help)

CONFIG_INET_ECN=y seems to be in the athlon default settings from RH 7.2
2.4.9.-21

I have appended stuff from .config from which I built 2.4.17.  Maybe
something else will ring a bell.


> Be sure to disable TCP Explicit Congestion Notification (ECN) in the
> kernel under Networking Options.

> Good luck,
> Colin



>> <posted & mailed>

>> I have a Linksys BEFSR41 router/switch, and find no browser access in
> linux!

>> "Connection refused" ... "Could not connect to host" ...

>> Same in Netscape, Konquerer, Mozilla, Galeon, ...??

>> I'd swear I used to be able to connect!

>> I can ping it. It works for routing. It refuses ftp!
>>         ftp> open 192.168.1.1
>>         ftp: connect: Connection refused)

>> This situation is the same with various BEFSR41 firmware, including:
>> 1.37, 1.39, 1.40-2

>> Any ideas?

>> Scott

-------------------------------------------------
stuff from .config from which I built 2.4.17

#
# Networking options
#
CONFIG_PACKET=y
CONFIG_PACKET_MMAP=y
CONFIG_NETLINK_DEV=y
CONFIG_NETFILTER=y
# CONFIG_NETFILTER_DEBUG is not set
CONFIG_FILTER=y
CONFIG_UNIX=y
CONFIG_INET=y
CONFIG_IP_MULTICAST=y
CONFIG_IP_ADVANCED_ROUTER=y
CONFIG_IP_MULTIPLE_TABLES=y
CONFIG_IP_ROUTE_FWMARK=y
CONFIG_IP_ROUTE_NAT=y
CONFIG_IP_ROUTE_MULTIPATH=y
CONFIG_IP_ROUTE_TOS=y
CONFIG_IP_ROUTE_VERBOSE=y
CONFIG_IP_ROUTE_LARGE_TABLES=y
# CONFIG_IP_PNP is not set
CONFIG_NET_IPIP=m
CONFIG_NET_IPGRE=m
CONFIG_NET_IPGRE_BROADCAST=y
CONFIG_IP_MROUTE=y
CONFIG_IP_PIMSM_V1=y
CONFIG_IP_PIMSM_V2=y
# CONFIG_ARPD is not set
CONFIG_INET_ECN=y
CONFIG_SYN_COOKIES=y

#
#   IP: Netfilter Configuration
#
CONFIG_IP_NF_CONNTRACK=m
CONFIG_IP_NF_FTP=m
# CONFIG_IP_NF_IRC is not set
CONFIG_IP_NF_QUEUE=m
CONFIG_IP_NF_IPTABLES=m
CONFIG_IP_NF_MATCH_LIMIT=m
CONFIG_IP_NF_MATCH_MAC=m
CONFIG_IP_NF_MATCH_MARK=m
CONFIG_IP_NF_MATCH_MULTIPORT=m
CONFIG_IP_NF_MATCH_TOS=m
# CONFIG_IP_NF_MATCH_LENGTH is not set
# CONFIG_IP_NF_MATCH_TTL is not set
CONFIG_IP_NF_MATCH_TCPMSS=m
CONFIG_IP_NF_MATCH_STATE=m
CONFIG_IP_NF_MATCH_UNCLEAN=m
CONFIG_IP_NF_MATCH_OWNER=m
CONFIG_IP_NF_FILTER=m
CONFIG_IP_NF_TARGET_REJECT=m
CONFIG_IP_NF_TARGET_MIRROR=m
CONFIG_IP_NF_NAT=m
CONFIG_IP_NF_NAT_NEEDED=y
CONFIG_IP_NF_TARGET_MASQUERADE=m
CONFIG_IP_NF_TARGET_REDIRECT=m
# CONFIG_IP_NF_NAT_SNMP_BASIC is not set
CONFIG_IP_NF_NAT_FTP=m
CONFIG_IP_NF_MANGLE=m
CONFIG_IP_NF_TARGET_TOS=m
CONFIG_IP_NF_TARGET_MARK=m
CONFIG_IP_NF_TARGET_LOG=m
CONFIG_IP_NF_TARGET_TCPMSS=m
CONFIG_IP_NF_COMPAT_IPCHAINS=m
CONFIG_IP_NF_NAT_NEEDED=y
CONFIG_IP_NF_COMPAT_IPFWADM=m
CONFIG_IP_NF_NAT_NEEDED=y
CONFIG_IPV6=m

#
#   IPv6: Netfilter Configuration
#
CONFIG_IP6_NF_IPTABLES=m
CONFIG_IP6_NF_MATCH_LIMIT=m
# CONFIG_IP6_NF_MATCH_MAC is not set
# CONFIG_IP6_NF_MATCH_MULTIPORT is not set
# CONFIG_IP6_NF_MATCH_OWNER is not set
CONFIG_IP6_NF_MATCH_MARK=m
CONFIG_IP6_NF_FILTER=m
# CONFIG_IP6_NF_TARGET_LOG is not set
CONFIG_IP6_NF_MANGLE=m
CONFIG_IP6_NF_TARGET_MARK=m
# CONFIG_KHTTPD is not set
CONFIG_ATM=y
CONFIG_ATM_CLIP=y
# CONFIG_ATM_CLIP_NO_ICMP is not set
CONFIG_ATM_LANE=m
CONFIG_ATM_MPOA=m
# CONFIG_VLAN_8021Q is not set

#
#
#
CONFIG_IPX=m
# CONFIG_IPX_INTERN is not set
CONFIG_ATALK=m
CONFIG_DECNET=m
CONFIG_DECNET_SIOCGIFCONF=y
CONFIG_DECNET_ROUTER=y
CONFIG_DECNET_ROUTE_FWMARK=y
CONFIG_BRIDGE=m
# CONFIG_X25 is not set
# CONFIG_LAPB is not set
# CONFIG_LLC is not set
# CONFIG_NET_DIVERT is not set
# CONFIG_ECONET is not set
# CONFIG_WAN_ROUTER is not set
# CONFIG_NET_FASTROUTE is not set
# CONFIG_NET_HW_FLOWCONTROL is not set

#
# QoS and/or fair queueing
#
CONFIG_NET_SCHED=y
CONFIG_NET_SCH_CBQ=m
CONFIG_NET_SCH_CSZ=m
# CONFIG_NET_SCH_ATM is not set
CONFIG_NET_SCH_PRIO=m
CONFIG_NET_SCH_RED=m
CONFIG_NET_SCH_SFQ=m
CONFIG_NET_SCH_TEQL=m
CONFIG_NET_SCH_TBF=m
CONFIG_NET_SCH_GRED=m
CONFIG_NET_SCH_DSMARK=m
CONFIG_NET_SCH_INGRESS=m
CONFIG_NET_QOS=y
CONFIG_NET_ESTIMATOR=y
CONFIG_NET_CLS=y
CONFIG_NET_CLS_TCINDEX=m
CONFIG_NET_CLS_ROUTE4=m
CONFIG_NET_CLS_ROUTE=y
CONFIG_NET_CLS_FW=m
CONFIG_NET_CLS_U32=m
CONFIG_NET_CLS_RSVP=m
CONFIG_NET_CLS_RSVP6=m
CONFIG_NET_CLS_POLICE=y
---------------------------------------------

 
 
 

Linksys BEFSR41 - no browser access in linux?

Post by R S Priga » Sat, 26 Jan 2002 11:30:48


<posted & mailed>

Colin gets the prize! Even though RH has
        CONFIG_INET_ECN=y
in their default .configs (and somehow their 2.4.9-21 kernel works?),
changing CONFIG_INET_ECN=  works!!
        CONFIG_INET_ECN=N

RSP


> I think it IS in kernel! ... the 2.4.9.-21athlon one works okay (but has a
> lot of extra hardware stuff I don't need)
 ...
> Does that mean the BEFSR41 is a "broken router?" (according to
> Configure.help)

> CONFIG_INET_ECN=y seems to be in the athlon default settings from RH 7.2
> 2.4.9.-21

...

>> Be sure to disable TCP Explicit Congestion Notification (ECN) in the
>> kernel under Networking Options.
...


>>> <posted & mailed>

>>> I have a Linksys BEFSR41 router/switch, and find no browser access in
>> linux!

>>> "Connection refused" ... "Could not connect to host" ...

>>> Same in Netscape, Konquerer, Mozilla, Galeon, ...

 
 
 

1. Linksys Realplayer 8 / Linksys BEFSR41 Router settings?

I have configured several boxes at home behind a Linksys router
#BEFSR41.Both my w2k and linux boxes are able to connect through the
router however Realplayer(RealOne) only connects through the router
successfully on my w2k box. On the linux box I have installed RealPlayer
8 successfully but cannot get get it to connect through the router.
Playing local ra files works fine. What should I be looking at in order
to solve this? I tried looking at preferences and tried Auto-Configure
to no avail.
Any help will be greatly appreciated.

Thanks,

Tony.

2. Netscape 4.03 Java problem (bus error).

3. Connecting to @Home (via linksys PCMCIA -> Linksys BEFSR41) (Mandrake 8.0)

4. ftpd - open of pid file failed

5. Linux/Win2K Server As A Router vs. Linksys Router (BEFSR41)

6. FA: Alphaserver 8400 -going once - going twice

7. Linux with a Linksys Befsr41 router

8. where is the error?

9. Linksys BEFSR41 and Red Hat Linux 8.0 problems - Please help!

10. Linux Firewall/NAT replacement for Linksys BEFSR41

11. Linksys BEFSR41 Router and Linux

12. Linksys BEFSR41 DSL router SLOW..why?

13. Linksys BEFSR41 and DHCP