Problem: AZTECHx8 IDE CDROM

Problem: AZTECHx8 IDE CDROM

Post by Ralf Denze » Sun, 05 Jan 1997 04:00:00



I'm working with kernel version 2.0.25 and 2.1.11 and both are unable
to detected my CDROM drive correctly. My drive is an 8x-speed AZTECH
IDE CDROM drive (model no. CDA 868-01IE). When I start the Linux kernel
I get the following boot message in the ide section:

ide: i82371 PIIX (Triton) on PCI bus 0 function 57
    ide0: BM-DMA at 0xffa0-0xffa7
    ide1: BM-DMA at 0xffa8-0xffaf
hda: WDC AC21600H, ATA DISK drive
hdb: no response (status = 0xd0)
hdb: non-IDE drive, CHS=622/128/63
hdc: FUJITSU M1638TAU, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: WDC AC21600H, 1549MB w/128kB Cache, LBA, CHS=787/64/63, DMA
hdb: INVALID GEOMETRY: 128 PHYSICAL HEADS?
hdc: FUJITSU M1638TAU, 2452MB w/128kB Cache, LBA, CHS=4982/16/63, DMA
Floppy drive(s): fd0 is 1.44M

The AZTECH CDROM drive is jumpered as slave and connected to the primary
ide port as the second drive. Under MS Windows 95 the drive works
correct.

On the other side, if I exchange the AZTECH with my old MITSUMI
FX400 CDROM drive everything works fine under both kernel versions:

ide: i82371 PIIX (Triton) on PCI bus 0 function 57
    ide0: BM-DMA at 0xffa0-0xffa7
    ide1: BM-DMA at 0xffa8-0xffaf
hda: WDC AC21600H, ATA DISK drive
hdb: FX400_02, ATAPI CDROM drive
hdc: FUJITSU M1638TAU, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: WDC AC21600H, 1549MB w/128kB Cache, LBA, CHS=787/64/63, DMA
hdc: FUJITSU M1638TAU, 2452MB w/128kB Cache, LBA, CHS=4982/16/63, DMA

Any suggestions are welcomed.

Ralf

/*--------------------------------------------------------------------*
 * Ralf Denzer                            Phone: (+49) 631 2017-139   *
 * Design and Analysis                    Fax:   (+49) 631 2017-199   *

 * University of Kaiserslautern                                       *
 * Erwin-Schroedinger-Strasse 58                                      *
 * D-67663 Kaiserslautern                                             *
 * Germany                                                            *
 *                                                                    *
 * "Forget the Physics, Just Look at the Mechanics"                   *
 *--------------------------------------------------------------------*/

 
 
 

Problem: AZTECHx8 IDE CDROM

Post by Chris Harshma » Sun, 05 Jan 1997 04:00:00


Quote:> The AZTECH CDROM drive is jumpered as slave and connected to the primary
> ide port as the second drive. Under MS Windows 95 the drive works
> correct.

Just a thought...  When my Hitachi CDR-7730 ATAPI cd-rom drive was a
slave on my primary IDE controller, Linux had trouble finding it.  Move it
to the 'master' spot on my secondary and all is kosher.   Have your tried
juggling the drives about?

Just my $.02

 
 
 

1. PROBLEM: 2.4.20 on ICH4 : ide-cdrom/ide-scsi problems reading cds

Please cc me directly as I am not subscribed to the list.

I am getting problems (intermittent) trying to play audio CDs using
2.4.20 with an ICH4 controller (although I don't know if the ICH4 is
relevant) - the problem is intermittent and I can eventually play the CD
by ejecting and loading the CD a couple of times. The problem below is
with the ide-cdrom module but it is exacerbated when I use ide-scsi instead.

I have tried this with 2 different CD RW drives (I went and bought a new
drive to check that the error was not with the old HP.
I also have applied the latest ACPI patch (to get this machine to power
off correctly) - but I have tested without the patch and I still get the
same problem.

Any help would be appreciated. Let me know if you need any further
information.

 >From /var/log/messages:

Dec 30 14:33:42 bart kernel: hdc: ATAPI 48X CD-ROM CD-R/RW drive, 2048kB
Cache, UDMA(33)
Dec 30 14:33:42 bart kernel: Uniform CD-ROM driver Revision: 3.12
<-- snip -->
Dec 30 14:41:28 bart kernel: ATAPI device hdc:
Dec 30 14:41:28 bart kernel:   Error: Illegal request -- (Sense key=0x05)
Dec 30 14:41:28 bart kernel:   Logical block address out of range --
(asc=0x21, ascq=0x00)
Dec 30 14:41:28 bart kernel:   The failed "Play Audio MSF" packet
command was:
Dec 30 14:41:28 bart kernel:   "47 00 00 00 02 20 27 0f 28 00 00 00 "
<-- snip -->
Dec 30 14:49:03 bart kernel: hdc: command error: status=0x51 {
DriveReady SeekComplete Error }
Dec 30 14:49:03 bart kernel: hdc: command error: error=0x50

Boot information:

Dec 30 14:31:53 bart kernel: Uniform Multi-Platform E-IDE driver
Revision: 6.31
Dec 30 14:31:53 bart kernel: ide: Assuming 33MHz system bus speed for
PIO modes; override with idebus=xx
Dec 30 14:31:53 bart kernel: ICH4: IDE controller on PCI bus 00 dev f9
Dec 30 14:31:53 bart kernel: PCI: Device 00:1f.1 not available because
of resource collisions
Dec 30 14:31:53 bart kernel: ICH4: BIOS setup was incomplete.
Dec 30 14:31:53 bart kernel: ICH4: chipset revision 1
Dec 30 14:31:53 bart kernel: ICH4: not 100%% native mode: will probe
irqs later
Dec 30 14:31:53 bart kernel:     ide0: BM-DMA at 0xffa0-0xffa7, BIOS
settings: hda:DMA, hdb:pio
Dec 30 14:31:53 bart kernel:     ide1: BM-DMA at 0xffa8-0xffaf, BIOS
settings: hdc:DMA, hdd:pio
Dec 30 14:31:53 bart kernel: hda: MAXTOR 6L080J4, ATA DISK drive
Dec 30 14:31:53 bart kernel: hdc: MSI CD-RW MS-8348, ATAPI CD/DVD-ROM drive
Dec 30 14:31:53 bart kernel: ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
Dec 30 14:31:53 bart kernel: ide1 at 0x170-0x177,0x376 on irq 15

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

2. Sound card/CD-ROM drive recommendations?

3. 2 IDE HDD and 1 IDE CDROM kernel supporting problem

4. Format.dat for ST15150N

5. Atapi cdrom problem: wrong speed found by ide-cdrom

6. CGI Front-end due to ISP Restrictions

7. Problem - secondary ide and mitsumi ide cdrom

8. O(1) scheduler, -D1, 2.5.2-pre9, 2.4.17

9. Dell Dimension + IDE HD + IDE CDROM + 2940 SCSI = PROBLEM???

10. ide cdrom and cdrom writer with scsi harddisk using cdrecord can't find cd reader

11. IDE cdroms on soundcard card ide interfaces

12. IDE and CDROM devices (was Re: [IDE bug] hdparm lockup)

13. NEC IDE CD-ROM + new IDE/CDROM driver