Supra 56i modem not working...

Supra 56i modem not working...

Post by Jonas Geduld » Wed, 22 Apr 1998 04:00:00



Mine is working with PnP enabled.  I think I just followed the PnP HOWTO, and
maybe the serial HOWTO. (PII-233.)  If I remember correctly, when I installed
PnP for Linux, it automatically looks for all PnP devices and fills in a
config script.  That worked fine for me.

: Has anyone managed to get the Diamond Supra 56i internal modem working
: with Linux? I disabled the Plug-n-Play mode and set it up for COM 2/IRQ 3,
: but still no luck. When I run minicom I can't enter any Hayes commands. :-(
: Needless to say, I get nowhere with Seyon or PPP either.
:
: I also tried COM 1/IRQ 4 with the same results. The kernel seems to find
: the modem OK though. Hmmm.
:
: I'm running this on an Alpha, but I doubt it makes a difference.
:
: --
: .______________________________________________________________________.
: |     Michael Champigny - (978) 568-4176   |   |   |   |   |   |   |   |
: |         Software Senior Engineer         | d | i | g | i | t | a | l |
: |______Alpha_CAD_Physical_Verification_____|___|___|___|___|___|___|___|

 
 
 

Supra 56i modem not working...

Post by Jeremy Matthew Kua » Thu, 23 Apr 1998 04:00:00


I got mine working fine by disabling the PnP and using setserial to set the irq
of the modem.  I'm connected fine now.


> Mine is working with PnP enabled.  I think I just followed the PnP HOWTO, and
> maybe the serial HOWTO. (PII-233.)  If I remember correctly, when I installed
> PnP for Linux, it automatically looks for all PnP devices and fills in a
> config script.  That worked fine for me.


> : Has anyone managed to get the Diamond Supra 56i internal modem working
> : with Linux? I disabled the Plug-n-Play mode and set it up for COM 2/IRQ 3,
> : but still no luck. When I run minicom I can't enter any Hayes commands. :-(
> : Needless to say, I get nowhere with Seyon or PPP either.
> :
> : I also tried COM 1/IRQ 4 with the same results. The kernel seems to find
> : the modem OK though. Hmmm.
> :
> : I'm running this on an Alpha, but I doubt it makes a difference.
> :
> : --
> : .______________________________________________________________________.
> : |     Michael Champigny - (978) 568-4176   |   |   |   |   |   |   |   |
> : |         Software Senior Engineer         | d | i | g | i | t | a | l |
> : |______Alpha_CAD_Physical_Verification_____|___|___|___|___|___|___|___|

--
Jeremy Matthew Kuan
CNA,CNE,MCP,Linux Guru Wannabe

Pager : 95956330

 
 
 

Supra 56i modem not working...

Post by The Enrollment Go » Fri, 24 Apr 1998 04:00:00


I have the 56i, and it works witn PnP, but not without some modification.

Based on my experience with a prior PnP modem, I have found that despite
what you have enabled in the kernal, Linux will not deviate from the
standard COMx - Port Address - IRQ combinations.  Like my last modem, the
Supra decided it wanted to be COM3, but instead of using IRQ4, it went for
IRQ11.  Linux, however, tried to set it up on IRQ4, and while I did get a
response out of the modem, it was delayed by about 40 seconds.  The solution
was to force an IRQ change by doing setserial <the device> IRQ<the IRQ the
modem is on>
You can verify the settings by typing setserial /dev/modem.  I placed this
command in the /etc/rc.d/rc.local file, to force the change at bootup.


>Has anyone managed to get the Diamond Supra 56i internal modem working
>with Linux? I disabled the Plug-n-Play mode and set it up for COM 2/IRQ 3,
>but still no luck. When I run minicom I can't enter any Hayes commands. :-(
>Needless to say, I get nowhere with Seyon or PPP either.

>I also tried COM 1/IRQ 4 with the same results. The kernel seems to find
>the modem OK though. Hmmm.

>I'm running this on an Alpha, but I doubt it makes a difference.

>--
>.______________________________________________________________________.
>|     Michael Champigny - (978) 568-4176   |   |   |   |   |   |   |   |
>|         Software Senior Engineer         | d | i | g | i | t | a | l |
>|______Alpha_CAD_Physical_Verification_____|___|___|___|___|___|___|___|

 
 
 

Supra 56i modem not working...

Post by April Kirb » Sat, 25 Apr 1998 04:00:00



>I got mine working fine by disabling the PnP and using setserial to set the
irq
>of the modem.  I'm connected fine now.

I would like to know how you disabled the PnP on this modem.
 
 
 

1. Modem Diamond Multimedia Supra PCI 56i - winmodem or not?

Hello!

  I tried to make that modem running under Linux. I tried playing with
setserial - I made proper settings but it didn't help. I have no idea what
to do now. Maybe it is a winmodem - I really need to talk with someone who
knows something about it!


THX!

--
Cayco and cayc0 are
registered trademarks
of Cay co.
;-)

2. substitution script

3. Is my Diamond Supra Express 56i V Pro PCI modem Linux compatible?

4. pppd error-message after ppp-off

5. Diamond Supra Express 56i SP PC Modem

6. Enable Java on Apache servers

7. Supra Express 56i (internal ISA modem card)

8. Third IDE Hard Drive?

9. Diamond Supra Express 56i PRO Pci modem

10. Diamond Supra Express 56i Modem

11. help! problem w/ supra 56i modem

12. Supra 56i Modem Help

13. SUPRA 56i modem problem