HELP!! Chinon CDS-545 CDROM

HELP!! Chinon CDS-545 CDROM

Post by Phil Zimmerm » Tue, 16 Jan 1996 04:00:00



I bought this Chinon CDS-545 IDE Quad Speed drive last month and have had
no luck getting the kernel to recognize it during bootup.  I'm "almost" 100%
sure that I am configuring the kernel correctly during 'make config' and I
am also re-running the setup program to configure for a cdrom.  I have the  
drive connected to the secondary IDE port on my motherboard.  
( During 'make config', I set the following parameters...)
        CONFIG_BLK_DEV_IDE      y
        CONFIG_BLK_DEV_IDECD    y
        CONFIG_ISO9660_FS       y

Does anyone have any have a similar drive or have any suggestions?

 
 
 

HELP!! Chinon CDS-545 CDROM

Post by nicholas holshous » Fri, 26 Jan 1996 04:00:00




Quote:

>I bought this Chinon CDS-545 IDE Quad Speed drive last month and have had
>no luck getting the kernel to recognize it during bootup.  I'm "almost" 100%
>sure that I am configuring the kernel correctly during 'make config' and I
>am also re-running the setup program to configure for a cdrom.  I have the  
>drive connected to the secondary IDE port on my motherboard.  
>( During 'make config', I set the following parameters...)
>        CONFIG_BLK_DEV_IDE      y
>        CONFIG_BLK_DEV_IDECD    y
>        CONFIG_ISO9660_FS       y

>Does anyone have any have a similar drive or have any suggestions?

I'll join the need help list on this since I have the same CD-ROM
and have never gotten it to work with or be recognized by Linux.

nick h

 
 
 

HELP!! Chinon CDS-545 CDROM

Post by Jim Part » Fri, 26 Jan 1996 04:00:00


Quote:>>I bought this Chinon CDS-545 IDE Quad Speed drive last month and have had
>>no luck getting the kernel to recognize it during bootup.  I'm "almost" 100%
>>sure that I am configuring the kernel correctly during 'make config' and I
>>am also re-running the setup program to configure for a cdrom.  I have the  
>>drive connected to the secondary IDE port on my motherboard.  
>>( During 'make config', I set the following parameters...)
>>        CONFIG_BLK_DEV_IDE      y
>>        CONFIG_BLK_DEV_IDECD    y
>>        CONFIG_ISO9660_FS       y

>>Does anyone have any have a similar drive or have any suggestions?

If your drive is the only drive on the secondary interface, it should be
jumpered as "Master", and not "Slave". You can also tell Linux where the
drive is when you're booting at the LILO prompt (try "linux hdc=cdrom" at the
prompt, or hdd=cdrom if it is the second drive on the second interface). The
CDROM-HOWTO is at ftp://sunsite.unc.edu/pub/Linux/docs/HOWTO/CDROM-HOWTO.
(Have you edited /etc/lilo.conf and re-run /sbin/lilo to use your new kernel?)
 
 
 

HELP!! Chinon CDS-545 CDROM

Post by Hyun-Min PA » Sat, 27 Jan 1996 04:00:00




>>>I bought this Chinon CDS-545 IDE Quad Speed drive last month and have had
>>>no luck getting the kernel to recognize it during bootup.  I'm "almost" 100%
>>>sure that I am configuring the kernel correctly during 'make config' and I
>>>am also re-running the setup program to configure for a cdrom.  I have the  
>>>drive connected to the secondary IDE port on my motherboard.  
>>>( During 'make config', I set the following parameters...)
>>>        CONFIG_BLK_DEV_IDE      y
>>>        CONFIG_BLK_DEV_IDECD    y
>>>        CONFIG_ISO9660_FS       y

>>>Does anyone have any have a similar drive or have any suggestions?

  Common mistake, did you do make mrproper first before make config??

  If you don't do make mrproper, then old config may stay around and
give you problems.

Quote:>If your drive is the only drive on the secondary interface, it should be
>jumpered as "Master", and not "Slave". You can also tell Linux where the

  For me, maybe because of the fact that I use the IDE port from
my SB16, my CD-rom doesn't even work if I set it at Master..  :(

  So, I HAVE to do Slave, but it isn't much trouble..  Though
Slackware 3.0.0 hangs :( Unless you have /dev/hdc -> /dev/hdd (cheap
trick)  Coz I put hdc=cdrom parameter and the installation script
expects the cdrom there..

Quote:>drive is when you're booting at the LILO prompt (try "linux hdc=cdrom" at the
>prompt, or hdd=cdrom if it is the second drive on the second interface). The

  Now, this is an oddity, since I don't have hdc device, if I do hdd=cdrom,
the cdrom doesn't even get recognized.  ( I mean, the interface on my
SB 16 doesn't get recognized..)  So, I have to do "hdc=cdrom" then it will
say something like hdc doesn't recognize, but hdd, gets recognized as
valid ATAPI cd-rom drive..  Very odd..

Quote:>CDROM-HOWTO is at ftp://sunsite.unc.edu/pub/Linux/docs/HOWTO/CDROM-HOWTO.
>(Have you edited /etc/lilo.conf and re-run /sbin/lilo to use your new kernel?)

  Very important..  VERY important..  

  Hope this has been helpful.

PS:  I believe 1.3.xx kernels ARE suppose to probe the second interface
even without hdc= parameter, though I am not sure...

 
 
 

1. HELP: Chinon CDS-545 bootup problem with Linux-1.3.61

I have just installed the Linux-1.3.61.
After reboot, everything is fine except the cdrom.
Here is the message at the boot time:
...................................
hdd: Chinon CD-ROM CDS-545 ATAPI CDROM drive
hdd: unexpected_intr: status=0xff
...................................
Any help and pointer will be greatly appreciated.

Regards,

--- Chang

2. Help with Compiling Kernel

3. Chinon 545 4x CD: Help Narrow Down Reason for Progblem

4. Crack passwords at change time

5. chinon 545 atapi cdrom probs.

6. looping nohup hangs

7. Adaptec 1522 hangs with Sony Scsi 545??? CDROM

8. PCI Sound card (es1371) help

9. Need help getting Linux to recognize Chinon CDS-545i 4X CDROM

10. Chinon 535 CD ROM and Chinon SCSI controller - driver?

11. ****** HELP HELP HELP - CHINON CDS535 CDROM DRIVE PROBLEM ******

12. Can someone help me with a CHINON CDS-535 CD-ROM?

13. HELP: SCSI-2 CD Drive DISCONNECT/RECONNECT problem (Chinon 525 CDS)