bttv no audio when trying to use mencode to capture tv

bttv no audio when trying to use mencode to capture tv

Post by Joh » Wed, 19 Feb 2003 06:10:09



I have a Hauppauge Win FM card that uses 878.  I can use mplayer with
the card just fine, other than the [0,9,/,*] keys don't work the
volume.  I can hear sound / audio fine when useing mplayer.  When I
try to use mencoder to capter / record tv I can hear the audio, but
when I play the file back there is no audio in it.

The command I run is as follows:
mencoder -tv on:driver=v4l:width=512:height=384:channel=49:chanlist=us-cable:norm=ntsc:device=/dev/video0
-ovc lavc -lavcopts vcodec=mpeg4:vbitrate=800 -oac mp3lame -lameopts
vbr=2 -vop pp=lb -endpos 00:00:15 -o tryone.avi 2>&1

These modules look to be installed when I do a "lsmod | grep bt"
btaudio                12556   0  (unused)
bttv                   71328   0
soundcore               6500  10  (autoclean) [btaudio emu10k1 sound]
videodev                8320   3  [bttv]
i2c-algo-bit            8840   1  [bttv]
i2c-core               19236   0  [bttv tuner tvaudio msp3400
i2c-algo-bit]

Please Help!!!

 
 
 

bttv no audio when trying to use mencode to capture tv

Post by TheMartia » Wed, 19 Feb 2003 07:03:17


which version of mplayer are you using?
did you source build it?
which version of the bttv driver are you using?

have you tried transcode,zapping,xawtv,dvr etc?


Quote:> I have a Hauppauge Win FM card that uses 878.  I can use mplayer with
> the card just fine, other than the [0,9,/,*] keys don't work the volume.
>  I can hear sound / audio fine when useing mplayer.  When I try to use
> mencoder to capter / record tv I can hear the audio, but when I play the
> file back there is no audio in it.

> The command I run is as follows:
> mencoder -tv
> on:driver=v4l:width=512:height=384:channel=49:chanlist=us-cable:norm=ntsc:device=/dev/video0
> -ovc lavc -lavcopts vcodec=mpeg4:vbitrate=800 -oac mp3lame -lameopts
> vbr=2 -vop pp=lb -endpos 00:00:15 -o tryone.avi 2>&1

> These modules look to be installed when I do a "lsmod | grep bt" btaudio
>                12556   0  (unused) bttv                   71328   0
> soundcore               6500  10  (autoclean) [btaudio emu10k1 sound]
> videodev                8320   3  [bttv] i2c-algo-bit            8840 1
> [bttv] i2c-core               19236   0  [bttv tuner tvaudio msp3400
> i2c-algo-bit]

> Please Help!!!

--
www.ozetechnology.com
100% Microsoft Free.

 
 
 

1. Capture TV card with its own processor -- What are you using?

Im just looking for a decent capture card with its own onboard processor.
the ones I have used (wintv - brooktree chipset) put quite a strain on the
processor and the fps are quite low (15 or less).

Im looking at the PVR 250 and have spent considerable time trying to get
it compiled into the kernel and such with little luck. Im sure If I spent
another MONTH on it I could get it to run but Im looking for an easier
approach.

So, Whats the word on capture cards? Which ones available now work well
with linux (Im using fedora core 1). What are you using??

My thanks in advance.

coffee412

2. Recipe: byterunner 8-port serial with linux RH 6.0 console.

3. Tv out/capture on Asus v3400tnt/tv?

4. Help: cannot install Linux

5. Zoltrix TV MAX tv tuner and vid capture card..

6. Reading is much more interesting than TV (1553/1708)

7. New bttv-compatible video capture card available

8. significant digits IEEE floating point

9. BTTV drivers and Bt848a capture card from boeder not working.

10. BTTV, BT848 Capture card, and Intel Cam

11. fps capture slow on bttv hauppauge system

12. Changing Serial Nos using 'brand'

13. Video Capture/Bttv