Kernel 2.2.12 & .13 and AIC7xxx problems

Kernel 2.2.12 & .13 and AIC7xxx problems

Post by Gregory K Hunte » Fri, 07 Jan 2000 04:00:00



Has anyone else noticed any problems compiling the Adaptec driver directly
into the Kernel (as opposed to a module). Everytime I make bzImage (or
zImage for that matter) the make dumps on the AIC7xxx driver. Compiled as a
module everything works fine, but as my boot disks are on this controller I
would prefer not to have it modularized. Any help/info would be much
appreciated.

Thank You (In advance)

Greg

------------------  Posted via CNET Linux Help  ------------------
                    http://www.searchlinux.com

 
 
 

Kernel 2.2.12 & .13 and AIC7xxx problems

Post by kari savolaine » Sat, 08 Jan 2000 04:00:00




Quote:> Has anyone else noticed any problems compiling the Adaptec driver directly
> into the Kernel (as opposed to a module). Everytime I make bzImage (or
> zImage for that matter) the make dumps on the AIC7xxx driver. Compiled as
a
> module everything works fine, but as my boot disks are on this controller
I
> would prefer not to have it modularized. Any help/info would be much
> appreciated.

I have kernel 2.2.13 and this driver compiled in the kernel and it works
fine, though I compiled it with 'make bzlilo'

// kari

 
 
 

Kernel 2.2.12 & .13 and AIC7xxx problems

Post by Ricardo C » Sat, 08 Jan 2000 04:00:00


you could try making an initrd image, works for me since my root dir is a
scsi device and I have the aic7xxx driver modularized.

/Ricardo

Note: any of the above may or may not show some signs of intelligence



Quote:> Has anyone else noticed any problems compiling the Adaptec driver directly
> into the Kernel (as opposed to a module). Everytime I make bzImage (or
> zImage for that matter) the make dumps on the AIC7xxx driver. Compiled as
a
> module everything works fine, but as my boot disks are on this controller
I
> would prefer not to have it modularized. Any help/info would be much
> appreciated.

> Thank You (In advance)

> Greg

> ------------------  Posted via CNET Linux Help  ------------------
>                     http://www.searchlinux.com

 
 
 

Kernel 2.2.12 & .13 and AIC7xxx problems

Post by Mark » Sun, 09 Jan 2000 04:00:00



> Has anyone else noticed any problems compiling the Adaptec driver directly
> into the Kernel (as opposed to a module). Everytime I make bzImage (or
> zImage for that matter) the make dumps on the AIC7xxx driver. Compiled as a
> module everything works fine, but as my boot disks are on this controller I
> would prefer not to have it modularized. Any help/info would be much
> appreciated.

I have the AIC7xxx driver compiled in..no problems. I have compiled it since
I installed the scsi card..back in kernel 2.1.x days!! I am running kernel
2.3.33
presently, but also have 2.2.13 onboard, which compiles withput problems.

Did you patch the kernel source from a previous version? Whenever I have
problems like this in the past (any sort of compile problem) I have d/l the
entire
source tree and started afresh..it's always worked.

Cheers.

  -----------== Posted via Newsfeeds.Com, Uncensored Usenet News ==----------
   http://www.newsfeeds.com       The Largest Usenet Servers in the World!
------== Over 73,000 Newsgroups - Including  Dedicated  Binaries Servers ==-----

 
 
 

Kernel 2.2.12 & .13 and AIC7xxx problems

Post by D. Stimit » Sun, 09 Jan 2000 04:00:00



> Has anyone else noticed any problems compiling the Adaptec driver directly
> into the Kernel (as opposed to a module). Everytime I make bzImage (or
> zImage for that matter) the make dumps on the AIC7xxx driver. Compiled as a
> module everything works fine, but as my boot disks are on this controller I
> would prefer not to have it modularized. Any help/info would be much
> appreciated.

> Thank You (In advance)

> Greg

> ------------------  Posted via CNET Linux Help  ------------------
>                     http://www.searchlinux.com

I depend soley on this driver for my hd's, and have always used it
compiled directly in. Using kernel 2.2.12, this works fine. Originally
it was on 2.2.5-x of RH 6, which also worked. Prior to this, it was on
2.0.35 and 2.1.130, working great. What was the error message at failure
time?
 
 
 

1. OPTi 16 Sound Card Configuration under RH5.2 & kernel 2.2.12

hello everyone

i'm having a problem with configuring a OPTi 16 sound card working under RH 5.2
& the 2.2.12 kernel.

I've compiled all of the OSS modules and I've tried using sndconfig, but
nothing seems to be working.

The card advertises itself as a SoundBlaster compatible, but just about every
card does that.  It is a PNP ISA card, and the BIOS does recognize the card at
boot time.  I've tried pnpdump and isapnp, but they haven't helped at all.

I'm running this on a pentium 166 MB from asus.  The machine has 48 megs of
ram, and the sound card is the only ISA card.  The other two cards are a
network card and my video card.

anybody had any success getting this card to work under linux?

thanks,

dennis

2. dhcpd

3. SB AWE64 ISA PnP & kernel 2.2.12

4. question

5. How to configure LOGROTATE.CONF?

6. [kernel 2.2.12-20 & NGROUPS]

7. An all new tool to design and display banners randomly

8. Upgrading kernel 2.2.12 to kernel 2.2.16, keeping same options

9. URGENT:problem with module-insertion in kernel-2.2.14-5.0 and 2.2.12-20

10. Problem with 'mkinitrd' while upgrading kernel to 2.2.12

11. Kernel 2.2.12 Compile Problem

12. Unable to handle kernel paging request problem at shutdown on 2.2.12