hard disk problems with VAIO PCG-F290

hard disk problems with VAIO PCG-F290

Post by Amit Mehrotr » Sat, 20 Nov 1999 04:00:00



I am having problems with the hard disk on my laptop. Occasionally it
locks up the system, the load goes up dramatically slowing the system
down and the disk keeps spinning. This madness goes on for about 30
minutes after which things get back to normal. /var/log/messages has
these error messages

Nov 19 17:51:22 localhost kernel: hda: irq timeout: status=0xd0 { Busy }

Nov 19 17:51:53 localhost kernel: ide0: reset timed-out, status=0x80
Nov 19 17:51:53 localhost kernel: hda: status timeout: status=0x80 {
Busy }
Nov 19 17:51:53 localhost kernel: hda: drive not ready for command
Nov 19 17:52:28 localhost kernel: ide0: reset timed-out, status=0x80
Nov 19 17:52:28 localhost kernel: hda: status timeout: status=0x80 {
Busy }
Nov 19 17:52:28 localhost kernel: end_request: I/O error, dev 03:05
(hda), sector 348442
Nov 19 17:52:28 localhost kernel: hda: drive not ready for command
Nov 19 17:52:28 localhost kernel: hda: status timeout: status=0x80 {
Busy }
Nov 19 17:52:28 localhost kernel: hda: drive not ready for command
Nov 19 17:53:08 localhost kernel: ide0: reset timed-out, status=0x80
Nov 19 17:53:08 localhost kernel: hda: status timeout: status=0x80 {
Busy }
Nov 19 17:53:08 localhost kernel: hda: drive not ready for command
Nov 19 17:53:43 localhost kernel: ide0: reset timed-out, status=0x80
Nov 19 17:53:43 localhost kernel: hda: status timeout: status=0x80 {
Busy }
Nov 19 17:53:43 localhost kernel: end_request: I/O error, dev 03:05
(hda), sector 348444
<snip>
Nov 19 18:14:59 localhost kernel: hda: drive not ready for command
Nov 19 18:14:59 localhost kernel: hda: status timeout: status=0x80 {
Busy }
Nov 19 18:14:59 localhost kernel: hda: drive not ready for command
Nov 19 18:15:39 localhost kernel: ide0: reset timed-out, status=0x80
Nov 19 18:15:39 localhost kernel: hda: status timeout: status=0x80 {
Busy }
Nov 19 18:15:39 localhost kernel: hda: drive not ready for command
Nov 19 18:16:08 localhost kernel: ide0: reset: success

I looked around the web and saw several references to the problem but no
solutions. Any idea why this is happening? The hdparam readings are
/dev/hda5:
 multcount    =  0 (off)
 I/O support  =  0 (default 16-bit)
 unmaskirq    =  0 (off)
 using_dma    =  1 (on)
 keepsettings =  0 (off)
 nowerr       =  0 (off)
 readonly     =  0 (off)
 readahead    =  8 (on)
 geometry     = 839/240/63, sectors = 3779937, start = 4112703

Amit