atyfb and kernel 2.6-test11 problem

atyfb and kernel 2.6-test11 problem

Post by tortie » Thu, 11 Dec 2003 01:13:15



Hi all,

Does anybody trie linux 2.6-test11 with atyfb ?

I have an ATI 3d rage pro (mach64).
It works fine with 2.4.23 kernel, but I did not succed in installing it with the
2.6 test 11 kernel.


I saw only a black screen until the start of X.

I tried some others configuration too but witout success.
I tried to change resolution with fbset after boot, but I froze my PC, and I had
to perform an hard reset.

Do you have an idea how can I make it working ?

Regards
tortieh

 
 
 

1. Problem with XFree 4.0.2 and kernel 2.4.0-test11

Hi,

Until recently I had a pretty stable XFree86 4.0.2 running on my machine.
 But as I have a Matrox G400 DH graphics card I thought I'd try to get
the OpenGL acceleration working.  Having installed kernel 2.4.0-test11, I
proceeded to set up the DRI stuff for my graphics card, selecting the
option for stuff like AGP and the relevent options for my card and MoBo.
I modified the XF86Config to use 16bit colour depth.  I re-compiled and
installed the new kernel, rebooted and started X windows (through 'gdm').

When I checked the XFree log file I found the following error msg:

--- 8< snip 8< -------------
(II) MGA(0): [drm] Sarea 2176+624: 2800
(0): [drm] created "mga" driver at busid "PCI:1:0:0"
(0): [drm] added 4096 byte SAREA at 0xc580d000
(0): [drm] mapped SAREA 0xc580d000 to 0x40019000
(0): [drm] framebuffer handle = 0xe8000000
(0): [drm] added 1 reserved context for kernel
(EE) MGA(0): [drm] MGADRIScreenInit failed (DRM version = 2.0.1, expected 1.0.x).  Disabling DRI.
(0): [drm] failed to remove DRM signal handler

Fatal server error:
Caught signal 11.  Server aborting
--- 8< snip 8< -------------

So then I attempted to close X windows and the screen went black, there
was a bit of disk activity then it just sat there, not responding to any
keyboard input, therefore requiring a power cycle to get it back.

Any clues?

System:
Abit BP6 MoBo, dual 466 Celeron,
Matrox G400 32MB DH,
196 MB RAM
13GB HD,
SuSE 6.3
Kernel 2.4.0-test11
XFree86 4.0.2

--

"If something is hard to do it's not worth doing."
  - Homer J Simpson

2. Samba and Session

3. kernel 2.4.0-test11 problem

4. Page Count on Samba Users

5. NVdriver and kernel 2.4.0-test11

6. NFS problem.

7. ppp 2.4.0 & 2.4.0-test11 kernel

8. bootp vs DHCPD

9. kernel 2.4.0-test11, TNT2 and XFree 4

10. getting pppoe with 2.4.0-test11 kernel

11. Intel 815E chipset on-board video and Linux Kernel 2.4.0-test11-pre*

12. Kernel 2.4.0-test11 does not boot after Mainboard exchange

13. kernel 2.4.0-test11 and Linksys Etherfast 10/100 PCMCIA card