Printer reset problem on RH 5.2

Printer reset problem on RH 5.2

Post by Garrick Hay » Sat, 09 Jan 1999 04:00:00



I just installed RH 5.2 up from 5.1. I have an IBM Lexmark 4029 printer
which defaults to PPDS, but I use the front panel buttons to make it
emulate PCL-4, and I told printtool that it is an HP laserjet. Under RH
5.1 this worked great. But RH 5.2 RESETS the printer, which makes it
default to PPDS each time before I try to print anything graphical! There
is no support for the PPDS language. How to make it stop resetting the
printer? I've read the HOWTO'S, and looked at /etc/printcap and files in
/usr/lib/rhs/rhs-printfilters/ and /var/spool/lpd/lp/

I have no clue. If I found where, I might even replace the reset
command with a string to set the printer to PCL4 automatically.

P.S. No, my printer does not have the postscript option.

 
 
 

Printer reset problem on RH 5.2

Post by Garrick Hay » Sat, 09 Jan 1999 04:00:00


I found the answer on DejaNews. Modify end of print filter from:

    eval $bestpath 2>/dev/null

to:

    printf "\033\0133\0113\003\000\000\061\002"
    eval $bestpath 2>/dev/null
    printf "\033\0133\0113\003\000\000\061\000"

It works.


> I just installed RH 5.2 up from 5.1. I have an IBM Lexmark 4029 printer
> which defaults to PPDS, but I use the front panel buttons to make it
> emulate PCL-4, and I told printtool that it is an HP laserjet. Under RH
> 5.1 this worked great. But RH 5.2 RESETS the printer, which makes it
> default to PPDS each time before I try to print anything graphical! There
> is no support for the PPDS language. How to make it stop resetting the
> printer? I've read the HOWTO'S, and looked at /etc/printcap and files in
> /usr/lib/rhs/rhs-printfilters/ and /var/spool/lpd/lp/

> I have no clue. If I found where, I might even replace the reset
> command with a string to set the printer to PCL4 automatically.

> P.S. No, my printer does not have the postscript option.