Printing problem : ls > /dev/lp0 -- /dev/lp0 : No Such Device ?

Printing problem : ls > /dev/lp0 -- /dev/lp0 : No Such Device ?

Post by wong man fa » Sun, 25 May 1997 04:00:00



Hello,
I have install a printer to the parellel port of my linux box then enter
the command :
        ls > /dev/lp0
but get this error message
        bash : /dec/lp0 : No Such Device
However, when I boot my linux box under MSDOS, the printer works, can
anybody help please ?

Thanks and Regards
Wong

 
 
 

Printing problem : ls > /dev/lp0 -- /dev/lp0 : No Such Device ?

Post by Joseph I. Valenzuel » Sun, 25 May 1997 04:00:00


    wong> Hello, I have install a printer to the parellel port of my
    wong> linux box then enter the command : ls > /dev/lp0 but get this
    wong> error message bash : /dec/lp0 : No Such Device However, when I
    wong> boot my linux box under MSDOS, the printer works, can anybody
    wong> help please ?

Try:

ls > /dev/lp1

or

or

ls > /dev/printer

or

ls| lpr -

--

God is the tangential point between zero and infinity.
                -- Alfred Jarry

 
 
 

Printing problem : ls > /dev/lp0 -- /dev/lp0 : No Such Device ?

Post by Kurt Wal » Sun, 25 May 1997 04:00:00



> Hello,
> I have install a printer to the parellel port of my linux box then enter
> the command :
>         ls > /dev/lp0
> but get this error message
>         bash : /dec/lp0 : No Such Device

Try /dev/lp1 ...
 
 
 

Printing problem : ls > /dev/lp0 -- /dev/lp0 : No Such Device ?

Post by Bob Niels » Sun, 25 May 1997 04:00:00



>Hello,
>I have install a printer to the parellel port of my linux box then enter
>the command :
>    ls > /dev/lp0
>but get this error message
>    bash : /dec/lp0 : No Such Device
>However, when I boot my linux box under MSDOS, the printer works, can
>anybody help please ?

Try lp1 instead of lp0.  lp1 is the normal default (except for some of the
latest 2.1.x versions).

Bob

--



                            http://www.primenet.com/~nielsen

 
 
 

Printing problem : ls > /dev/lp0 -- /dev/lp0 : No Such Device ?

Post by Juergen Hein » Mon, 26 May 1997 04:00:00


Hello,

Quote:>    bash : /dec/lp0 : No Such Device
>However, when I boot my linux box under MSDOS, the printer works, can
>anybody help please ?

if you've not modified the source of lp.c then ...

LPT1 -> /dev/lp1
LPT2 -> /dev/lp2
LPT3 -> /dev/lp0

Bye, Juergen

--
\ Real name     : Juergen Heinzl     \       no flames      /

  \ Phone Private : +49 0911-4501186   \                  /

 
 
 

Printing problem : ls > /dev/lp0 -- /dev/lp0 : No Such Device ?

Post by Floyd L. Tol » Mon, 26 May 1997 04:00:00



Quote:>Hello,
>I have install a printer to the parellel port of my linux box then enter
>the command :
>    ls > /dev/lp0
>but get this error message
>    bash : /dec/lp0 : No Such Device
>However, when I boot my linux box under MSDOS, the printer works, can
>anybody help please ?

>Thanks and Regards
>Wong

Try ls |lpr
--
  Floyd L.Tolar

  (To Reply...Remove #s)
  "The riskier the road, the greater the profit."
  [Ferengi 62nd. Rule of Aquisition]
 
 
 

Printing problem : ls > /dev/lp0 -- /dev/lp0 : No Such Device ?

Post by Floyd L. Tol » Mon, 26 May 1997 04:00:00



Quote:>Hello,
>I have install a printer to the parellel port of my linux box then enter
>the command :
>    ls > /dev/lp0
>but get this error message
>    bash : /dec/lp0 : No Such Device
>However, when I boot my linux box under MSDOS, the printer works, can
>anybody help please ?

>Thanks and Regards
>Wong

Try ls |lpr
--
  Floyd L.Tolar

  (To Reply...Remove #s)
  "The riskier the road, the greater the profit."
  [Ferengi 62nd. Rule of Aquisition]
 
 
 

Printing problem : ls > /dev/lp0 -- /dev/lp0 : No Such Device ?

Post by Louis J. LaBash J » Wed, 28 May 1997 04:00:00


|>
|> Hello,
|> I have install a printer to the parellel port of my linux box then enter
|> the command :
|>         ls > /dev/lp0
|> but get this error message
|>         bash : /dec/lp0 : No Such Device
|Try /dev/lp1 ...

A way to be sure is:
  dmesg | less

Search for lp, you should see more detail.  It is also a good way to find
out about the kernel's view of your hardware.

--

 
 
 

Printing problem : ls > /dev/lp0 -- /dev/lp0 : No Such Device ?

Post by Louis J. LaBash J » Wed, 28 May 1997 04:00:00


|>
|> Hello,
|> I have install a printer to the parellel port of my linux box then enter
|> the command :
|>         ls > /dev/lp0
|> but get this error message
|>         bash : /dec/lp0 : No Such Device
|Try /dev/lp1 ...

A way to be sure is:
  dmesg | less

Search for lp, you should see more detail.  It is also a good way to find
out about the kernel's view of your hardware.

--

 
 
 

Printing problem : ls > /dev/lp0 -- /dev/lp0 : No Such Device ?

Post by Andreas Kessemeie » Thu, 29 May 1997 04:00:00




> >Hello,
> >I have install a printer to the parellel port of my linux box then enter
> >the command :
> >       ls > /dev/lp0
> >but get this error message
> >       bash : /dec/lp0 : No Such Device
> >However, when I boot my linux box under MSDOS, the printer works, can
> >anybody help please ?

> Try ls |lpr

That may no fix the problem. I have had severe problems with an lpr/lpd
installation on a linux box. For the first time everything runs fine,
i could print from any PC, MAC whatever could not jump on the tree in
time,
but after a few printouts things got stuck. I have had a look in the
syslog
and found "lpr: Could not open /dev/lp0: No such device". Sounds to me
that
the lp.c driver sometime does not recognize the hardware right or
something
like that.

Best regards,
        A. Kessemeier

 
 
 

1. ls > /dev/lp0 fails--but /dev/lp0 exists

I'm new to Linux.  I just loaded the Slackware distribution onto Swan 386SX,
386DX/25 and 486DX.  I have the same problem on all of them:

ls > /dev/lp0 gives:    
    bash: /dev/lp0: no such device.

ls -al /dev/lp0 gives:  
   crw-rw----  1  root  lp   6,  0  Nov 30 14:30  /dev/lp0

Nothing prints.  

All these machines print fine on lpt1: under DOS.  I've read the
print HOWTO and "Linux Installation and Getting Started."   On the 386SX,
uname -a gives:  
    Linux alinux 1.0 #9 Tue Mar 15 18:27:34 CST 1994  i386

I'd appreciate any help you can give.

2. how to force a repaint on XView?

3. bash: ls > /dev/lp0 :No such device

4. rsh creates a zombie

5. I can print via ls > lp0 in /dev, but...please help

6. PPP/Linux: Can't get modem to dial!

7. Printtool not seeing my printer on /dev/lp0, /dev/lp1 or /dev/lp2

8. Managing Modem under SCO Unix

9. Printing Problem - /dev/lp0: No such device.

10. problem printing to HP LJ IIp by > /dev/lp0

11. cat file > /dev/lp0 gives "no such device"

12. /dev/lp0 nor /dev/lp1 getting detected

13. /dev/sequencer and /dev/lp0