Pinnacle PCTV - no channel tunning

Pinnacle PCTV - no channel tunning

Post by Martin Marche » Sun, 31 Aug 2003 17:20:44



Hi,

Sorry if this came thru twice, I crossposted the first one but then
cancelled it hopefully fast enough :)

Ok here goes my problem, I recently bought a Pinnacle PCTV Rave (chip is
BT878) compiled the i2c and bttv modules and gave it a shot guess what, no
go. So after lurking around a bit I tried several bttv cards (39 Pinnacl
PCTV Rave is autorecognized) and tuner cards (with kernel 2.4.16 type 4 -
not tuner - is recognized, and with 2.6 type 33 MT2032 is recognized)
neither of those work.

I have been lurking thru  google groups and what came out was that I had
to update the bttv stuff, the homepage said that with kernel 2.5 and
higher the newest build is included that's why I tried 2.6.

tvtime says no signal and the screen stays blue, xawtv stays black when
capturing in overlay mode and when capturing with grabdisplay I get a
green screen with some snow at the top of it. scantv doesn't find anything
I tried to go thru the whole frequency range with different tuners not
only thru the given table but also no no :(

I live in Europe/Austria so the norm should be PAL and Frequency table
from scantv europe-west.

Now for some output I can give you:

modprobe bttv:
Linux video capture interface: v1.00
bttv: driver version 0.9.11 loaded
bttv: using 8 buffers with 2080k (520 pages) each for capture bttv: Host
bridge is 0000:00:00.0
bttv: Host bridge needs ETBF enabled. bttv: Bt8xx card found (0).
bttv0: Bt878 (rev 17) at 0000:00:0d.0, irq: 12, latency: 32, mmio:
0xed001000 bttv0: detected: Pinnacle PCTV [card=39], PCI subsystem ID is
11bd:0012 bttv0: using: BT878(Pinnacle PCTV Studio/Ra)
[card=39,autodetected] bttv0: enabling ETBF (430FX/VP3 compatibilty) PM:
Adding info for No Bus:i2c-0

id=1 info="PAL / mono" radio=no bttv0: using tuner=33


not found tvaudio: TV audio decoder + audio/video mux driver tvaudio:
known chips:
tda9840,tda9873h,tda9874h/a,tda9850,tda9855,tea6300,tea6420,tda8425,pic16c54

registering 0-0043
PM: Adding info for i2c:0-0043

tuner: type set to 33 (MT2032 universal) MT2032: Companycode=8300 Part=42
Revision=03 not a MT2032.
registering 0-0060
PM: Adding info for i2c:0-0060
MT2032: Companycode=8300 Part=42 Revision=03 not a MT2032.
videodev: "BT878(Pinnacle PCTV Studio/Ra)" has no release callback. Please
fix your driver for proper sysfs support, see
http://lwn.net/Articles/36850/ bttv0: registered device video0
videodev: "bt848/878 vbi" has no release callback. Please fix your driver
for proper sysfs support, see http://lwn.net/Articles/36850/ bttv0:
registered device vbi0
bttv0: PLL: 28636363 => 35468950 .. ok

This is just the autorecognized stuff, I tried different tuners because I
think I caught the problem down to the tuner type, none of them worked.
The Handbook I downloaded from pinnacle says the tuner is a PAL_BG Tuner,
I especially tried all tuner types from the CARDLIST.gz where it says
PAL_BG none of them worked

lsmod (under 2.6):
tuner                  15460  0
tda9887                 7104  0
tvaudio                22528  0
bttv                  133568  0
video_buf              21760  1 bttv
i2c_algo_bit           10312  1 bttv
btcx_risc               4836  1 bttv
i2c_core               25828  5 tuner,tda9887,tvaudio,bttv,i2c_algo_bit
v4l2_common             4576  1 bttv
videodev                9856  1 bttv

lspci -vv:
00:0d.0 Multimedia video controller: Brooktree Corporation Bt878 Video
Capture (rev 11)
        Subsystem: Pinnacle Systems Inc. PCTV pro (TV + FM stereo
        receiver) Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV-
        VGASnoop- ParErr- Stepping- SERR- FastB2B- Status: Cap+ 66Mhz-
        UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort-
        >SERR- <PERR- Latency: 32 (4000ns min, 10000ns max) Interrupt: pin
        A routed to IRQ 12
        Region 0: Memory at ed001000 (32-bit, prefetchable) [size=4K]
        Capabilities: [44] Vital Product Data Capabilities: [4c] Power
        Management version 2
                Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA
                PME(D0-,D1-,D2-,D3hot-,D3cold-) Status: D0 PME-Enable-
                DSel=0 DScale=0 PME-

00:0d.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture
(rev 11)
        Subsystem: Pinnacle Systems Inc. PCTV pro (TV + FM stereo
        receiver, audio section) Control: I/O- Mem+ BusMaster+ SpecCycle-
        MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- Status: Cap+
        66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort-
        <MAbort- >SERR- <PERR- Latency: 32 (1000ns min, 63750ns max)
        Interrupt: pin A routed to IRQ 12
        Region 0: Memory at ed000000 (32-bit, prefetchable) [size=4K]
        Capabilities: [44] Vital Product Data Capabilities: [4c] Power
        Management version 2
                Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA
                PME(D0-,D1-,D2-,D3hot-,D3cold-) Status: D0 PME-Enable-
                DSel=0 DScale=0 PME-

any help appreciated
thx
Martin