kernel 2.2.18 + ide patch panics when trying to mount root fs

kernel 2.2.18 + ide patch panics when trying to mount root fs

Post by Tim Van Holde » Fri, 23 Feb 2001 00:04:32



I'm running SuSE 7.0 Pro (kernel 2.2.16 with loadsa patches).
I want to upgrade to 2.2.18 (I'll also try 2.4.1, but as a test
environment only, for now).  Since I have an Asus A7V133
motherboard, I needed the ide patches to support the hard drive that
is connected to the Promise Utra100 controller. Kernel compiled fine.
Boots up fine, detects all 4 IDE devices but then panics, claiming
it can't mount the root filesystem because the device has unsupported
features.
I'm booting from a hard drive that's attached to the motherboard's
controller (which has a VIA 82CXXX chipset, for which support is
compiled into the kernel), so there should be no problem (in fact,
the SuSE kernel I use is the 'eide' version which also has the
support for Promise & VIA compiled in).
What's going on? Most likely I enabled some configuration option I
shouldn't have (or vice versa), but which one?

--
Tim Van Holder - Falcon Software N.V.
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
This message was posted using plain text. I do not endorse any
products or services that may be hyperlinked to this message.

 
 
 

kernel 2.2.18 + ide patch panics when trying to mount root fs

Post by Rinaldi J. Montess » Fri, 23 Feb 2001 22:04:40



> I'm running SuSE 7.0 Pro (kernel 2.2.16 with loadsa patches).
> I want to upgrade to 2.2.18 (I'll also try 2.4.1, but as a test
> environment only, for now).  Since I have an Asus A7V133
> motherboard, I needed the ide patches to support the hard drive that
> is connected to the Promise Utra100 controller. Kernel compiled fine.
> Boots up fine, detects all 4 IDE devices but then panics, claiming
> it can't mount the root filesystem because the device has unsupported
> features.
> I'm booting from a hard drive that's attached to the motherboard's
> controller (which has a VIA 82CXXX chipset, for which support is
> compiled into the kernel), so there should be no problem (in fact,
> the SuSE kernel I use is the 'eide' version which also has the
> support for Promise & VIA compiled in).
> What's going on? Most likely I enabled some configuration option I
> shouldn't have (or vice versa), but which one?

Maybe the last few lines of your boot log or dmesg (if it got written)
might help.

--
Rinaldi]$
When we remember we are all mad the mysteries disappear and
life stands explained.  - Mark Twain

 
 
 

kernel 2.2.18 + ide patch panics when trying to mount root fs

Post by Tim Van Holde » Mon, 26 Feb 2001 06:08:51




Quote:> Maybe the last few lines of your boot log or dmesg (if it got written)
> might help.

Hmm - I can't seem to reproduce the 'unsupported feature' message...

But I did see the exact problem (though the cause evades me):

at bootup, not all partitions are shown:

hda1 hda2 hda3 < hda5 >
hdg1 < hdg5 hdg6 hdg7 hdg8 hdg9 >

hda 6 to 10 are missing; my root filesystem is on hda7... so no wonder
the kernel panics :-)
Any idea as to what option to change to get the kernel to see the missing
partitions?

 
 
 

1. 2.2.18: Cannot NFS export mounted vfat FS

Hi all,

since I upgraded to 2.2.18 (from 2.2.17) I can no longer
nfs export a locally mounted vfat filesystem. I export
both, root and that vfat fs which is locally mounted
on /mnt/dosE. I'm running kernel nfsd.

/etc/exports is two lines:
  / sirius(rw,no_root_squash,nohide)
  /mnt/dosE sirius(rw,no_root_squash)

/etc/fstab mount for the vfat partition is
  /dev/hda6  /mnt/dosE  vfat  auto,user  0 0

When I try to mount /mnt/dosE from another machine (sirius)
I get a permission denied error. And the rpc.mountd
on the server side issues an error message
  "Jan  8 23:21:38 hdf rpc.mountd: getfh failed: Operation not
permitted"

The root mount is ok.

Everything went well with 2.2.17.

What has changed? What have I to change?

TIA

-Hans-

2. ioctl request list for Linux (2.0.29)

3. KERNEL PANIC in 2.2.17 and 2.2.18

4. who -> memory exhausted

5. Big trouble trying to compile a 2.2.18 kernel

6. 2.5.64-mm8: drivers/atm/idt77252.c doesn't compile

7. Kernel panic in 2.2.18 and SMP

8. Follow up on Fantasy Pentium

9. Kernel Panic with LinuxPPC, 2.2.18 and Adaptec AHA2940UW

10. Kernel panic after upgrade from 2.2.16 to 2.2.18

11. Does kernel 2.2.18 need to be patched for raid???

12. 2.2.18 IDE tape problem, with ide-scsi