CD-RW problem - can't find it!

CD-RW problem - can't find it!

Post by Gregory Stol » Wed, 29 Sep 1999 04:00:00



Hi!  I'm running RedHat 6.0 (kernel 2.2.5-15), and I've been having
problems with my CD-RW drive.  I read the CD-Writing HOWTO and did all
of the stuff, and I got to where I am now.  I have a DVD drive on
/dev/hdc, and this is detected at /dev/scd0.  My CD-RW drive is on
/dev/hdd, and I can't find it anywhere.  Both drives are IDE-ATAPI, and
I have reconfigured the kernel with appropriate options as found in the
CD-Writing HOWTO (SCSI emulation, no IDE-ATAPI CD drive, etc.)
"cdrecord -scanbus" finds the DVD drive at sr0 (on scsibus0), but for
1-7 it just prints "*".  The startup log (dmesg) seems to suggest that
the DVD is on sr0-sr7 and the CD-RW is on sr8-sr15, but I don't actually
have /dev/sr0, etc.  Here is some relevant output from dmesg:

scsi0: SCSI host adapter emulation for IDE ATAPI devices
scsi: 1 host
    Vendor: HITACHI        Model: DVD-ROM GD-2500        Rev: 0101
    Type:
CD-ROM
ANSI SCSI revision: 02
Detected scsi CD-ROM sr0 at scsi0, channel 0, id 0, lun 0
    Vendor: HITACHI        Model: DVD-ROM GD-2500        Rev: 0101
    Type:
CD-ROM
ANSI SCSI revision: 02
Detected scsi CD-ROM sr1 at scsi0, channel 0, id 0, lun 1
[...continues until sr7]
    Vendor: IDE-CD            Model: R/RW 2x2x24                    Rev:
1.6
    Type:
CD-ROM
ANSI SCSI revision: 02
Detected scsi CD-ROM sr9 at scsi0, channel 0, id 1, lun 0
    Vendor: IDE-CD            Model: R/RW 2x2x24                    Rev:
1.6
    Type:
CD-ROM
ANSI SCSI revision: 02
Detected scsi CD-ROM sr10 at scsi0, channel 0, id 1, lun 1
[...continues until sr15]
sr0: scsi3-mmc drive: 10x/24x cd/rw xa/form2 cdda tray
Uniform CDROM driver Revision: 2.54
sr1: scsi3-mmc drive: 10x/24x cd/rw xa/form2 cdda tray
sr2: scsi3-mmc drive: 10x/24x cd/rw xa/form2 cdda tray
sr3: scsi3-mmc drive: 10x/24x cd/rw xa/form2 cdda tray
sr4: scsi3-mmc drive: 10x/24x cd/rw xa/form2 cdda tray
sr5: scsi3-mmc drive: 10x/24x cd/rw xa/form2 cdda tray
sr6: scsi3-mmc drive: 10x/24x cd/rw xa/form2 cdda tray
sr7: scsi3-mmc drive: 10x/24x cd/rw xa/form2 cdda tray
sr8: scsi3-mmc drive: 24x/24x writer cd/rw xa/form2 cdda tray
sr9: scsi3-mmc drive: 24x/24x writer cd/rw xa/form2 cdda tray
sr10: scsi3-mmc drive: 24x/24x writer cd/rw xa/form2 cdda tray
sr11: scsi3-mmc drive: 24x/24x writer cd/rw xa/form2 cdda tray
sr12: scsi3-mmc drive: 24x/24x writer cd/rw xa/form2 cdda tray
sr13: scsi3-mmc drive: 24x/24x writer cd/rw xa/form2 cdda tray
sr14: scsi3-mmc drive: 24x/24x writer cd/rw xa/form2 cdda tray
sr15: scsi3-mmc drive: 24x/24x writer cd/rw xa/form2 cdda tray
sr0: disc change detected.
VFS: Disk change detected on device sr(11,0)

In my lilo.conf file I have the following line:

append="mem=96M hdc=ide-scsi hdd=ide-scsi"

and in my conf.modules I have

alias scd0 sr_mod
alias scsi_hostadapter ide-scsi

The modules that are loaded (according to lsmod) are: sg, loop,
ide-scsi, 3c509, es1371, soundcore

Sorry to include so much stuff, but I'm not really sure where the
problem is.  I looked around a lot before posting this, so I hope I'm
not wasting your time!  Anyway, any suggestions would be *greatly*
appreciated!  :-)

-Greg

-----------------------
Gregory Stoll

"I know who I am."
Check out Greg's Bridge Page!
http://www.math.swt.edu/~gs39947/bridge.html

 
 
 

CD-RW problem - can't find it!

Post by @ndre » Wed, 29 Sep 1999 04:00:00


http://move.to/linuz


> Hi!  I'm running RedHat 6.0 (kernel 2.2.5-15), and I've been having
> problems with my CD-RW drive.  I read the CD-Writing HOWTO and did all
> of the stuff, and I got to where I am now.  I have a DVD drive on
> /dev/hdc, and this is detected at /dev/scd0.  My CD-RW drive is on
> /dev/hdd, and I can't find it anywhere.  Both drives are IDE-ATAPI, and
> I have reconfigured the kernel with appropriate options as found in the
> CD-Writing HOWTO (SCSI emulation, no IDE-ATAPI CD drive, etc.)
> "cdrecord -scanbus" finds the DVD drive at sr0 (on scsibus0), but for
> 1-7 it just prints "*".  The startup log (dmesg) seems to suggest that
> the DVD is on sr0-sr7 and the CD-RW is on sr8-sr15, but I don't actually
> have /dev/sr0, etc.  Here is some relevant output from dmesg:

> scsi0: SCSI host adapter emulation for IDE ATAPI devices
> scsi: 1 host
>     Vendor: HITACHI        Model: DVD-ROM GD-2500        Rev: 0101
>     Type:
> CD-ROM
> ANSI SCSI revision: 02
> Detected scsi CD-ROM sr0 at scsi0, channel 0, id 0, lun 0
>     Vendor: HITACHI        Model: DVD-ROM GD-2500        Rev: 0101
>     Type:
> CD-ROM
> ANSI SCSI revision: 02
> Detected scsi CD-ROM sr1 at scsi0, channel 0, id 0, lun 1
> [...continues until sr7]
>     Vendor: IDE-CD            Model: R/RW 2x2x24                    Rev:
> 1.6
>     Type:
> CD-ROM
> ANSI SCSI revision: 02
> Detected scsi CD-ROM sr9 at scsi0, channel 0, id 1, lun 0
>     Vendor: IDE-CD            Model: R/RW 2x2x24                    Rev:
> 1.6
>     Type:
> CD-ROM
> ANSI SCSI revision: 02
> Detected scsi CD-ROM sr10 at scsi0, channel 0, id 1, lun 1
> [...continues until sr15]
> sr0: scsi3-mmc drive: 10x/24x cd/rw xa/form2 cdda tray
> Uniform CDROM driver Revision: 2.54
> sr1: scsi3-mmc drive: 10x/24x cd/rw xa/form2 cdda tray
> sr2: scsi3-mmc drive: 10x/24x cd/rw xa/form2 cdda tray
> sr3: scsi3-mmc drive: 10x/24x cd/rw xa/form2 cdda tray
> sr4: scsi3-mmc drive: 10x/24x cd/rw xa/form2 cdda tray
> sr5: scsi3-mmc drive: 10x/24x cd/rw xa/form2 cdda tray
> sr6: scsi3-mmc drive: 10x/24x cd/rw xa/form2 cdda tray
> sr7: scsi3-mmc drive: 10x/24x cd/rw xa/form2 cdda tray
> sr8: scsi3-mmc drive: 24x/24x writer cd/rw xa/form2 cdda tray
> sr9: scsi3-mmc drive: 24x/24x writer cd/rw xa/form2 cdda tray
> sr10: scsi3-mmc drive: 24x/24x writer cd/rw xa/form2 cdda tray
> sr11: scsi3-mmc drive: 24x/24x writer cd/rw xa/form2 cdda tray
> sr12: scsi3-mmc drive: 24x/24x writer cd/rw xa/form2 cdda tray
> sr13: scsi3-mmc drive: 24x/24x writer cd/rw xa/form2 cdda tray
> sr14: scsi3-mmc drive: 24x/24x writer cd/rw xa/form2 cdda tray
> sr15: scsi3-mmc drive: 24x/24x writer cd/rw xa/form2 cdda tray
> sr0: disc change detected.
> VFS: Disk change detected on device sr(11,0)

> In my lilo.conf file I have the following line:

> append="mem=96M hdc=ide-scsi hdd=ide-scsi"

> and in my conf.modules I have

> alias scd0 sr_mod
> alias scsi_hostadapter ide-scsi

> The modules that are loaded (according to lsmod) are: sg, loop,
> ide-scsi, 3c509, es1371, soundcore

> Sorry to include so much stuff, but I'm not really sure where the
> problem is.  I looked around a lot before posting this, so I hope I'm
> not wasting your time!  Anyway, any suggestions would be *greatly*
> appreciated!  :-)

> -Greg

> -----------------------
> Gregory Stoll

> "I know who I am."
> Check out Greg's Bridge Page!
> http://www.math.swt.edu/~gs39947/bridge.html

  -----------== Posted via Newsfeeds.Com, Uncensored Usenet News ==----------
   http://www.newsfeeds.com       The Largest Usenet Servers in the World!
------== Over 73,000 Newsgroups - Including  Dedicated  Binaries Servers ==-----

 
 
 

CD-RW problem - can't find it!

Post by Gregory Stol » Wed, 29 Sep 1999 04:00:00


OK, I'm using xcdroast now, and it "sees" my CD-RW drive, but it won't let me write
to it, and it can't tell that there's a CD in the drive.  It can read my DVD drive
though, so something still isn't quite working...Please help!
:-)

-Greg

-----------------------
Gregory Stoll

"I know who I am."
Check out Greg's Bridge Page!
http://www.math.swt.edu/~gs39947/bridge.html

 
 
 

CD-RW problem - can't find it!

Post by Timo Sakari Leppiniem » Wed, 29 Sep 1999 04:00:00



> OK, I'm using xcdroast now, and it "sees" my CD-RW drive, but it won't let me write
> to it, and it can't tell that there's a CD in the drive.  It can read my DVD drive
> though, so something still isn't quite working...Please help!
> :-)

> -Greg

> -----------------------
> Gregory Stoll

> "I know who I am."
> Check out Greg's Bridge Page!
> http://www.math.swt.edu/~gs39947/bridge.html

    I had once the same problem... I think that you have compiled in the kernel scsi
section
    probe all LUN's??? I removed that option from the kernel and after that it
worked...

            -timppa

 
 
 

1. SCSI CD-RW: yamaha 4416s: HowTo REWrite CD-RW's?

Hi,

I have a SCSI-CD-RW drive yamaha 4416s in my linux box
(4x write, 4x re-write, 16x read)
along with a SCSI CD-ROM TEAC CD-532S (/dev/scd0)

1) How to get it work with CD-RW's?
2) How to erase CD-RW's?
3) How to (re-)write?

I have cdrecord and xcdroast installed.

Many questions. I know

Any help is welcome.
Carsten

2. dosemu not working

3. Where to Find 'xcdroast' +'cdwrite' for CD-RW ?

4. XFree 3.1 and GNU Emacs 19.25

5. broken 2.2 IDE CD-RW (was Re: plain 2.2.X: no ide CD-RW?)

6. RS6000 ethernet

7. HP CD-RW hangs my machine when mounting it!!!!

8. Permissions on burned cd (please help)

9. CD-RW support specifically with NEC NR 7700A CD-RW drive

10. ide-scsi cd-rw woes (creative cd-rw blaster)

11. Sony DVD-RW/CD-RW drive problems

12. PROBLEM: CD-RW doesn't work well in 2.4.21-pre4(-ac4)

13. Can't mount CD-RW or Music CD.