Help me on ATI Mach 64 Configuration!!!!!!!

Help me on ATI Mach 64 Configuration!!!!!!!

Post by vicente fernande » Wed, 29 Jul 1998 04:00:00



Hi:

  first my configuration:
  -VX-Pro II PCI Motherboard
  -Slackware 96 ( Linux 2.0.27)
  -Ati Graphics Pro (Mach64) PCI Video Card,

  two problems:

  1 - The kernel dont detect the PCI VGA card ( I have the PCI option
      in the kernel )
  2 - The Xfree XF86Setup  start and the screen goes black with crazy
lines.

 What could i do???

 thanks.

 
 
 

1. S3 964 Diamond Stealth 64, ATI Mach 64 and Gateway Vivitron 1776 - Help!!!

I'm kinda new to Linux but had some time under my belt with this OS so
I thought I'd do some experimenting.

I had X-Windows setup with my Gateway/ATI  Mach 64 GX (according to Windoze95
it VRAM). When I opened up several apps in this order 'xfm', Netscape, and Cockpit
everthing came up OK but I would get color shifts when switching from app to app.
When I tried starting apps up in this order Netscape, Cockpit and then 'xfm' I would get
some kind of response saying something like 'not enough colors to display icons'.
And sure enough, the icons in 'xfm' would not diplay.

I assumed that one of the possible causes of this was that I was running at
1280x1024 8bpp. I tried editing my XF86Config file so the 8bpp section was
removed and could not get any X-Window display for 16bpp.

I figured that one of the possible reasons for this to occur was becuse the graphics
card did not have enough memory to display more than 8bpp. I also though I read
that you can't display more than 8bpp with the ATI card. Is this true?

So I happened to get my hands on a Diamond Stealth 64 (S3 964) w/4MB VRAM
card. I have read that support for Diamond products and Linux is not that great but
saw some workarounds in the various README's.

With the Diamond card when I startx I get nothing but a white screen. I saw the adds
for MetroX in the Linux Journal and read the review on this product and though that
this was the answer to my problem. I got it, installed it and selected virtually
every possible resolution and bpp possible.

It seemed to work OK at low res but anything above 800x600 displays 'stuff' all over the
screen and broken or distorted text in the dialog boxes. Is there a way to solve this
problem? If the best I can get with the Stealth 64 card is 8bpp (even with MetroX)
I'd be better of with my Mach 64 card at 8bpp (I'd save 100 bucks) and the stuff I
have to do in Windoze95 would take a little longer to display).

Of course, if MetroX would allow me to display 16bpp or 32bpp at 1280x1024
with the Mach 64 card it might be worth keeping. Can anybody offer any suggestions
or help?

Thanx,


2. atexit() across exec()

3. HELP HELP HELP!! ATI Mach 64 and X

4. USB dock (laptop)

5. ATI MAch 64 vs STB PowerGraph 64

6. CD-ROM drives with LINUX.

7. Diamond Stealth 64 Video VRAM or ATI Graphics Pro Turbo (Mach 64)?

8. backscroll? & xv for linux?

9. Stealth Video 64 or ATI Mach 64

10. ATI Mach 64 informations, then ATI vs Diamond vs Miro, Zappa vs Alladin.

11. ATI Mach 64 infos requested, ATI vs Diamond vs Miro, Zappa vs Alladin.

12. ATI mach 64? ATI rage 128?

13. Request for help: dot clocks on ATI Mach 64 WinTurbo/ProTurbo