Does the HP7200i ATAPI CD Writer need SCSI emulation

Does the HP7200i ATAPI CD Writer need SCSI emulation

Post by Paul Joh » Fri, 11 Jun 1999 04:00:00



Relevant config:
        SuSE 6.1 kernel 2.25
        KDE    
        HP 7200i IDE CD writer
        8.4GB EIDE hda
        4.2GB SCSI sda
        PPro 128M

In order to get my HP 7200i IDE CD writer to work, I enabled SCSI
emulation in the kernel & recompiled. Everything is fine, and the
drives are recognised correctly by cdwrite & cdrecord. However,
whenever I write a CDR, 9 times out of 10 it fails part way through
due to a SCSI I/O error & the buffer becoming empty. I stepped the
write speed down to x1 and the result is the same. Oddly enough,
it does seem to work without error on a rewriteable CD. I have tried
several brands of CDR's & all fail somewhere between 25 & 60%
through the write process.

I can only assume the problem lies with the SCSI emulation. I notice
there are other cd recording apps about, keasycd for example and I
wondered if there are any that will work with the CD writer in
native ATAPI/IDE mode.

Failing that, are there any special parameters I should be using for
the SCSI emulation. At the moment,  it is recognised by CDToast as a
generic SCSI CD-Writer.

Any help appreciated. Thanks.

 
 
 

Does the HP7200i ATAPI CD Writer need SCSI emulation

Post by David Borows » Sat, 12 Jun 1999 04:00:00


: Relevant config:
:       SuSE 6.1 kernel 2.25
:       KDE    
:       HP 7200i IDE CD writer
:       8.4GB EIDE hda
:       4.2GB SCSI sda
:       PPro 128M

: In order to get my HP 7200i IDE CD writer to work, I enabled SCSI
: emulation in the kernel & recompiled. Everything is fine, and the
: drives are recognised correctly by cdwrite & cdrecord. However,
: whenever I write a CDR, 9 times out of 10 it fails part way through
: due to a SCSI I/O error & the buffer becoming empty. I stepped the
: write speed down to x1 and the result is the same. Oddly enough,
: it does seem to work without error on a rewriteable CD. I have tried
: several brands of CDR's & all fail somewhere between 25 & 60%
: through the write process.

: I can only assume the problem lies with the SCSI emulation. I notice
: there are other cd recording apps about, keasycd for example and I
: wondered if there are any that will work with the CD writer in
: native ATAPI/IDE mode.

: Failing that, are there any special parameters I should be using for
: the SCSI emulation. At the moment,  it is recognised by CDToast as a
: generic SCSI CD-Writer.

: Any help appreciated. Thanks.

I use the 7200i on a p133 on 2.26 without trouble.
some things to check:  your 7200i should be set to master on the
second ide bus.  some other cd readers if set to slave on the same bus
mess it up like mitsumi.  7200i is somewhat prone to dust if it is
in a dusty room and even afew months old, clean it!
Try cdrecord that's what I use.  If you're running samba or other odd
network stuff like dhcp try turning it off.
Hope this helps.