Soundblaster Live - Wrong kernal version

Soundblaster Live - Wrong kernal version

Post by Darre » Fri, 10 Sep 1999 04:00:00



Hello, I'm hoping someone can quickly explain how I can get past this
problem I'm having with getting my SB Live running.

When I do "insmod emu10k1", I get the following message:


Using /lib/modules/2.2.5/misc/emu10k1.o
/lib/modules/2.2.5/misc/emu10k1.o: kernel-module version mismatch
        /lib/modules/2.2.5/misc/emu10k1.o was compiled for kernel
version 2.2.5-15
        while this kernel is version 2.2.5.

I'm running kernal 2.2.7. Do I need to install 2.2.5 or is there a way
aroung that?

Regards,
Darren

 
 
 

Soundblaster Live - Wrong kernal version

Post by f.g.a.m.wouter » Fri, 10 Sep 1999 04:00:00


The answer is simple, you have downloaded the wrong tar.

Frans Wouters



> Hello, I'm hoping someone can quickly explain how I can get past this
> problem I'm having with getting my SB Live running.

> When I do "insmod emu10k1", I get the following message:


> Using /lib/modules/2.2.5/misc/emu10k1.o
> /lib/modules/2.2.5/misc/emu10k1.o: kernel-module version mismatch
>         /lib/modules/2.2.5/misc/emu10k1.o was compiled for kernel
> version 2.2.5-15
>         while this kernel is version 2.2.5.

> I'm running kernal 2.2.7. Do I need to install 2.2.5 or is there a way
> aroung that?

> Regards,
> Darren


 
 
 

Soundblaster Live - Wrong kernal version

Post by John Clanc » Fri, 10 Sep 1999 04:00:00


>> When I do "insmod emu10k1", I get the following message:


>> Using /lib/modules/2.2.5/misc/emu10k1.o
>> /lib/modules/2.2.5/misc/emu10k1.o: kernel-module version mismatch
>>         /lib/modules/2.2.5/misc/emu10k1.o was compiled for kernel
>> version 2.2.5-15
>>         while this kernel is version 2.2.5.

>> I'm running kernal 2.2.7. Do I need to install 2.2.5 or is there a way
>> aroung that?

>> Regards,
>> Darren

If you read the readme in the emu10k1.tar.gz package it warns you about
putting an 'alias emu10k1 -f' or something along those lines in your
/etc/conf.modules file I run redhat 6.0 with the kernel update to 2.2.5-22
and it works fine with the -f option, you could test by doing an 'insmod
emu10k1 -f' and see if that loads it

John Clancy

 
 
 

Soundblaster Live - Wrong kernal version

Post by Kent Carpente » Fri, 10 Sep 1999 04:00:00



> Hello, I'm hoping someone can quickly explain how I can get past this
> problem I'm having with getting my SB Live running.

> When I do "insmod emu10k1", I get the following message:


> Using /lib/modules/2.2.5/misc/emu10k1.o
> /lib/modules/2.2.5/misc/emu10k1.o: kernel-module version mismatch
>         /lib/modules/2.2.5/misc/emu10k1.o was compiled for kernel
> version 2.2.5-15
>         while this kernel is version 2.2.5.

> I'm running kernal 2.2.7. Do I need to install 2.2.5 or is there a way
> aroung that?

> Regards,
> Darren

Didn't the tar come with several modules compiled for different kernels?
(mine did)

Anyway, No you don't NEED to install 2.2.5.

insmod -f emu10k1

"-f" will force its use even with the kernel mismatch (should work if
the module used was compiled for a similar version kernel). It will
still report the error, but the module will be loaded, and in many cases
will work just fine.

 
 
 

Soundblaster Live - Wrong kernal version

Post by Darryl Bryan » Sat, 11 Sep 1999 04:00:00



> Hello, I'm hoping someone can quickly explain how I can get past this
> problem I'm having with getting my SB Live running.

> When I do "insmod emu10k1", I get the following message:


> Using /lib/modules/2.2.5/misc/emu10k1.o
> /lib/modules/2.2.5/misc/emu10k1.o: kernel-module version mismatch
>         /lib/modules/2.2.5/misc/emu10k1.o was compiled for kernel
> version 2.2.5-15
>         while this kernel is version 2.2.5.

> I'm running kernal 2.2.7. Do I need to install 2.2.5 or is there a way
> aroung that?

> Regards,
> Darren

try this, I did this on mandrake 6 with the 2.2.9-19mdk kernel, this from
an earlier post.

dAz

1.)  Extract the drivers you downloaded off Creative's Web site into a
folder on your personal directory
2.)  You will need to copy the file named "emu10k1.o-2.2.5-15 into your
/lib/modules/2.2.9-19mdk/misc (or the /lib/modules/2.2.7/misc in your case)
folder and rename it to emu10k1.o
3.)  Open up your /etc/conf.modules file and add the following lines:-

alias sound emu10k1
options emu10k1 -f
pre-install emu10k1 insmod soundcore
post-remove emu10k1 rmmod soundcore

Save the file and reboot and that should be that :-)

A word of warning though, if you are going to upgrade your kernel, it
must be of the 2.2.10 or higher varety, as the emu10k1 module will not
work with kernel upgrades below these.

 
 
 

1. Soundblaster Live! with wrong PCI ID

  Greetings.  I just got a new computer with an SB Live! in it, but it seems
to be either a new revision or a special version.  The normal emu10k1
drivers do not detect the device at all because the PCI id is 1102:0006
instead of 1102:0002.

Does anyone know any quick fixes?  And if not, what would I need to do to
compile a custom driver that detects the 0006 instead of the 0002?

Thanks!

-Dave

2. logging in using modems

3. wrong kernal version....

4. help w/man pages on OSR5.0.2

5. plip-link: wrong cable? wrong version?

6. Run Perl Socket As Unix Deamon

7. Error: Wrong version of [$JAVAHOME/]java for this version of AIX.

8. accessing POP server from unix terminal?

9. Call 1-800-856-2469, LIVE LIVE LIVE 809-474-7588 code830

10. Call 1-800-856-2469, LIVE LIVE LIVE 809-474-7588 code2311

11. Call 1-800-856-2469, LIVE LIVE LIVE 809-474-7588 code820

12. Call 1-800-856-2469, LIVE LIVE LIVE 809-474-7588 code826

13. Problem: Soundblaster AWE 64 on Kernal 2.1.129