3c509B Combo not detected

3c509B Combo not detected

Post by Jose M. Pere » Tue, 03 Dec 1996 04:00:00



Firstly, sorry for my English, its not good enough. Im from Spain.

    My computer does not detect my Ethernet card, 3c509B. This card
configuration is: PnP disabled, I/O port 0x300, interrupt 10. I have
compiled the kernel with support for the 3c509 card, I think at least.
DOS and W95 do detect the card and all tests I passed the card under
these systems have been ok. The computer only have a PCI card (video
card) and the ethernet card (ISA). By the way, when kernel probe PCI
hardware it gives me TWO warnings about PCI hardaware: something like
"unknown PCI hardware: vendor=8 .... contact .."; I only have one pci
card and obtain two warnings.
    With the 3c509B, the most surprising thing is that I have another
computer, DELL XPS 120Mhz with the same card 3c509 and I have no
problems at all. Both cards with the same configuration 0x300 i/o port,
interrupt 10. One computer detect it and another one does not. :-(((.
    I have even interchanged kernel files (vmlinuz) from Dell computer
to the bad one with no result.

    Main board in which Linux doesnt detect 3c509 card is a Pentium
P5I430VX-250 Explorer green.

    Could anyone help me ?.
    Thank you.

 
 
 

3c509B Combo not detected

Post by Roland Exle » Wed, 04 Dec 1996 04:00:00



>     My computer does not detect my Ethernet card, 3c509B. This card
> configuration is: PnP disabled, I/O port 0x300, interrupt 10. I have
> compiled the kernel with support for the 3c509 card, I think at least.
> DOS and W95 do detect the card and all tests I passed the card under
> these systems have been ok. The computer only have a PCI card (video
> card) and the ethernet card (ISA). By the way, when kernel probe PCI
> hardware it gives me TWO warnings about PCI hardaware: something like
> "unknown PCI hardware: vendor=8 .... contact .."; I only have one pci
> card and obtain two warnings.
>     With the 3c509B, the most surprising thing is that I have another
> computer, DELL XPS 120Mhz with the same card 3c509 and I have no
> problems at all. Both cards with the same configuration 0x300 i/o port,
> interrupt 10. One computer detect it and another one does not. :-(((.
>     I have even interchanged kernel files (vmlinuz) from Dell computer
> to the bad one with no result.

>     Main board in which Linux doesnt detect 3c509 card is a Pentium
> P5I430VX-250 Explorer green.

Are your sure it's the ethernet-card which is not detected? If your
mainboard has on-board periperals they may be the reason for the warning.
Look at the file 'pci.h', there you may find at least the vendors of the
cards not recogniced.

Besides from this, the pci-warnings are most likely not effecting
operation at all, as long as no driver is used which reads out the
pci-configuration. I've a P133 with Adaptec 2940, 3c900,
on-board-graphics and IO and got three or four warnings like you got, but
anything is running without problems after recompiling the kernel using
the right drivers (the messages stay).

Roland

+---------------------------------------+---------------------------+
I Roland Exler                          I EMAIL:                    I

I Institut fuer Elektrische Messtechnik I                           I
I Altenbergerstr. 69                    I Phone:                    I
I A-4040 Linz, AUSTRIA                  I + 43 732 2468 9205        I
+---------------------------------------+---------------------------+

 
 
 

3c509B Combo not detected

Post by Markus Schmi » Wed, 04 Dec 1996 04:00:00



: Firstly, sorry for my English, its not good enough. Im from Spain.
:
:     My computer does not detect my Ethernet card, 3c509B. This card
: configuration is: PnP disabled, I/O port 0x300, interrupt 10. I have
: compiled the kernel with support for the 3c509 card, I think at least.
: DOS and W95 do detect the card and all tests I passed the card under
: these systems have been ok. The computer only have a PCI card (video
: card) and the ethernet card (ISA). By the way, when kernel probe PCI
: hardware it gives me TWO warnings about PCI hardaware: something like
: "unknown PCI hardware: vendor=8 .... contact .."; I only have one pci
: card and obtain two warnings.
:     With the 3c509B, the most surprising thing is that I have another
: computer, DELL XPS 120Mhz with the same card 3c509 and I have no
: problems at all. Both cards with the same configuration 0x300 i/o port,
: interrupt 10. One computer detect it and another one does not. :-(((.
:     I have even interchanged kernel files (vmlinuz) from Dell computer
: to the bad one with no result.
:
:     Main board in which Linux doesnt detect 3c509 card is a Pentium
: P5I430VX-250 Explorer green.
:    
:     Could anyone help me ?.
:     Thank you.

Hi
Try to boot with the option :
eth0=0x300,10

Markus
--
Markus FWEREWOLF Schmitt


WWW     : http://vieta.math.uni-sb.de/~fw/eigene/Welcome.html

 
 
 

1. 3com 3c509B Combo not detected at boot

I am trying to get my 3com 3c509B combo that is setup
via the 3com dos util:  PnP OFF;  irq 10;  i/o address 0x300 to
detect at boot in linux 1.2.13.  I do *not* have the EEPROM set
up to auto detect -- it is set up at 10BaseT only.  I am told auto-
detection is not reliable?

Anyway, I use the following parameters at boot:

LILO:  linux ether=10,0x300,eth0

with these parameters it gives me the error messages:

ewrk3_probe(): No device found
eth0: de4x5_probe() cannot find device at 0x0300.

*without* these parameters it gives me the error messages:

eth0: ewrk3_probe(): Detected a device already registered at 0x2e0
eth0: ewrk3_probe(): Detected a device already registered at 0x360
eth0: ewrk3_probe(): Detected a device already registered at 0x3c0

Is there something I should do/rebuild the kernel
so that this hardware device is seen and/or the proper driver sees it?

I am using Linux  release 1.2.13.

Any suggestions would be appreciated!

Thanx!!

Steve

2. ODT 3.0 ISAM-Libs on OSR5.04 ???

3. my 3c509b not detected by installed kernel, IS detected when I use net root disk.

4. Using loadlin.exe with Win98?

5. help: not detecting network card, can't find 3c509b at boot time (not P&P )

6. FAST Modems > 28800 baud

7. 3c509b combo nic not recognized

8. Quicktime under linux, an alternate approach?

9. 3COM Etherlink III 3c509B - not detected ??

10. 3com 3c509b not auto detected

11. 3c509b combo: doesn't find TP connector

12. 3c509B Combo card

13. 3C509B-COMBO Ethernet Card Problem