Help on SMC-EtherEZ card, please

Help on SMC-EtherEZ card, please

Post by Arul Selva » Mon, 29 Dec 1997 04:00:00



Hi,

I am trying to load the smc-ultra.o module using insmod but
unable to load it properly. I get the following message.


printk: wrong version or undefined
check_region: wrong version or undefined
init_etherdev: wrong version or undefined
ei_debug: wrong version or undefined
ethdev_init: wrong version or undefined
request_region: wrong version or undefined
NS8390_init: wrong version or undefined
ei_interrupt: wrong version or undefined
request_irq: wrong version or undefined
ei_open: wrong version or undefined
jiffies: wrong version or undefined
eth_copy_and_sum: wrong version or undefined
free_irq: wrong version or undefined
irq2dev_map: wrong version or undefined
register_netdev: wrong version or undefined
kfree: wrong version or undefined
release_region: wrong version or undefined
unregister_netdev: wrong version or undefined
Loading failed! The module symbols (from linux-2.0.30) don't match your
linux-2.0.30

Any ideas?.

Thanks in advance. Could you please cc: the reply to my e-mail?

-Arul

 
 
 

Help on SMC-EtherEZ card, please

Post by John Smit » Mon, 29 Dec 1997 04:00:00


try modprobe smc-ultra io=0x300 or whatever io port your card is setup to.


>Hi,

>I am trying to load the smc-ultra.o module using insmod but
>unable to load it properly. I get the following message.


>printk: wrong version or undefined
>check_region: wrong version or undefined
>init_etherdev: wrong version or undefined
>ei_debug: wrong version or undefined
>ethdev_init: wrong version or undefined
>request_region: wrong version or undefined
>NS8390_init: wrong version or undefined
>ei_interrupt: wrong version or undefined
>request_irq: wrong version or undefined
>ei_open: wrong version or undefined
>jiffies: wrong version or undefined
>eth_copy_and_sum: wrong version or undefined
>free_irq: wrong version or undefined
>irq2dev_map: wrong version or undefined
>register_netdev: wrong version or undefined
>kfree: wrong version or undefined
>release_region: wrong version or undefined
>unregister_netdev: wrong version or undefined
>Loading failed! The module symbols (from linux-2.0.30) don't match your
>linux-2.0.30

>Any ideas?.

>Thanks in advance. Could you please cc: the reply to my e-mail?

>-Arul