AMI MegaRAID 1600 + RH 7.1 not working

AMI MegaRAID 1600 + RH 7.1 not working

Post by Oliver Olse » Wed, 25 Apr 2001 17:54:00



Hi!
I'm trying to install RH 7.1 on an Intel server (dual P3-1ghz, 512mb RDIMM
etc) with the AMI MegaRAID 1600-controller (493). RH 7.1 detects the
controller, I'm able to select the packages wanted as well as specifying
what partitions/sizes to use. It also says that the sda-partition has to be
initialized, and I have to press 5 times in order to continue. However, when
I'm done and have pressed the OK button in order to start installing I get
the message:
"Unable to format /. This may be a serious error".

Anyone familiar with this? I've tried RH 7.0 (2.2.16-22enterprise kernel)
which works great. However, as I'd like the 2.4 kernel in order to run
Vmware G6-server. I then compiled the 2.4.3-ac9 kernel and tried booting up.
The kernel recogizes the controller and disk-array, but says:

SCSI device sda: 286875648 512 byte hdwr sectors (146880 MB)
 sda: unknow partition table

blah-blah-blah......

VFS: Cannot open root device "801" or 08:01
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on 08:01

___________________________-

This looks like a 2.4 kernel problem and my controller. I've tried mailing
AMI-support, but not much response from them yet.

Anyone??

Best regards,
Oliver Olsen

 
 
 

AMI MegaRAID 1600 + RH 7.1 not working

Post by Roberto Migliorat » Sat, 28 Apr 2001 10:12:49


With RH 7.0, were you using the stock standard kernel?? Some manufacturers
(Dell and others) include customised patches in their kernels to support
their hardware (RAID controllers in particular). If this is your case then
try and visit the server maker we-site and look for patches that will work
with your setup.

Regards,

Roberto.

Quote:> Hi!
> I'm trying to install RH 7.1 on an Intel server (dual P3-1ghz, 512mb RDIMM
> etc) with the AMI MegaRAID 1600-controller (493). RH 7.1 detects the
> controller, I'm able to select the packages wanted as well as specifying
> what partitions/sizes to use. It also says that the sda-partition has to
be
> initialized, and I have to press 5 times in order to continue. However,
when
> I'm done and have pressed the OK button in order to start installing I get
> the message:
> "Unable to format /. This may be a serious error".

> Anyone familiar with this? I've tried RH 7.0 (2.2.16-22enterprise kernel)
> which works great. However, as I'd like the 2.4 kernel in order to run
> Vmware G6-server. I then compiled the 2.4.3-ac9 kernel and tried booting
up.
> The kernel recogizes the controller and disk-array, but says:

> SCSI device sda: 286875648 512 byte hdwr sectors (146880 MB)
>  sda: unknow partition table

> blah-blah-blah......

> VFS: Cannot open root device "801" or 08:01
> Please append a correct "root=" boot option
> Kernel panic: VFS: Unable to mount root fs on 08:01

> ___________________________-

> This looks like a 2.4 kernel problem and my controller. I've tried mailing
> AMI-support, but not much response from them yet.

> Anyone??

> Best regards,
> Oliver Olsen


 
 
 

AMI MegaRAID 1600 + RH 7.1 not working

Post by Oliver Olse » Sat, 28 Apr 2001 16:50:00



Quote:> With RH 7.0, were you using the stock standard kernel?? Some manufacturers
> (Dell and others) include customised patches in their kernels to support
> their hardware (RAID controllers in particular). If this is your case then
> try and visit the server maker we-site and look for patches that will work
> with your setup.

My server is one of the server-packs you can buy from Intel (yes, case,
mobo, cpu's are from Intel) and yes, I used standard kernel as I am booting
from the cd.
The AMI-card is bought separately, and I naturally tried AMI for support.
However, their support is the worst I've ever experienced. Totally arrogant
with one-line answers and no useful info whatsoever.
I've tried several news-groups as well as Bugzilla. No solution here yet. I
know Dell use some of these controllers (guess they have "Dellified" the
firmware/BIOS) but they claim a working driver is included with RH 7.1.
Guess I'll have to stick with RH 7.0 and the 2.2 brach if no solution is
found shortly.

regards,
Oliver

 
 
 

AMI MegaRAID 1600 + RH 7.1 not working

Post by Victor Martine » Sat, 05 May 2001 01:53:34


I installed rh7.1 (seawolf) on machine with a AMI Elite 1600 (2ch).
I did not install the os on the raid, it is used for a data drive. But it
was recognized and I was able to setup the mount during the installation.
 
 
 

1. Driver for AMI MegaRAID Elite 1600 (Dell PERC3/DC )??

Anyone have any idea how to get Solaris 10 to install on the above
controller?  I've looked around but have been unsuccessful in finding a
driver.

LSI used to have a driver for Solaris 6, 7, and 8 but I don't see
anything newer nor even those drivers for download on their website (LSI
apparently purchased AMI).

Thanks for any leads/tips!

2. PPP trouble

3. AMI MegaRaid Elite 1600

4. on linux now since 1995 new to PPC

5. AMI Megaraid Express 200 on RH 7.1?

6. Firewall problems

7. Kyocera FS 1600 or FS 1600+ Printer drivers ( FS-1600 FS-1600+)

8. Problem while creating two different sockets.

9. Installing an Ami MegaRaid express 500 (40LD) in a Red Hat 7.1

10. RedHat 7.1 + AMI MegaRAID 100 need help

11. Compaq Presario 1600 e Mandrake 7.1?

12. Proliant ML530, Megaraid 493 (Elite 1600), 2.4.7, timeout & abort

13. Slow SCSI Disk Access on AMI Elite 1600 controller