SCSI AVA1502 problems

SCSI AVA1502 problems

Post by Mike Fieschk » Tue, 27 Apr 1999 04:00:00




> I'm having problems getting Linux to recognize my SCSI adapter.  It's a
> Adaptec AVA1502, it has selectable IO and IRQs, no conflict in Windows.  The
> HOWTO says it's supported by the AHA152x driver.  I have compiled it as a
> module because you use settings, but when load the module, I used to get an
> error message that said something about "SCSI Hosts: 0" or none found, and it
> would not be loaded. Now I get an "init_module: Device or resource busy"
> error.

> Can someone help me out or guide me in the right direction.

What's in your /etc/conf.modules file about the aha152x module?

--

Message composed with XEmacs 20.4 and VM 6.70 on RedHat 5.2
Kernel 2.2.5-2 (was 2.2.3-ac4-4)

 
 
 

SCSI AVA1502 problems

Post by w.. » Wed, 28 Apr 1999 04:00:00


Greetings,

Quote:>I'm having problems getting Linux to recognize my SCSI adapter.  It's a
>Adaptec AVA1502, it has selectable IO and IRQs, no conflict in Windows.  The
>HOWTO says it's supported by the AHA152x driver.  I have compiled it as a
>module because you use settings, but when load the module, I used to get an
>error message that said something about "SCSI Hosts: 0" or none found, and it
>would not be loaded. Now I get an "init_module: Device or resource busy"

Since you're using modules, add the following line to  /etc/conf.modules
  options aha152x aha152x=0x340,11,7,1
(this assumes I/O=0x340, interrupt=11)

You don't need to use modules.  You can compile aha152x support into the
kernal.  Then specify it's settings during boot.
If you use loadlin:
  loadlin.exe zImage root=/dev/hdb1 aha152x=0x340,11,7,1
If you're using lilo, add the following line to  /etc/lilo.conf
  append="aha152x=0x340,11,7,1"

Later,
        William Altaffer


 
 
 

SCSI AVA1502 problems

Post by Frithjof Ander » Thu, 29 Apr 1999 04:00:00



> I'm having problems getting Linux to recognize my SCSI adapter.  It's a
> Adaptec AVA1502, it has selectable IO and IRQs, no conflict in Windows.  The
> HOWTO says it's supported by the AHA152x driver.  I have compiled it as a
> module because you use settings, but when load the module, I used to get an
> error message that said something about "SCSI Hosts: 0" or none found, and it
> would not be loaded. Now I get an "init_module: Device or resource busy"
> error.

> Can someone help me out or guide me in the right direction.

somebody wrote already:   Since you're using modules, add the following line to
/etc/conf.modules    options aha152x aha152x=0x340,11,7,1
   (this assumes I/O=0x340, interrupt=11)

The module does only probe some limited number of ports. If you have a IOMEGA
ZOOM
card, which is sold for using with the ZIP drive, the port address is 0x140 and
IRQ 11.,
according to the installation manual..

Just look in your hardware handbook and substitute the proper port address and
IRQ
as options for the aha152x module.

good look
Frithjof

--
        "If you see someone without a smile, give him one of yours"

Frithjof Anders
Institut  fuer Festkoerperphysik
Technische Universitaet Darmstadt
Hochschulstr. 6
64289 Darmstadt, GERMANY


FAX  +49 (6151) 16-3681

 
 
 

1. PLEASE HELP! -> Adaptec SCSI AVA1502 <-

I have a Iomega Zip Plus on a Iomega Zip Zoom SCSI card; it is an
Adaptec AVA-1502, which should work with aha152x driver. I give:

modprobe aha152x aha152x=0x140,9,7

and get:

1 controller detected [.....] probing software interrupt: 9: software
interrupt lost, maybe wrong. [.... ] SCSI 0 hosts
SCSI detected total (!!)

But it correctly works under Windows 95 with IO=0x140 and irq=9. I am
using kernel 2.2.5, what else can I do? Some people has managed to mke
the card work, and I've followed their instructions....

Thanks to anyone can help

Ernesto Mottola

2. Including Content

3. 4th message: PLEASE HELP -->AVA1502 SCSI card <--

4. Problems with system include files

5. Please Help! -> Adaptec SCSI AVA1502 <-

6. Gnomemeeting can't send video to Netmeeting

7. How to work with PD driver using AVA1502 SCSI card?

8. ANNOUNCE XCd 1.3

9. SCSI aha152x AVA1502

10. problems with soundcard + ava1502

11. Sudden seg fault problems with Microtek E3 & ava1502

12. Slackware 3.3 doesn't see; Adaptec AVA1502 & Matsushita 7501

13. ava1502 ae + mikrotek e3