Screen goes blank/Keyboard locks

Screen goes blank/Keyboard locks

Post by Klaus Wern » Tue, 12 May 1998 04:00:00



DEC pc Lpx 486DX2 - 16MB RAM - 1 primary (330MB) & 1 Secondary (850MB) HDD
Screen: DEC VRC16
Linux: Slackware 3.4

I boot Linux (on the secondary HDD) from the primary drive using Loadlin.
I find that from time to time the keyboard will not work, sometimes at the
login prompt. Nothing works to recover the situation, except using the
powerwsitch.
When compiling WINE (which took approx. 2 hours!) after about 15 minutes
the screen went blank, without any way of 'switching' it back on. The
compile job worked successfully, but again had to reboot to recover.
I looked at the setterm -blank variable; it was coded into one of the
rc files - commented that out but the same happens.
X Windows however works fine - it goes blank after a certain time and
touching the mouse brings the screen up again.
Perhaps this has nothing to do with Linux - hardware problem likely.
Any thoughts/hints/advice appreciated.
Klaus

--
Klaus Werner

REMOVE 'NOS' FROM ADDRESS IF REPLYING BY EMAIL!

 
 
 

Screen goes blank/Keyboard locks

Post by Ia » Wed, 13 May 1998 04:00:00




Quote:> X Windows however works fine - it goes blank after a certain time
> and touching the mouse brings the screen up again.  Perhaps this has
> nothing to do with Linux - hardware problem likely.  Any
> thoughts/hints/advice appreciated.

Check your DPMS and powersaving settings in the BIOS and your monitor,
if it has power settings. My monitor used to blank on X startup,
switching the BIOS DPMS signalling from "DPMS" to "Hsync/Vsync blank"
stopped this happening.

The power saving events usually have a list of IRQs that are wake-up
events. It sounds like your keyboard is not amongst them. I think I
switched off all motherboard power-saving features and got X to
control the monitor itself.

--

There are no facts, only opinions

 
 
 

1. startx produces blank screen and locks system

I've actually gotten InfoMagic's Slackware distribution up and running
on one of my computers, and have gone through xf86configure successfully
and generated an XF86Configure file in /etc as the prompts indicated was
appropriate.  The system is a DX4 100 mh 486 with 28 mb of ram, an ATI
Xpression-64 card with 2 mb ram, and an Idek VisionMaster 17" monitor,
all things supported by the system.  Nonetheless, running startx
blanks the screen, totally locks the system (ctrl-alt-bkspace doesn't
help, ctrl-alt-numericminus doesn't help...), and all I can do is
hit the reset button.

The XF86Configure file looks totally correct.

I get the feeling there must have been one last step which the
documentation did not describe...  I'd appreciate hearing (email) from
anybody with any clues on this sort of behavior.

Ted Holden

2. kde & gifs files

3. Help: bizarre shimmer on Mach32...goes away after screen blank

4. It doesnt matter, I still get hung up at LI

5. screen goes blank at login

6. Solaris 2.6/7/8 differences

7. Screen goes blank - Help!!!

8. Compiling source with shell script

9. Screen goes blank after shutdown X or System

10. Screen goes blank, but I don't want

11. screen is blank after exiting X. what's going on?

12. screen blanking won't go away!

13. Screen Blank go Away!