boot troubles with second HD on Sparc5

boot troubles with second HD on Sparc5

Post by Willi Kerne » Sun, 31 Dec 2000 22:24:42



Hi,

I tried to install a second HD (the seagate) on a sparc 5, on RedHat
6.2:

----------------------------------------------------------
scsi:1 host
Vendor: SEAGATE Model: ST34371W SUN4.2G REV:7462
Type: Direct-access             ANSI SCSI revision:02
Detected SCSI disk sda at scsi0, channel 0, id 1, lun 0
Vendor: IBM Model: DPES31080SUN1.05 Rev:S80B
Type: Direct-access             ANSI SCSI revision:02
Detected SCSI disk sda at scsi0, channel 0, id 3, lun 0
scsi: detected 2 scsi disks total.

----------------------------------------------------------
following error during the boot process appears:

----------------------------------------------------------
VFS: Cannot open root device 08:02
Kernel panic: VFS: Unable to mount root fs on 08:02
----------------------------------------------------------
can anyone help me? thanx in advance.
willi

 
 
 

boot troubles with second HD on Sparc5

Post by Henrik Carlqvis » Wed, 03 Jan 2001 03:56:49



> I tried to install a second HD (the seagate) on a sparc 5, on RedHat
> 6.2:

> ----------------------------------------------------------
> scsi:1 host
> Vendor: SEAGATE Model: ST34371W SUN4.2G REV:7462
> Type: Direct-access             ANSI SCSI revision:02
> Detected SCSI disk sda at scsi0, channel 0, id 1, lun 0
> Vendor: IBM Model: DPES31080SUN1.05 Rev:S80B
> Type: Direct-access             ANSI SCSI revision:02
> Detected SCSI disk sda at scsi0, channel 0, id 3, lun 0
> scsi: detected 2 scsi disks total.
> VFS: Cannot open root device 08:02

So you are unable to open 08:02 which is /dev/sda2 where I suppose that
your root partition lives? Reading at the detection of disks we can see
that booth disks (id 1 and id3) are detected as "SCSI disk sda". This is
not good, one of them should probably be sda and the other sdb.

I'm not familiar with Linux on sparc, but I think I recall something
about old sparc machines having SCSI ID 3 becoming SCSI ID 0 which they
were supposed to boot from. Maybe this is giving you some trouble now?
If so, you could try to give the new seagate SCSI ID 4 instead of SCSI
ID 3.

regards Henrik

--
spammer strikeback:


 
 
 

1. HELP: Booting Win95 on second HD from Solaris 2.5 boot manager

Help please...

I have Solaris 2.5 x86 on my first drive.
How can I boot Win95 on my second drive (0x81) ?

Maybe... What should I do in Solaris Configuration to make it work whith
the HD
configured as c0d1 (0x81) so that I can install Win95 HD as primary (0x80)
?

Thanks. Fabio Invernizzi.

2. Promise RAID ATA133 Problems

3. lilo config for dual hd-boot hd->ramdisk-boot?

4. AIX 4.3.1 Compiler version 3.6.4

5. Sparc5 HD busy for no reason

6. Ensoniq Soundscape ISA PnP (modell 2)

7. boot DOS on second hd?

8. Best Linux distribution: where do I get it?

9. Linux: two 540 Mb HD or one 1GB HD

10. Problem Installing second Fat32 HD in dual boot system

11. Boot linux in second HD.

12. Linux on second HD - Boot as first

13. LILO booting tooo slooooooowwwww (second HD)