Missing Disk Information & Inaccurate Temperatures in GKrellM with compiled Kernel v2.4.20

Missing Disk Information & Inaccurate Temperatures in GKrellM with compiled Kernel v2.4.20

Post by ANT.. » Mon, 02 Dec 2002 05:55:39



Hi. I downloaded, configured, compiled, and installed Kernel 2.4.20,
lm_sensors v2.6.5, and GKrellM v1.2.13 recently for my Red Hat Linux
v7.2 box. I think I got almost everything working except:

1. Two inaccurate temperature readings in GKrellM. Sensors command
   shows correct readings:


as99127f-i2c-0-2d
Adapter: SMBus Via Pro adapter at e800
Algorithm: Non-I2C SMBus adapter
VCore 1:   +1.68 V  (min =  +4.08 V, max =  +4.08 V)              
VCore 2:   +1.68 V  (min =  +4.08 V, max =  +4.08 V)              
+3.3V:     +3.28 V  (min =  +2.97 V, max =  +3.63 V)              
+5V:       +4.94 V  (min =  +4.50 V, max =  +5.48 V)              
+12V:     +12.39 V  (min = +10.79 V, max = +13.11 V)              
-12V:     -12.95 V  (min =  -0.00 V, max =  -0.00 V)              
-5V:       -4.91 V  (min =  -0.00 V, max =  -0.00 V)              
fan1:        0 RPM  (min = 3000 RPM, div = 2)                    
fan2:     3214 RPM  (min = 3000 RPM, div = 2)                    
fan3:        0 RPM  (min = 3000 RPM, div = 2)                    
temp1:       +95F  (limit = +140F)                              
temp2:    +132.8F  (limit = +248F, hysteresis = +212F)        
temp3:     +57.2F  (limit = +248F, hysteresis = +212F)        
vid:      +1.650 V
alarms:  
beep_enable:
          Sound alarm enabled

arp-i2c-0-61
Adapter: SMBus Via Pro adapter at e800
Algorithm: Non-I2C SMBus adapter

GKrellM showed (all in F degrees): 95.0 (temp1 -- looks correct), 92.4
(temp2), and 44.6 (temp3). All are factor of 1.0000 (tried to do math
but that didn't work).

2. Missing disk status information in GKrellM (no read and write values).

My computer configuration (primary computer):
http://alpha.zimage.com/~ant/antfarm/about/computers.txt

This is a little off-topic, but how do I turn off the sound alarm feature?

Did I misconfigure something? Thank you in advance.
--
          "Everything tastes better at a picnic... the ants, the sand,
                                                everything." --unknown
  /\___/\


   \ _ /            Remove ANT if replying by e-mail from a newsgroup.
    ( )

 
 
 

1. V2.2.0 & V2.2.2 kernel do not compile on a m68k Amiga A1200

 I have tried to compile linux kernal v2_2_0 and v2_2_2 and get a
compilation error.
 My system is an Amiga A1200 with a Blizzard 1260 and SCSI interface.
 48Mb Ram and approx 5.5Gb of disk space on the SCSI port and .5Gb on
 the IDE port.
 A CDROM and a HP T4000s tape streamer are also on the SCSI port.

 I am running 2_0_36 at present and I would like to upgrade as I am
having trouble getting linux to boot when I have a Zip drive connected
 to the SCSI port.

 On typing make I get the following output.
 Has anyone tried to compile this before and if so how did you
overcome this error.

 Thank you.

 --------------------------------------------------------------------

  gcc -D__KERNEL__ -I/usr/src/linux/include -Wall -Wstrict-prototypes
 -O2 -fomit-frame-pointer -pipe -fno-strength-reduce -ffixed-a2
-m68060
  -c -o init/main.o init/main.c

 /usr/src/linux/include/asm/semaphore.h: In function
`waking_non_zero':
 In file included from /usr/src/linux/include/linux/fs.h:161,
                  from /usr/src/linux/include/linux/capability.h:13,
                  from /usr/src/linux/include/linux/binfmts.h:5,
                  from /usr/src/linux/include/linux/sched.h:8,
                  from /usr/src/linux/include/linux/mm.h:4,
                  from /usr/src/linux/include/linux/slab.h:14,
                  from /usr/src/linux/include/linux/malloc.h:4,
                  from /usr/src/linux/include/linux/proc_fs.h:5,
                  from init/main.c:15:
 /usr/src/linux/include/asm/semaphore.h:61: `owner_depth' undeclared
 (first use this function)
 /usr/src/linux/include/asm/semaphore.h:61: (Each undeclared
identifier
 is reported only once
 /usr/src/linux/include/asm/semaphore.h:61: for each function it
appears in.)
 make: *** [init/main.o] Error 1

2. System name

3. gkrellm and temperature sensors on i815 chipset

4. USB mouse not working with 2.5.66+

5. PPPD v2.1.2 & kernel v2.0.0

6. LinuxPPC on Network Server 700?

7. linux-2.4.20 Kernel Compile Errors?

8. Auto-config proxy on port 8080 with Apache/Squid

9. Prestoserve V2.4.1 to V2.4.2 ?

10. RedHat 7.1 (kernel v2.4.2-2) and Netgear FA311

11. Linux Kernel Information & Install Kernel Script

12. networking in v2.2 vs v2.4 kernels.

13. Problem compiling Kernel with RedHat 5.0 (Linux v2.0.32)