mad 16 sound card interference

mad 16 sound card interference

Post by Mike LaPagli » Sat, 09 Nov 1996 04:00:00



Hello
  Has anyone else observed that some mad16 sound cards experience
interference when data is transferred over the mddem or
if the mouse moves?  I have this problem and wonder
if there might be some setup to fix it.  I know
there must be a way since the noise problem is
not present under windows 95.  Any help is
appreciated
-Mike

 
 
 

mad 16 sound card interference

Post by Derek B. Noonbu » Sun, 10 Nov 1996 04:00:00



> Has anyone else observed that some mad16 sound cards experience
> interference when data is transferred over the mddem or if the mouse
> moves?

I fixed the problem by adding these lines to rc.local:

    /usr/local/bin/mixer line1 0:0
    /usr/local/bin/mixer line2 0:0

(/usr/local/bin/mixer is from snd-util-3.5)

I believe the explanation is that some sound cards don't connect one
or both of the external inputs, so they can pick up noise.  One of
these is probably the CD audio input, which I personally never use.
You may want to try setting just line1 or just line2 to 0 volume.

- Derek

 
 
 

mad 16 sound card interference

Post by Matthew Nobl » Wed, 13 Nov 1996 04:00:00



> Hello
>   Has anyone else observed that some mad16 sound cards experience
> interference when data is transferred over the mddem or
> if the mouse moves?  I have this problem and wonder
> if there might be some setup to fix it.  I know
> there must be a way since the noise problem is
> not present under windows 95.  Any help is
> appreciated
> -Mike

Sounds like an interupt conflict to me, check that the soundcard and
mouse/modem arn't both using the same irq. Mine works fine under linux

Matt

***************************************************************************
*  From    Matthew Noble at Reading University;                           *

*  http://www.fst.rdg.ac.uk/people/pnoble/                                *
***************************************************************************

 
 
 

1. Opti - Mad 16 Pro Sound Card

Hello,
i have an Opti Mad 16 Pro Sound card. I'd like to configure it under
linux RedHat 5.2 Kernel 2.2.2.
I compiled as modules:

Sound card support
OSS sound modules
Generic OPL2/OPL3 FM sysnthesizer support
Microsoft Sound Sistem support
Support for OPTi MAD16 and/or Mozard based cards
FM synthesizer (YM3812/OPL-3) support

I have done depmod -a and the sound demon is active, but doing
modprobe mad16 the system says:

/lib/modules/2.2.2/misc/mad16.o :init_module: Device or resource busy

What can I do now?

Thank you
Domenico Mozzanica

2. Training Kit

3. MAD-16 Sound Card With IDE Sony CDU55E Drive--Installation

4. Recover deleted files?

5. Mad 16 - drives me mad

6. SOHO ISA card

7. Mad 16 Pro / Opti930 sound driver?

8. LinuxConf

9. can't get sound to work....mad 16 (opti 82924 chipset)

10. Mad 16 Pro card and Sony cdu31a

11. Jazz 16 sound card(SB 16 Compatible) Problem

12. 2.2.x PnP sound card (SB 16 / Vibra 16)

13. SB 16 PnP: 8-bit sound works, 16-bit sound broken?