IDE HD "hdc is not a valid block device"?!

IDE HD "hdc is not a valid block device"?!

Post by Chri » Fri, 02 Feb 2001 19:56:32



Hi,

    Probably a really simple answer tho this, but anyway..

I use Mandrake 7.2, up until yesterday evening I had a single 30.7Gb
Maxtor IDE drive (UDMA 66, Master on 1st IDE channel). I had a 3.2Gb
Samsung in one of my other systems and I decided to add it to my
linux box as the master on the second IDE channel. The BIOS picks
it up fine, dos fdisk can see it, when linux is loading it detects
/dec/hdc. If I run the Mandrake installer up to the drive partition
step then it sees both drives, I can even partition hdc and format
it. However when I boot linux and try something like

mount -t ext2 /dev/hdc1 /mnt/local

I get a "not a valid block device" error. fdisk and fcdisk refuse to
even open /dev/hdc and /usr/sbin/diskdrake will only show hda!
Any suggestions would be appreciated..

Chris

 
 
 

IDE HD "hdc is not a valid block device"?!

Post by p43cibmgs-Fran » Sat, 03 Feb 2001 01:56:16



> Hi,
>     Probably a really simple answer tho this, but anyway..
> I use Mandrake 7.2, up until yesterday evening I had a single 30.7Gb
> Maxtor IDE drive (UDMA 66, Master on 1st IDE channel). I had a 3.2Gb
> Samsung in one of my other systems and I decided to add it to my
> linux box as the master on the second IDE channel. The BIOS picks
> it up fine, dos fdisk can see it, when linux is loading it detects
> /dec/hdc. If I run the Mandrake installer up to the drive partition
> step then it sees both drives, I can even partition hdc and format
> it. However when I boot linux and try something like
> mount -t ext2 /dev/hdc1 /mnt/local
> I get a "not a valid block device" error. fdisk and fcdisk refuse to
> even open /dev/hdc and /usr/sbin/diskdrake will only show hda!
> Any suggestions would be appreciated..
> Chris

Have you done a mkfs.ext2 /dev/hdc1 ?  

Tim

 
 
 

IDE HD "hdc is not a valid block device"?!

Post by Chri » Sat, 03 Feb 2001 19:08:15



> > I get a "not a valid block device" error. fdisk and fcdisk refuse to
> > even open /dev/hdc and /usr/sbin/diskdrake will only show hda!
> > Any suggestions would be appreciated..
> Have you done a mkfs.ext2 /dev/hdc1 ?

Nope, but last night I decided to reinstall from scratch (I wanted
to alter the partition structure and I`d only just reinstalled
after something nuked my partition table anyway, no gret problem.)
Now it works perfectly, I guess i had missed something obvious
after all ;)
 
 
 

1. CD-Writer "not a valid block device"

In my system I have an HP CD-Writer Plus 8100 and a Creative DVD-ROM.  
I get the DVD to mount, but everytime I try to mount the CD-R it tells me:

/dev/hdb is not a valid block device

I used the CD-R to install the system, so i know it works.  
The CD-R is the slave device on the primary controller. so it is hdb.
I can't find any reference to this "not a valid block device" anywhere.  

Can anyone help?

2. Linux and HP Pavilion internal modem

3. /dev/fd0 "not a valid block device" ???

4. Apache Problem

5. jaz: "not a valid block device"

6. login function?

7. CD-ROM installs, then "not a valid block device"?

8. raw vs. vxfs filesystems with Informix DB

9. "/dev/cdrom is not a valid block device" in Debian 3.0 Woody

10. "/dev/cdrom1/ is not a valid block device"

11. Help "Not a valid block device"

12. PATCH: eisa reports "0 device" not "0 devices"

13. HELP!: cdrom problem----> hdc not a valid block device