Mitsumi 4X CD & Linux ? (ATAPI)

Mitsumi 4X CD & Linux ? (ATAPI)

Post by Sam Kenda » Mon, 30 Jan 1995 04:25:51



Quote:> Does anybody have the new Mitsumi 4X CD-ROM on his Linux ?

Yes, with Kernel 1.1.81 (need >= 1.1.76).  Works great.

--Sam Kendall

 
 
 

1. 1.1.81 and Mitsumi 4X IDE (ATAPI) CD-ROM problems

I'm having problems getting Linux 1.1.81 to successfully recognize my
Mitsumi 4X IDE (ATAPI) CD-ROM drive.  The drive works fine under DOS
and Windows.

I've read the README.ide in the drivers/block directory.  I've added the
'append "hdc=cdrom"' line to /etc/lilo.conf (and reinstalled lilo).

Here are some excerpts from the /var/adm/messages file:

-------------------------
Jan 18 04:00:43 helix kernel: ide1: hdc: cdrom
.
.
.
Jan 18 04:00:43 helix kernel: hdc: no response
Jan 18 04:00:43 helix kernel: hdc: ATAPI cdrom (?)
Jan 18 04:00:43 helix kernel: ide1: secondary interface on irq 15
Jan 18 04:00:43 helix kernel: ide0: primary interface on irq 14
-------------------------

If I attempt to mount a CD-ROM the machine hangs for a while
(I can switch virtual consoles but cannot type).  If I hit
control-C the 'mount' attempt finally fails (after a minute
or so) and then I can type again.

If I boot DOS first (which loads the DOS IDE driver for the
enhanced IDE card and for the CD-ROM drive) and then do a
warm reboot into Linux, Linux recognizes the CD-ROM drive
and the drive mounts and works fine.

Here is what /var/adm/messages says in that case:

----------------------------------
Jan 18 03:52:25 helix kernel: hdc: FX400_02, ATAPI, CDROM drive
----------------------------------

If I use Linux 1.1.75 with the ide patch applied (and warm boot
to Linux from DOS), here is what /var/adm/messages says:

Jan 18 02:53:50 helix kernel: hdc: XF04_020, ATAPI, CDROM drive

The drive works fine in this case too.

Any ideas on what could be the problem?

Is it more likely a problem with the drive or with the PCI EIDE
card?  I recently helped someone setup up Linux 1.1.75 with IDE
patches and a Mitsumi 4X IDE ATAPI drive on a ZEOS Pantera and
had none of the above-described problems.

My machine has an ASUS P5-90 PCI motherboard.  The EIDE card I'm
using is called "S1363-004 PCI Local Bus Enhanced IDE & Multi
I/O Controller".
--

               World Wide Web: http://www.compbio.caltech.edu/~garnett
"If private encryption is outlawed, then only criminals will have access to
  secure communications."

2. Puzzling AIX issue...

3. ATAPI/Mitsumi CD-ROM 4x Problem...

4. Linux Telephony

5. Problem with Mitsumi ATAPI 4x CD-ROM

6. Solaris to Linux conversion problem: "I just Traversed into a different shell!!!"

7. Toshiba 4x v. Mitsumi 4x CD-ROM

8. HELP!!!!

9. linux, Mitsumi CD-ROM (& SB), & the TA CD-ROM - solved!

10. 4 ide drives & Mitsumi (IDE/ATAPI) CD-ROM via SB

11. Once again(?): Mitsumi 4x ATAPI woes

12. IDE1 ATAPI MITSUMI 4x CDROM -- MASTER OR SERVANT ?

13. Mitsumi 4X speed CD and Linux