SiS 7018 SoundCard Problem with alsa driver.

SiS 7018 SoundCard Problem with alsa driver.

Post by Isaa » Thu, 06 Dec 2001 16:37:54



I have problems with onboard sound card. This is SIS 7018. Mandrake 8.1
seems
install correctly

Doing cat /proc/asound/sndstat I obtain:

Sound Driver:3.8.1a-980706 (ALSA v0.5.11 emulation code)
Kernel: Linux 2.4.8-26mdk
Config Options: 0

Installed drivers:
Type 10: ALSA emulation

Card config:
SiS 7018 PCI audio at 0x3100, irq 11

Audio Devices:
0: Trident 4DWave (DUOLEX)

Synth devices: NOT ENABLED IN CONFIG

Midi devices:
0: MPU-401 (UART)

Timers:
7: system timer

Mixer:
0: 0x49434511 ICE

Doing cat /proc/pci | grep -i audio obtain:

Multimedia Audio Controller: Silicon Integrated Systems [SiS] PCI Audio
Accelerator (rev 2)

In /etc/modules.conf I have:

alias sound-slot-0 snd-card-trident
above snd-card-trident snd-pcm-oss

Load the trident module. The correct module for my sound card.

In  /var/log/messages I have something suspicious

modprobe: modprobe: Cant locate module snd-card-1
modprobe: modprobe: Cant locate module snd-card-2
modprobe: modprobe: Cant locate module snd-card-3
modprobe: modprobe: Cant locate module snd-card-4
modprobe: modprobe: Cant locate module snd-card-5
modprobe: modprobe: Cant locate module snd-card-6
modprobe: modprobe: Cant locate module snd-card-7

But I  attribute this to a probe of numerous modules (alias) to find
one.

All seems ok but when I try to play a sound with alsaplayer or xmms
neither
play the sound. Don't report any error. They begin play but no sound is
heard.
I have quit mute in aumix (this don't save my configuration an I need to
unmute again
each I run aumix) and alsamixer. I have quit artsd server because
possible conflicts. I
have look the irq and this it's ok, the same that in Windows.

Thanks for read me.

PD:My laptop is an Airis. I  will grateful for any posted specially if
you have this
laptop or sound card and you run sound correctly.

 
 
 

SiS 7018 SoundCard Problem with alsa driver.

Post by Isaa » Tue, 11 Dec 2001 19:19:36


Hi guys:

I have quit devfs with devfs=no mount in lilo.conf. I read that this, may
cause that sound card don't work properly. After that the cat
/proc/asound/sndstat is the
same that in the first message. But I have a surprise when I try to execute
alsamixer. This command fails and report the error:

alsamixer:failed to open mixer #0/#0: No such file or directory

alsamixer run correctly with devfs activate. Any trail?.

Thanks

Isaac

 
 
 

1. update on Sis 7018/AC97/Trident sound problem

Last week, I had reported random flakies with my SiS7018-based sound
  subsystem, using the Trident driver.  The problem was that the
  digital parts of the system would spontaneously become horribly
  distorted, and the mixer would be noisy and highly non-linear.
  The remedy was to power-cycle the machine--mere reboot wasn't
  good enough!

I decided a couple of days ago to try recompiling the kernel with
  the TRIDENT driver *compiled-in*, rather than as a loadable module.
  That seems to have cleared up the problems I was having.

I notice that between 2.4.2 and 2.4.17 kernel code, the trident driver
  has been tweaked a fair amount.  I'll try upgrading to 2.4.17 sometime
  soon.
--
----------------------------------------------------------------------
Marcus Leech                             Mail:   Dept 8M70, MS 012, FITZ
Advisor                                  Phone: (ESN) 393-9145  +1 613 763 9145
Security Architecture and Planning       Fax:   (ESN) 393-9435  +1 613 763 9435

2. NIS and NFS

3. newbie sound card problem SiS 7018

4. Help Getting Printer Working

5. Soundrecording with SiS 7018

6. HELP : PS2 mouse - HP Vectra VL series 3 5/90 mouse wont work.

7. sound SiS 7018 help

8. Everex Tape Streamer: Need Help

9. HELP!"!ยง$ Audio SiS 7018 + Mandrake 8.2 !!!

10. SiS 7018 sound card doesn't work, "modprobe trident" failed

11. SIS7012/K7S5A: ALSA, Kernel driver, SIS's driver... best driver choice?

12. ct5880 onboard soundcard and alsa driver

13. ALSA cs4237b soundcard drivers