3Com 3C905, Adaptec 2940W and AMI Bios problems

3Com 3C905, Adaptec 2940W and AMI Bios problems

Post by Tony Mongkolsma » Mon, 06 Oct 1997 04:00:00



Hi,
I've been trying to set up my ethernet card to run under Linux on a
Gateway G6-266.  It's a 3Com 3C905 card.  I've gotten the updated driver

from the Vortex site, and I have got the kernel compiled.  The card is
detected by the kernel but it doesn't work under the rc.inet1 thing.  I
get the common error that my card is not installed or set up properly
and I also get a SIOCSFFLAGS: Try Again error.  I now think that my
problem is that my IRQ of my Adaptec 2940W adapter and 3Com card are
both 9.  However, my American Megatrends Bios editor will not let me set

the IRQ on either card.  Is there any way I can set it up so this card
will work, or any other way to change the setting in the bios?
Thanks for your time,
Tony

 
 
 

3Com 3C905, Adaptec 2940W and AMI Bios problems

Post by Derkjan de Ha » Tue, 07 Oct 1997 04:00:00




Quote:> Hi,
> I've been trying to set up my ethernet card to run under Linux on a
> Gateway G6-266.  It's a 3Com 3C905 card.  I've gotten the updated driver

> from the Vortex site, and I have got the kernel compiled.  The card is
> detected by the kernel but it doesn't work under the rc.inet1 thing.  I
> get the common error that my card is not installed or set up properly
> and I also get a SIOCSFFLAGS: Try Again error.  I now think that my
> problem is that my IRQ of my Adaptec 2940W adapter and 3Com card are
> both 9.  However, my American Megatrends Bios editor will not let me set

> the IRQ on either card.  Is there any way I can set it up so this card
> will work, or any other way to change the setting in the bios?
> Thanks for your time,
> Tony

In your bios you should be able to configure which IRQs and DMA channels
are in use by non-P&P ISA cards. You'll want to check this carefully.
When booting, your mainboard picks free ( = not is use by ISA) IRQs and
assigns them to the cards.
Most probably, the reason why both of your cards have been assigned the same
IRQ is that your mainboard thinks all others are in use by ISA cards.

Hope this helps,

Derkjan de Haan

 
 
 

3Com 3C905, Adaptec 2940W and AMI Bios problems

Post by CNR » Fri, 10 Oct 1997 04:00:00


One way you could do is using a DOS boot disk and the utility provided on
the 3Com disk.
The problem is that you might not able to run the config program. Another
possibility is to remove the net card from the system, boot the computer,
then insert it back and see if still has the same interrupt. If you are
using also a sound card and IDE devices chances are that there is no
interrupt available for the net card.



Quote:> Hi,
> I've been trying to set up my ethernet card to run under Linux on a
> Gateway G6-266.  It's a 3Com 3C905 card.  I've gotten the updated driver

> from the Vortex site, and I have got the kernel compiled.  The card is
> detected by the kernel but it doesn't work under the rc.inet1 thing.  I
> get the common error that my card is not installed or set up properly
> and I also get a SIOCSFFLAGS: Try Again error.  I now think that my
> problem is that my IRQ of my Adaptec 2940W adapter and 3Com card are
> both 9.  However, my American Megatrends Bios editor will not let me set
> the IRQ on either card.  Is there any way I can set it up so this card
> will work, or any other way to change the setting in the bios?

 
 
 

3Com 3C905, Adaptec 2940W and AMI Bios problems

Post by Brent Casavan » Fri, 10 Oct 1997 04:00:00


[snip]

Quote:> Another
> possibility is to remove the net card from the system, boot the computer,
> then insert it back and see if still has the same interrupt.

First, it is _never_ wise to hot-swap cards, at least in run-of-the-mill
PC's.

Second, it won't help. I actually tried this with a 3c905 two weeks ago
(do as I say, not as I do :) and the card was completely ignored. Of
course I was dealing mainly with EISA configuration problems, but
nevertheless I don't know why it would be any better for PCI or ISA.

Brent Casavant

--

http://www.ecn.ou.edu/~bcasavan             | What I say, I remember.
----------------------------------------+ What I do, I know.
Remove despamming agent from address.   |  - Chinese proverb.

 
 
 

3Com 3C905, Adaptec 2940W and AMI Bios problems

Post by Eduardo Romero » Wed, 15 Oct 1997 04:00:00



: One way you could do is using a DOS boot disk and the utility provided on
: the 3Com disk.
: The problem is that you might not able to run the config program. Another
: possibility is to remove the net card from the system, boot the computer,
: then insert it back and see if still has the same interrupt. If you are
: using also a sound card and IDE devices chances are that there is no
: interrupt available for the net card.
:


: > Hi,
: > I've been trying to set up my ethernet card to run under Linux on a
: > Gateway G6-266.  It's a 3Com 3C905 card.  I've gotten the updated driver
: >
: > from the Vortex site, and I have got the kernel compiled.  The card is
: > detected by the kernel but it doesn't work under the rc.inet1 thing.  I
: > get the common error that my card is not installed or set up properly
: > and I also get a SIOCSFFLAGS: Try Again error.  I now think that my
: > problem is that my IRQ of my Adaptec 2940W adapter and 3Com card are
: > both 9.  However, my American Megatrends Bios editor will not let me set
: > the IRQ on either card.  Is there any way I can set it up so this card
: > will work, or any other way to change the setting in the bios?
:

I have the same problem with a Dell OptiPlex GxPro , and the one solution
was to install 2.0.31-pre10 [ in few words , 3c905 have a pci addr that
isn't defined in pci.h in 2.0.30 or before ], when u cat /proc/interrupts ,
this have a both dispositives in a same irq [ 11 in a dell ]

Saludos

--
|Quien haya recorrido los cerros /  /   /     Eduardo N. Romero U.   Ce2Tbo |
|de Valparaiso, habra recorrido /==/|==/        Travolta at Irc and Relay   |
|  el Mundo  (Pablo Neruda)    /  / | / Electronic Engineering Std. at Utfsm|

 
 
 

3Com 3C905, Adaptec 2940W and AMI Bios problems

Post by Peter E. Fr » Fri, 17 Oct 1997 04:00:00



> : One way you could do is using a DOS boot disk and the utility provided on
> : the 3Com disk.

  This is actually a good diagnostic -- the 3COM DOS utility.  I
installed a pair of 905s on a 430FX motherboard, and they constantly
tried to share IRQs (actually, one wasn't properly assigned an IRQ).  If
a card failed the DOS diagnostic, I knew it wasn't going to work in
Linux (it just wouldn't transmit or receive).
  I was able to solve it partially with BIOS "upgrades" (some were
downgrades), but results were inconsistent.  I finally solved it by
magic -- the damn thing just started working.  Go figure.
  Swapping slots may help as well.

Peter E. Fry

 
 
 

1. 3Com 3c905, Adaptec 2940W and AMI Bios

Hi,
I've been trying to set up my ethernet card to run under Linux on a
Gateway G6-266.  It's a 3Com 3C905 card.  I've gotten the updated driver
from the Vortex site, and I have got the kernel compiled.  The card is
detected by the kernel but it doesn't work under the rc.inet1 thing.  I
get the common error that my card is not installed or set up properly
and I also get a SIOCSFFLAGS: Try Again error.  I now think that my
problem is that my IRQ of my Adaptec 2940W adapter and 3Com card are
both 9.  However, my American Megatrends Bios editor will not let me set
the IRQ on either card.  Is there any way I can set it up so this card
will work, or any other way to change the setting in the bios?
Thanks for your time,
Tony

2. Another wget question

3. 3Com 3C905 and Compaq BIOS

4. Resource temporarily unavailable

5. Redhat + Adaptec 2940w card + 3com card

6. Anpassung MTU via IPTABLES

7. Adaptec 2920 and 3Com 3c905 IRQ Conflict?

8. Is it possible to set-up a USB connected HP printer?

9. 3com 3c905 tx vs 3c905-CX-TX

10. AMI bios problems, and other questions.

11. AMI BIOS LBA problem

12. AMI BIOS - Boot to OS/2 gives Linux problems, both On and Off.

13. Power Management problem with AMI BIOS