No Sound from Intel 845 chipset

No Sound from Intel 845 chipset

Post by Banj » Tue, 01 Jul 2003 04:58:51



I have a new Mandrake 9.1 installation
 on an Intel D845PESV motherboard. This
 board has the embedded sound in the 845
 chipset.

 Our sound works great some of the time
 and is silent at other times. This
 seems to be random, and reboots and
 logins do not fix it.

 Sometimes our Quake3 game tells us that
 the device /dev/dsp (which is a symlink
 to /dev/sound/dsp) is busy and it
 then runs silently. Sometimes it
 works OK and we get sound with the
 game.

 I have tried killing the artsd to
 see if that will free up the device,
 but it does not help. I have also tried
 running the app using artsdsp program
 to vector the sound through the mixer,
 but the program simply tells us
 "Your sound card cannot do this."

 Does anybody know what is going on
 with the sound as it is played

 on the 845 chipset?

 Also, if the answer is "Get a sound
 card", can anybody recommend a card
 that is known to work on Mandrake
 9.1.

 Thanks in advance,

 Banjo
 (_)=='=~

 
 
 

No Sound from Intel 845 chipset

Post by horn » Mon, 07 Jul 2003 12:54:41


Banjo scribbled:

Quote:> I have a new Mandrake 9.1 installation
>  on an Intel D845PESV motherboard. This
>  board has the embedded sound in the 845
>  chipset.

<deletia>

On my system with an Intel 810 chipset the following modules are reported by
/sbin/lsmod

i810                   65624  15
snd-mixer-oss           8704   0 (unused)
snd                    23400   0 [snd-mixer-oss]
maestro3               24648   2
soundcore               3332   2 [snd maestro3]
ac97_codec              9568   0 [maestro3]

Hopefully, this will point you in the correct direction.

--
Free Software Foundation (FSF) Associate Member 499
Linux Counter Statistics: UserID 277671
LindowsOS v3.0 (Linux kernel 2.4.19) Compaq Presario 3555 Pentium III