SiS 6326 Graphics & Samsung SyncMaster 3

SiS 6326 Graphics & Samsung SyncMaster 3

Post by Greg » Fri, 11 Feb 2000 04:00:00



I was wondering if anyone out there may be able to help me get the X Server
working on either RedHat 6.1 or Corel Linux.

The PC is an AMD K6 200, with 64mb ram on a PC Chips M590 Mainboard.  The
main board has an integrated SiS 6326 AGP Graphics chip with 8mb Ram.  I am
using a Samsung SyncMaster 3 Low Rad monitor.

With the Red Hat setup I am only able to get a resolution of 1024*768 with 8
bit colour.  This then condenses the screen so only a third of the monitor
is
used.  The monitor can't really handle it!!  Using my windows partition I
can get 800*600 which is ideal and takes up the whole screen.  For some
reason when the Red Hat setup tests my user defined setting for 800*600 it
rejects them every time.  If I force it to use 800*600 the display just
flickers so nothing can be seen.

I then decided to download the latest XFree86 packages including the SVGA
package which is compatible with my card.  However after updating the system
they don't seem to solve the problem.

I then decided to try the Corel distribution, and the same problem exists.
In fact this seems to lock out the keyboard when the Xserver is loaded.  I
can only use it in console.

If any one out there has solved a similar problem or could help I would be
very grateful.  I'd love to junk the windows partition, but if I cant see
the screen it's not going to happen:-(

Many thanks,

Greg.

 
 
 

SiS 6326 Graphics & Samsung SyncMaster 3

Post by Lion » Fri, 11 Feb 2000 04:00:00




Quote:>With the Red Hat setup I am only able to get a resolution of 1024*768 with 8
>bit colour.  This then condenses the screen so only a third of the monitor
>is
>used.  The monitor can't really handle it!!  Using my windows partition I
>can get 800*600 which is ideal and takes up the whole screen.  For some
>reason when the Red Hat setup tests my user defined setting for 800*600 it
>rejects them every time.  If I force it to use 800*600 the display just
>flickers so nothing can be seen.

Try adding the following lines to /etc/X11/XF86Config, under the gfx
device (SiS/SVGA) section:

Option "no_bitblt"
Option "no_imageblt"
Option "sw_cursor"
Option "no_accel"

--
Lion

 
 
 

1. Linux Newbie & SiS 6326 Graphics (SuSE 6.2)

ok, here's my system:

P2 300MHz
64 MB RAM
3GB Windows 98
3GB SuSE Linux 6.2

video card:

SiS 6326 AGP Graphics Card
-8MB Video RAM

I'm trying to run X with KDE 1.1.1
In Windows I can get 1024 x 768 with 24bit Color
and 1280 x 1024 on 16bit, but in KDE, I can only get
up to 800 x 600 in 24bit, and 1024 x 768 in 16bit.
normally, the 16 bit would be enough, but it leaves
window trails and other artifacts when i move
things around on my desktop.

I tried downloading the XSuSE_SiS Patch, referenced in:

http://www.suse.de/XSuSE/XSuSE_E.html

but that didn't work.  Any ideas let me know, thanx in advance,
-DeL

2. Linux kills another monitor 2.1.115

3. SIS 6326 Graphic Card

4. Help!! Fastest network card 100% supported by Linux

5. Graphics Problem on SiS 6326.

6. /dev/console problem (file descriptor refers to VC at time of open, not current VC)

7. SiS 6326 Graphics chipset and Red Hat 5.2

8. Training sources in Washington, DC or Northern Virginia

9. SiS 6326 Daytona graphic card

10. SiS 6326 and SiS 5597 driver problems with X

11. SIS 6326 & X on RH7.2

12. SiS 6326 card & XFree86

13. RedHat 5.2 & SiS-6326